LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Fedora
User Name
Password
Fedora This forum is for the discussion of the Fedora Project.

Notices



Reply
 
Search this Thread
Old 08-05-2005, 09:28 PM   #1
Ray4389
Member
 
Registered: Jul 2004
Location: Chesapeake, VA
Distribution: Fedora Core 4
Posts: 57

Rep: Reputation: 15
No sound recorded from mic Audacity


When I use audactiy and hit record no sound is recorded.

However I know the mic is working. When I speak I can hear myself through my headphones telling me that I do have sound being transmitted.

Settings in alsamixer have the mic turned on and everything. The mic is aparently not muted.

Why might audacity not pick up the sound?
 
Old 08-06-2005, 07:00 AM   #2
bpcomp
LQ Newbie
 
Registered: Oct 2004
Location: Tucson, AZ
Distribution: suse 9.2
Posts: 8

Rep: Reputation: 0
recording sound

On my computer there are two things. First I have to open QAmix and enable the mic from there, then I have to go into Audacity and chose my recording device as the mic.

Hope this helps.
 
Old 08-06-2005, 12:57 PM   #3
Ray4389
Member
 
Registered: Jul 2004
Location: Chesapeake, VA
Distribution: Fedora Core 4
Posts: 57

Original Poster
Rep: Reputation: 15
The only recording device I can choose is mysterious...
it's /dev/dsp

WTF is that?

But my mic is enabled. I did that already.
 
Old 08-06-2005, 04:17 PM   #4
slackwarebilly
Member
 
Registered: Jun 2005
Distribution: !<:Slackware:>!
Posts: 99

Rep: Reputation: 15
Arrow wow...ummm

BTW, /dev/dsp is your sound device (sound card). Have you turned up the mic input slider in audacity? it's over to the right somewhere. at the top and under the toolbar and sound monitor... does this help?

lemme know,

slackwarebilly : D
 
Old 08-07-2005, 12:43 AM   #5
Ray4389
Member
 
Registered: Jul 2004
Location: Chesapeake, VA
Distribution: Fedora Core 4
Posts: 57

Original Poster
Rep: Reputation: 15
Yes I have and it doesn't help.
 
Old 08-12-2005, 11:31 AM   #6
misc
Senior Member
 
Registered: Apr 2003
Distribution: Red Hat + Fedora
Posts: 1,074

Rep: Reputation: 53
In the middle of the Audacity main window, do you see the two sliders for setting output volume and input volume? Right-most of it you should see a combo-box where you can choose the input channel. Choose "Mic" or "Line1" or whatever is appropriate for your audio configuration. If you don't see that combo-box, what do you get for "rpm --query audacity"?
 
Old 08-20-2005, 04:10 PM   #7
sedibr
LQ Newbie
 
Registered: Oct 2003
Location: Sao Paulo, Brazil
Distribution: Fedora Core 3
Posts: 6

Rep: Reputation: 0
Unhappy Did you find any solution?

Hi Tay.

Did you manage to find any solution for this?

I have (apparently) the same condition and the same problem ... :-(
 
Old 08-27-2005, 04:17 AM   #8
Chuckinator
Member
 
Registered: Feb 2005
Distribution: Gentoo
Posts: 34

Rep: Reputation: 15
I also had this problem (although not on Fedora) and found a simple solution: Run alsamixer in a console, press F4 to switch to Capture mode, and make sure the mic level is turned up. Before doing this, I only had the Playback mic level turned up and could hear my voice, but not record it.
 
Old 08-29-2005, 12:26 PM   #9
sedibr
LQ Newbie
 
Registered: Oct 2003
Location: Sao Paulo, Brazil
Distribution: Fedora Core 3
Posts: 6

Rep: Reputation: 0
This solution works

Thanks, this solution really works.

1) run alsamixer
2) F4 - capture mode
3) Enable "capture" volume (on my instalation, that is not a "mic" volume on campture mode).

My environment: Fedora FC4, SB Live! 5.1.
 
Old 08-29-2005, 12:39 PM   #10
misc
Senior Member
 
Registered: Apr 2003
Distribution: Red Hat + Fedora
Posts: 1,074

Rep: Reputation: 53
rpm --query audacity

gives what?
 
Old 08-29-2005, 12:51 PM   #11
sedibr
LQ Newbie
 
Registered: Oct 2003
Location: Sao Paulo, Brazil
Distribution: Fedora Core 3
Posts: 6

Rep: Reputation: 0
More version information

Collected from rpm -q:

alsa-lib-1.0.9rf-2.FC4
alsa-utils-1.0.9rf-2.FC4
audacity-1.2.3-5
 
Old 08-29-2005, 03:50 PM   #12
misc
Senior Member
 
Registered: Apr 2003
Distribution: Red Hat + Fedora
Posts: 1,074

Rep: Reputation: 53
alsa-lib is irrelevant here, as current Audacity doesn't use it, but only OSS. And OSS is kernel level for Audacity, even if ALSA provides the OSS devices. Hence if you select an input source in Audacity (described in an older reply above), the audio channel routing done by ALSA's OSS layer may need to be adjusted with tools like alsamixer.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Could not record any sound from mic using audacity in FC4 sedibr Linux - Software 1 08-11-2006 08:56 PM
Audacity doing crappy with the mic Orgullomoore Linux - Software 4 08-10-2005 09:38 PM
Audacity 1.1.2-3.1 strange distortion when more than one track is recorded MMRush Linux - Software 0 05-08-2005 06:00 AM
audacity help (mic won't work) rejser Linux - Software 3 08-10-2004 01:38 PM
No sound recorded,gv4l. akihandyman Mandriva 0 07-14-2004 09:53 PM


All times are GMT -5. The time now is 10:10 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration