LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Fedora
User Name
Password
Fedora This forum is for the discussion of the Fedora Project.

Notices

Reply
 
Search this Thread
Old 02-11-2006, 09:05 AM   #1
MurX
Member
 
Registered: Oct 2005
Location: London
Distribution: elive e17
Posts: 152

Rep: Reputation: 30
No sound out put, how do I un-mute the sound in FC3?


I have installed FC3 but can not get any sound output. i have tried looking in control Centre but can find anywhere that enables me to un-mute the sound.

It works ok in fc4.

the sound card that I am using is an ESI Julia Pro.
 
Old 02-11-2006, 10:26 AM   #2
spicyed
LQ Newbie
 
Registered: Jan 2006
Location: New Jersey
Distribution: Fedora Core 4, Slackware 10.2
Posts: 29

Rep: Reputation: 15
Try running alsamixer.
 
Old 02-11-2006, 08:18 PM   #3
MurX
Member
 
Registered: Oct 2005
Location: London
Distribution: elive e17
Posts: 152

Original Poster
Rep: Reputation: 30
I ran alsamixer as su and turned up the volume on master but still I get no sound.

BTW how do I adjust the other parameters on alsamixer?

Also, the sound card that alsamixer is showing is the onboard card not the Julia Pro, so how do I change the sound card to Julia pro?
 
Old 02-12-2006, 10:23 AM   #4
Gethyn
Member
 
Registered: Aug 2003
Location: UK
Distribution: (X)Ubuntu 10.04/10.10, Debian 5, CentOS 5
Posts: 900

Rep: Reputation: 32
Unless you need the onboard sound for some reason, I would advise disabling it in the BIOS. Some sound cards have a glitch where you need to mute some channels if you aren't using them. Just to check the obvious, you do have your speakers plugged into the onboard sound card at the moment, if that's the one FC is using? If they're plugged into the card that isn't being used, then it should be no surprise that there's no sound...
 
Old 02-12-2006, 01:10 PM   #5
MurX
Member
 
Registered: Oct 2005
Location: London
Distribution: elive e17
Posts: 152

Original Poster
Rep: Reputation: 30
OK Gethyn, I disabled the on-board sound via the bios and I get some messages at boot saying that a device no longer exists. That is to be expected really.

regarding the speakers; they are plugged into the ESI Julia Pro Soundcard, which FC3 does nto seem to be able to see. So I am not surprized that there is no sound out. How o I get FC 3 to recognise the Soundcard?
 
Old 02-14-2006, 05:12 AM   #6
Gethyn
Member
 
Registered: Aug 2003
Location: UK
Distribution: (X)Ubuntu 10.04/10.10, Debian 5, CentOS 5
Posts: 900

Rep: Reputation: 32
From a quick hunt on Google, it looks like there might not be a driver for this under Linux. Look here and here.

I'd try running the Soundcard Detection program (I expect you've already done this though). If that doesn't work, it might be worth switching the soundcard to a different PCI slot - sometimes I've found one PCI slot fails for unknown reasons, but cards work OK when they are switched to a different slot.

If neither of those work, you may have to go back to the onboard sound I'm afraid.
 
Old 02-14-2006, 07:23 AM   #7
MurX
Member
 
Registered: Oct 2005
Location: London
Distribution: elive e17
Posts: 152

Original Poster
Rep: Reputation: 30
Thanks for those links Gethyn.

I can understand your point about drivers but, the card works fine when I boot up in FC4! So is there some way of using the driver that FC4 uses?

If that is the case then can some one advise me on exactly how to do this, which files do I copy from my FC4 install and how do I get FC3 to use them?

I will also try moving the card to another slot.

Incidently, how do you run a soundcard detection prgoram? I have never done this before.
 
Old 02-14-2006, 12:15 PM   #8
Gethyn
Member
 
Registered: Aug 2003
Location: UK
Distribution: (X)Ubuntu 10.04/10.10, Debian 5, CentOS 5
Posts: 900

Rep: Reputation: 32
Oops! Sorry, I forgot that you mentioned that the card works OK in FC4. Moving the card to a different slot is unlikely to make any difference in that case.

In KDE, you can find the Soundcard Detection program on the main menu, under System Settings. Alternatively, as root, run 'system-config-soundcard'. I hope that sorts out the problem, because anything more complicated is beyond me to figure out! One last thought does occur - have you tried updating ALSA in FC3? Something like 'yum update alsa*' might do the trick, if you're not in the habit of updating regularly.
 
Old 02-14-2006, 05:35 PM   #9
MurX
Member
 
Registered: Oct 2005
Location: London
Distribution: elive e17
Posts: 152

Original Poster
Rep: Reputation: 30
I tried soundcard detection and all it does is try to play a sound, and I get no sound.

I had alook in hardware browser and I can see the soundcard from there both in FC3 and FC4.

I am now trying to update alsa for FC3 using yum update alsa. Will report back in the morning.
 
Old 02-14-2006, 05:39 PM   #10
MurX
Member
 
Registered: Oct 2005
Location: London
Distribution: elive e17
Posts: 152

Original Poster
Rep: Reputation: 30
I ran te soundcard detection and all it does is try and play a sound, I still get no sound.

In Hardware borwser I can see the SC both in FC3 and FC4.

I tried to update also by doing yum update alsa and I get the following.

Setting up Update Process
Setting up Repos
base 100% |=========================| 1.1 kB 00:03
updates-released 100% |=========================| 951 B 00:00
Reading repository metadata in from local files
primary.xml.gz 100% |=========================| 797 kB 00:55
MD Read : ################################################## 2623/2623
base : ################################################## 2622/2622
primary.xml.gz 100% |=========================| 342 kB 00:01
MD Read : ################################################## 910/910
updates-re: ################################################## 910/910
Could not find update match for alsa
No Packages marked for Update/Obsoletion

What next?
 
Old 02-15-2006, 06:19 AM   #11
Gethyn
Member
 
Registered: Aug 2003
Location: UK
Distribution: (X)Ubuntu 10.04/10.10, Debian 5, CentOS 5
Posts: 900

Rep: Reputation: 32
Try comparing the files /etc/sysconfig/hwconf and /etc/modprobe.conf on the two installs. These both should have a section referring to the soundcard. Might be worth posting discrepancies up here. I don't know if copying the relevant sections from your FC4 install into your FC3 install will help though, as some things may have changed, and the files may be auto-generated anyway.

I don't know the name of the relevant packages to update in yum, but you could always try 'yum update' or 'yum --exclude kernel* update' (use the second if you don't want to update the kernel, which sometimes breaks things). This should update everything, including the relevant parts of ALSA. It might take a while if you haven't updated for a long time though.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
sound starts up as mute... seaking Linux - Newbie 12 10-18-2005 07:54 AM
Es1869 Sound Card: Mute gani Slackware 15 09-26-2004 10:14 PM
mute sound alsa mixer - used to work TroelsSmit Linux - Newbie 4 09-02-2004 12:39 PM
Mute KDE startup sound? prompt Linux - Software 2 06-04-2004 03:33 PM
Why is this sound card only 1/2 mute? ONEderer Linux - General 0 01-24-2004 09:07 PM


All times are GMT -5. The time now is 09:02 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration