LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Fedora (http://www.linuxquestions.org/questions/fedora-35/)
-   -   no sound in Fedora 8 "PULSEAUDIO: Unable to connect-" using onboard Optical spdif (http://www.linuxquestions.org/questions/fedora-35/no-sound-in-fedora-8-pulseaudio-unable-to-connect-using-onboard-optical-spdif-625174/)

Legolas327 03-02-2008 01:53 PM

no sound in Fedora 8 "PULSEAUDIO: Unable to connect-" using onboard Optical spdif
 
I have read many threads and still not sure what to do. This is a newly built and loaded computer and after upgrades. I have onboard sound MCP55 HDA intel. I am trying to use the spdif optical out. I get nothing. I have an other computer same FD8 OS but it has a audigy z-2 sound card running spdif out (not optical) and it works just fine. If you can help please do. I am out of ideas and not sure what to look for to correct the issue?

Code:

[root@GraysNew ~]# uname -a
Linux GraysNew 2.6.23.15-137.fc8 #1 SMP Sun Feb 10 17:03:13 EST 2008 x86_64 x86_64 x86_64 GNU/Linux

When I run system-config-soundcard I get this in the scsrun.log. First big clue is the "PULSEAUDIO: Unable to connect: Connection refused" Why I don't know?

Code:

------- System Config Soundcard Log --------
Sun Mar  2 09:53:30 EST 2008

Playing WAVE '/usr/share/system-config-soundcard/sound-sample.wav' : Signed 16 bit Little Endian, Rate 44100 Hz, Stereo
*** PULSEAUDIO: Unable to connect: Connection refused
amixer: Mixer attach default error: Connection refused
ProbeCards, method =  hal
--------- Card 0 --------
Active 1
Vendor: nVidia Corporation
Model: MCP55 High Definition Audio
Driver: snd-hda-intel

here is my aplay -L listing (note the null on the digital out):

Code:

[root@GraysNew ~]# aplay -L
front:CARD=NVidia,DEV=0
    HDA NVidia, ALC882 Analog
    Front speakers
surround40:CARD=NVidia,DEV=0
    HDA NVidia, ALC882 Analog
    4.0 Surround output to Front and Rear speakers
surround41:CARD=NVidia,DEV=0
    HDA NVidia, ALC882 Analog
    4.1 Surround output to Front, Rear and Subwoofer speakers
surround50:CARD=NVidia,DEV=0
    HDA NVidia, ALC882 Analog
    5.0 Surround output to Front, Center and Rear speakers
surround51:CARD=NVidia,DEV=0
    HDA NVidia, ALC882 Analog
    5.1 Surround output to Front, Center, Rear and Subwoofer speakers
surround71:CARD=NVidia,DEV=0
    HDA NVidia, ALC882 Analog
    7.1 Surround output to Front, Center, Side, Rear and Woofer speakers
iec958:CARD=NVidia,DEV=0
    HDA NVidia, ALC882 Digital
    IEC958 (S/PDIF) Digital Audio Output
null
    Discard all samples (playback) or generate zero samples (capture)

Here is my amixer list:

Code:

[root@GraysNew ~]# amixer
Simple mixer control 'Master',0
  Capabilities: pvolume pswitch pswitch-joined
  Playback channels: Front Left - Front Right
  Limits: Playback 0 - 65536
  Mono:
  Front Left: Playback 49088 [75%] [on]
  Front Right: Playback 49088 [75%] [on]
Simple mixer control 'Capture',0
  Capabilities: cvolume cswitch cswitch-joined
  Capture channels: Front Left - Front Right
  Limits: Capture 0 - 65536
  Front Left: Capture 65536 [100%] [off]
  Front Right: Capture 65536 [100%] [off]

Here is the asound version:

Code:

[root@GraysNew ~]# cat /proc/asound/version
Advanced Linux Sound Architecture Driver Version 1.0.15 (Tue Nov 20 19:16:42 2007 UTC).

Here is my asound.conf file:

Code:

[root@GraysNew ~]# cat /etc/asound.conf
#Generated by system-config-soundcard
#If you edit this file, don't run system-config-soundcard,
#all your changes here could be lost.
#SWCONF
#DEV 1
defaults.pcm.card 0
defaults.pcm.device 1
defaults.ctl.card 0

Here is my sysconfig/hwconf listing for audio:

Code:

class: AUDIO
bus: PCI
detached: 0
driver: snd-hda-intel
desc: "nVidia Corporation MCP55 High Definition Audio"
vendorId: 10de
deviceId: 0371
subVendorId: 10de
subDeviceId: c55e
pciType: 1
pcidom:    0
pcibus:  0
pcidev:  f
pcifn:  1

Code:

[root@GraysNew ~]# cat /proc/asound/pcm
00-02: ALC882 Analog : ALC882 Analog : capture 2
00-01: ALC882 Digital : ALC882 Digital : playback 1 : capture 1
00-00: ALC882 Analog : ALC882 Analog : playback 1 : capture 2

Here is my lspci -vn:
Code:

[root@GraysNew ~]#  clr; lspci -v |grep -iC 10 audio
00:0f.1 Audio device: nVidia Corporation MCP55 High Definition Audio (rev a2)
        Subsystem: nVidia Corporation Unknown device c55e
        Flags: bus master, 66MHz, fast devsel, latency 0, IRQ 20
        Memory at cfff0000 (32-bit, non-prefetchable) [size=16K]
        Capabilities: [44] Power Management version 2
        Capabilities: [50] Message Signalled Interrupts: Mask+ 64bit+ Queue=0/0 Enable-
        Capabilities: [6c] HyperTransport: MSI Mapping Enable- Fixed+
        Kernel driver in use: HDA Intel
        Kernel modules: snd-hda-intel

Not sure what to make of this:
Quote:

Subsystem: nVidia Corporation Unknown device c55e
My lsmod output:

Code:

[root@GraysNew ~]# lsmod |grep snd
snd_usb_audio          95169  0
snd_usb_lib            24001  1 snd_usb_audio
snd_rawmidi            28865  1 snd_usb_lib
snd_hda_intel        361577  4
snd_seq_dummy          11461  0
snd_seq_oss            37313  0
snd_seq_midi_event    15041  1 snd_seq_oss
snd_seq                56673  5 snd_seq_dummy,snd_seq_oss,snd_seq_midi_event
snd_seq_device        15061  4 snd_rawmidi,snd_seq_dummy,snd_seq_oss,snd_seq
snd_pcm_oss            45889  0
snd_mixer_oss          22721  2 snd_pcm_oss
snd_pcm                80201  3 snd_usb_audio,snd_hda_intel,snd_pcm_oss
snd_timer              27721  2 snd_seq,snd_pcm
snd_page_alloc        16465  2 snd_hda_intel,snd_pcm
snd_hwdep              16073  2 snd_usb_audio,snd_hda_intel
snd                    60137  17 snd_usb_audio,snd_rawmidi,snd_hda_intel,snd_seq_oss,snd_seq,snd_seq_device,snd_pcm_oss,snd_mixer_oss,snd_pcm,snd_timer,snd_hwdep
soundcore              15073  2 snd

Here is a listing of installed alsa software:
Code:

[root@GraysNew ~]# clr; yum list installed |grep alsa
/root
alsa-lib.x86_64                          1.0.15-1.fc8          installed
alsa-lib.i386                            1.0.15-1.fc8          installed
alsa-lib-devel.x86_64                    1.0.15-1.fc8          installed
alsa-lib-devel.i386                      1.0.15-1.fc8          installed
alsa-oss.x86_64                          1.0.14-3.fc8          installed
alsa-oss-devel.i386                      1.0.14-3.fc8          installed
alsa-oss-devel.x86_64                    1.0.14-3.fc8          installed
alsa-oss-libs.x86_64                    1.0.14-3.fc8          installed
alsa-oss-libs.i386                      1.0.14-3.fc8          installed
alsa-plugins-jack.x86_64                1.0.15-2.fc8          installed
alsa-plugins-oss.x86_64                  1.0.15-2.fc8          installed
alsa-plugins-pulseaudio.x86_64          1.0.15-2.fc8          installed
alsa-plugins-samplerate.x86_64          1.0.15-2.fc8          installed
alsa-plugins-upmix.x86_64                1.0.15-2.fc8          installed
alsa-plugins-vdownmix.x86_64            1.0.15-2.fc8          installed
alsa-tools.x86_64                        1.0.12-4.fc7          installed
alsa-utils.x86_64                        1.0.15-1.fc8          installed
alsamixergui.x86_64                      0.9.0-0.3.rc1.fc8.2    installed
bluez-utils-alsa.x86_64                  3.20-6.fc8            installed

Here is a listing of my pulseaudio installed software:
Code:

akode-pulseaudio.x86_64                  2.0.2-4.fc8            installed
alsa-plugins-pulseaudio.x86_64          1.0.15-2.fc8          installed
kde-settings-pulseaudio.noarch          3.5-36.fc8.1          installed
pulseaudio.x86_64                        0.9.8-5.fc8            installed
pulseaudio-core-libs.x86_64              0.9.8-5.fc8            installed
pulseaudio-esound-compat.x86_64          0.9.8-5.fc8            installed
pulseaudio-libs.i386                    0.9.8-5.fc8            installed
pulseaudio-libs.x86_64                  0.9.8-5.fc8            installed
pulseaudio-libs-devel.i386              0.9.8-5.fc8            installed
pulseaudio-libs-devel.x86_64            0.9.8-5.fc8            installed
pulseaudio-libs-glib2.x86_64            0.9.8-5.fc8            installed
pulseaudio-libs-glib2.i386              0.9.8-5.fc8            installed
pulseaudio-libs-zeroconf.i386            0.9.8-5.fc8            installed
pulseaudio-libs-zeroconf.x86_64          0.9.8-5.fc8            installed
pulseaudio-module-bluetooth.x86_64      0.9.8-5.fc8            installed
pulseaudio-module-gconf.x86_64          0.9.8-5.fc8            installed
pulseaudio-module-jack.x86_64            0.9.8-5.fc8            installed
pulseaudio-module-lirc.x86_64            0.9.8-5.fc8            installed
pulseaudio-module-x11.x86_64            0.9.8-5.fc8            installed
pulseaudio-module-zeroconf.x86_64        0.9.8-5.fc8            installed
pulseaudio-utils.x86_64

Help would be greatly appreciated. I'm thinking different driver??? I have read posts about SElinux blocking but did not understand how to check or fix?

Legolas

LinuxNewbie999 03-03-2008 12:25 AM

My Fedora8 also has no sound... When i playing a music file there's no sound... I tried configure volume control but still no sound. But some times it sounds...zzz

LinuxNewbie999 03-03-2008 12:27 AM

My Fedora 8 also no sound. but some time it sounds...z.zzz I tried configure the volume control but smae thing.. hmmm,, What went wrong??

jfraymondpa 03-03-2008 03:13 PM

I get choppy sound with VLC and no sound with XINE trying to play DVDs
Yet I get perfect sound with JUK playing CDs.
Flash and Realplayer clips from the news sites works fine.

Simon Bridge 03-04-2008 01:55 AM

Quote:

Originally Posted by LinuxNewbie999
When i playing a music file there's no sound

Be specific - what kind of music file?

What makes you think this problem is related to OP?

Quote:

Originally Posted by jfraymondpa
I get choppy sound with VLC and no sound with XINE trying to play DVDs

You have been reconfiguring the default av setup - how did you install xine? What did you do to enable DVD playback? Which formats are we talking about? And - what makes you think this problem is related to OP?

@OP: make sure your output is enabled. In gnome, rt-click the volume conrol applet and select "open volume control" - make sure your desired output is checked.

I'm checking your errors and logs. Do you get sound on the other outputs?

LinuxNewbie999 03-04-2008 07:59 AM

Problem fixed after i plugin the headphone. I do not know how it doesn't sounds on laptop itself..

Legolas327 03-04-2008 03:15 PM

Hey Simon! Thanks for looking at this. Which question is addressed to me (Legolas327)?

jfraymondpa 03-05-2008 09:56 AM

Quote:

Originally Posted by Simon Bridge (Post 3077393)
Be specific - what kind of music file?

What makes you think this problem is related to OP?

You have been reconfiguring the default av setup - how did you install xine? What did you do to enable DVD playback? Which formats are we talking about? And - what makes you think this problem is related to OP?

@OP: make sure your output is enabled. In gnome, rt-click the volume conrol applet and select "open volume control" - make sure your desired output is checked.

Simon --

I was running FC 6/KDE, all was working fine. I then upgraded to FC 8/ KDE and lost the sound then. There was no hardware change just the upgrade.

For music, both Ogg and MP3 files, as well as just trying to play Audio CDs.

Xine was installed using Yum. I didn't do anyting to enable DVD, just selected it from Xine. Yes I have been reconfiguring the sound trying to get it to work.

Well anyway it's a moot point now, as I was trying to remove a software package I hosed my system and so I loaded FC 8 /Gnome and I have sound now.
When I have time I'll put in KDE and try again.

-- John

Simon Bridge 03-30-2008 07:13 PM

Continuing in new thread by OP.

@LinuxNewbie999: how did you get on, that last post was a bit confusing?

lovenemesis 04-07-2008 05:54 PM

Check this one I posted, it might be help.

Make sure you put the correct value after "model=", for ALC882 it only has:

3stack-dig 3-jack with SPDIF I/O
6stack-dig 6-jack digital with SPDIF I/O
arima Arima W820Di1
targa Targa T8, MSI-1049 T8
asus-a7j ASUS A7J
asus-a7m ASUS A7M
macpro MacPro support
mbp3 Macbook Pro rev3
imac24 iMac 24'' with jack detection
w2jc ASUS W2JC
auto auto-config reading BIOS (default)

Refer to /usr/share/doc/kernel-doc-2.6.23/Documentation/sound/alsa/ALSA-Configuration.txt for more details.

PS: Kernel 2.6.24 are available for Fedora 8 :)

Legolas327 04-08-2008 08:58 PM

lovenemesis wrote:

Quote:

Make sure you put the correct value after "model=", for ALC882 it only has:

3stack-dig 3-jack with SPDIF I/O
6stack-dig 6-jack digital with SPDIF I/O
arima Arima W820Di1
targa Targa T8, MSI-1049 T8
asus-a7j ASUS A7J
asus-a7m ASUS A7M
macpro MacPro support
mbp3 Macbook Pro rev3
imac24 iMac 24'' with jack detection
w2jc ASUS W2JC
auto auto-config reading BIOS (default)
How do I know which one?
Quote:

3stack-dig 3-jack with SPDIF I/O
Or
Quote:

6stack-dig 6-jack digital with SPDIF I/O
And I could not find the file referenced below. I did searches but nothing found:

Quote:

Refer to /usr/share/doc/kernel-doc-2.6.23/Documentation/sound/alsa/ for more details.
I do have a file called /usr/share/doc/alsa-lib-1.0.15/asoundrc.txt

Gray

lovenemesis 04-09-2008 02:39 AM

Well, I forget the default installation won't include kernel-doc.

You can get that reference via:
yum install kernel-doc

It probably nobody knows which option fits you. I am running an ASUS laptop but I have to put "model=lenovo" for my ALC861VD to get audio support.

Just try, there're not too much. :)

But remember turn the volume to MAX via your mixer provided by the Desktop Environment(e.g. KMixer for KDE).

I strongly suggest you perform an update before all of these:
yum update

rkemp 07-27-2009 09:58 PM

I know this is an old thread, but in case someone looking for the solution in Fedora Core 11, try

yum erase kde-settings-pulseaudio xine-lib-pulseaudio
alsa-plugins-pulseaudio

Then run alsamixer from terminal and unmute IEC95B or something similar


All times are GMT -5. The time now is 09:05 PM.