LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Fedora
User Name
Password
Fedora This forum is for the discussion of the Fedora Project.

Notices

Reply
 
Search this Thread
Old 11-26-2009, 02:57 PM   #1
ursusca
Member
 
Registered: Sep 2008
Location: Toronto, ON, Canada
Distribution: Gentoo, RHEL (Fedora, CentOS, OEL), Ubuntu, FreeBSD, Solaris 10
Posts: 170

Rep: Reputation: 34
No sound after ugrade to Fedora 12 from Fedora 11


Hello everyone,

I've upgraded to Fedora 12 from Fedora 11 using preupgrade utility.
Now I have no sound but microphone works fine. Any ideas?

Code:
lspci | grep Audio
00:1b.0 Audio device: Intel Corporation 82801G (ICH7 Family) High Definition Audio Controller (rev 01)

amixer
Simple mixer control 'Master',0
  Capabilities: pvolume pswitch pswitch-joined
  Playback channels: Front Left - Front Right
  Limits: Playback 0 - 65536
  Mono:
  Front Left: Playback 93389 [143%] [on]
  Front Right: Playback 93389 [143%] [on]
Simple mixer control 'Capture',0
  Capabilities: cvolume cswitch cswitch-joined
  Capture channels: Front Left - Front Right
  Limits: Capture 0 - 65536
  Front Left: Capture 98304 [150%] [on]
  Front Right: Capture 98304 [150%] [on]

arecord -l
**** List of CAPTURE Hardware Devices ****
card 0: Intel [HDA Intel], device 0: AD198x Analog [AD198x Analog]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
 
Old 11-27-2009, 03:41 PM   #2
ursusca
Member
 
Registered: Sep 2008
Location: Toronto, ON, Canada
Distribution: Gentoo, RHEL (Fedora, CentOS, OEL), Ubuntu, FreeBSD, Solaris 10
Posts: 170

Original Poster
Rep: Reputation: 34
1. I've removed pulseaudio
Code:
yum remove pulseaudio
restarted computer and it helped.
2. I've installed pulseaudio again
Code:
yum install pulseaudio alsa-plugins-pulseaudio pulseaudio-esound-compat pulseaudio-libs pulseaudio-libs-glib2 pulseaudio-module-zeroconf pulseaudio-libs-zeroconf xmms-pulse pulseaudio-module-gconf wine-pulseaudio xine-lib-pulseaudio pulseaudio-utils pulseaudio-module-bluetooth gst-mixer padevchooser paman paprefs pavucontrol pavumeter
I've got sound too but skype didn't work properly:no sound, microphone works only.
3.I've removed pulseaudio again. I've got sound and skype woks properly.

I can't understand what is my problem now... skype or pulseaudio?

Please help me out on this,
Thanks in anticipation
 
Old 11-28-2009, 02:39 PM   #3
toddbailey
LQ Newbie
 
Registered: Jul 2004
Location: seattle
Posts: 16

Rep: Reputation: 1
you won't like my fix but after several days of frustration of the bugs in F12 I reinstalled F11. Sorry to say this release wasn't ready to be called a release version.


Anyway I too had lost sound and the more I did to configure the machine the worse the crashes occured.

now I have sound again. and more functionality like networking always working.


I give F12 another 3 to 6 months of user acceptance testing before I attempt another install.
 
Old 12-01-2009, 02:54 PM   #4
ursusca
Member
 
Registered: Sep 2008
Location: Toronto, ON, Canada
Distribution: Gentoo, RHEL (Fedora, CentOS, OEL), Ubuntu, FreeBSD, Solaris 10
Posts: 170

Original Poster
Rep: Reputation: 34
Hello toddbailey,
thanks for replying to me.

Today I've updated the system. Several pulseaduo packages was installed during updating process. I've ran
Code:
yum install pulseaudio alsa-plugins-pulseaudio pulseaudio-esound-compat pulseaudio-libs pulseaudio-libs-glib2 pulseaudio-module-zeroconf pulseaudio-libs-zeroconf xmms-pulse pulseaudio-module-gconf wine-pulseaudio xine-lib-pulseaudio pulseaudio-utils pulseaudio-module-bluetooth gst-mixer padevchooser paman paprefs pavucontrol pavumeter
again.

My problem is gone :-)
 
Old 12-02-2009, 09:42 PM   #5
michael.guerrero
LQ Newbie
 
Registered: Oct 2006
Distribution: Fedora Core
Posts: 21

Rep: Reputation: 1
I still have no sound.
 
Old 12-02-2009, 09:49 PM   #6
michael.guerrero
LQ Newbie
 
Registered: Oct 2006
Distribution: Fedora Core
Posts: 21

Rep: Reputation: 1
Oh my god...I installed the Pulse Audio volume control and never checked it. When I went to look at it the audio channel was muted. This isn't the Alsa mixer, this is the Pulse Audio Volume Control.

In KDE, Applications > Multimedia > Volume Control.

That was dumb.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
No user sound following upgrade from Fedora 9 to Fedora 10. gzickert Fedora 1 12-08-2008 01:07 PM
Fedora Core 5 with Sound Blaster NX USB driver fails to sound maybi7 Linux - Hardware 1 10-26-2006 03:31 PM
http://download.fedora.us/fedora/fedora/3/i386/RPMS.os broken! caps_phisto Fedora 3 02-05-2005 04:16 PM
Sound Card on Fedora Core 2 only playing test sound silverado0103 Linux - Hardware 0 07-29-2004 03:23 PM
Fedora Core 2 = No sound / Fedora 1 = sound? carlosinfl Fedora 4 06-22-2004 12:28 PM


All times are GMT -5. The time now is 10:42 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration