LinuxQuestions.org
View the Most Wanted LQ Wiki articles.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Fedora
User Name
Password
Fedora This forum is for the discussion of the Fedora Project.

Notices

Reply
 
Search this Thread
Old 09-30-2005, 09:06 PM   #1
xbill311x
Member
 
Registered: Mar 2005
Location: Delaware
Distribution: Fedora Core 4
Posts: 93

Rep: Reputation: 15
NFS Locking.............FAILED


Hi all,

I have recently upgraded to Fedora Core 4. Now when I shutdown my machine, I get something to the effect of:

Shutting down NFS Locking.............FAILED

Everything else passes though.

Anyone else had this?

Thanks in advance

Bill

PS - what is NFS Locking anyway?

 
Old 11-26-2005, 01:16 AM   #2
majara
Member
 
Registered: Apr 2005
Location: Burgos (Spain)
Distribution: Fedora Core 4
Posts: 46

Rep: Reputation: 15
With FC4 I get the same advise, but I don't know what does it mean.

Anybody can help us?

Saludos.
 
Old 11-28-2005, 03:55 AM   #3
KTheorem
LQ Newbie
 
Registered: Nov 2005
Location: Vista, CA, USA
Distribution: Fedora 12
Posts: 24

Rep: Reputation: 16
My guess would be that you are not using NFS and so unlocking it would do nothing. It's just complaining that there is nothing to unlock.

Could be wrong about this but that's all that makes sense to me.
 
Old 11-28-2005, 06:11 AM   #4
mokele
Member
 
Registered: Jan 2005
Location: Puerto Rico
Distribution: Slackware 13
Posts: 146

Rep: Reputation: 15
Under slackware you can try commenting the `locked' line in
/etc/hosts.allow and /etc/hosts.deny. That might help. But
if you start-up scripts are calling the NFS daemon, then you
might need this line. If you are sharing files from that PC I suggest
you read this and particularly this

Saludos
 
Old 11-28-2005, 12:51 PM   #5
Gethyn
Member
 
Registered: Aug 2003
Location: UK
Distribution: (X)Ubuntu 10.04/10.10, Debian 5, CentOS 5
Posts: 900

Rep: Reputation: 32
Under KDE, if you go to the main menu, System Settings->Server Settings->Services (or type system-config-services at a prompt as root), you can disable NFS locking. I don't know exactly what it is, but it relates to the network file system (NFS), so if you aren't using that you don't need it.

In the Service Configuration window that comes up, just untick the box that says nfslock in the left window and click save. You might also want to do this for runlevel 3.

Hope it helps!
 
Old 11-28-2005, 01:04 PM   #6
travellers
LQ Newbie
 
Registered: Jun 2005
Posts: 16

Rep: Reputation: 0
I did the same thing by going to the services and deselecting nfslock. Then I shut down the system. The error " Stopping NFS Locking failed" still come up. This error doesn't affect you to start up or shut down your Linux system. But the red error sign make me uphappy with the system. Who can provide more info and ways to fix it?
 
Old 11-28-2005, 05:44 PM   #7
Mad Scientist
Member
 
Registered: May 2003
Posts: 167

Rep: Reputation: 30
NFS is the network file system, and it is used to remotely access disk space. For instance, I use NFS in the computer lab that I administer. We have one file server which allows all the other computers to mount the "/home" directory, where all my users put their mission critical data.

If you are not using NFS, you can just disable all NFS services, something like

Code:
chkconfig --level 2345 nfs off
chkconfig --level 2345 nfslock off
Starting with the next time you boot your computer, you shouldn't see notices about the NFS service any more.
 
Old 11-29-2005, 11:00 AM   #8
travellers
LQ Newbie
 
Registered: Jun 2005
Posts: 16

Rep: Reputation: 0
Mad Scientist:

Thanks for your input. I have read some of the threads that gave me different approaches to fix this problem such as check /etc/init.d/nfslock to see what it does, Or go to /etc/rc5.d to rm S57netfs, K57netfs, S20nfs, K20nfs, S86nfslock, K86nfslock, or do chkconfig --del nfs. I also read some papers how to config NFS on server and client.

My current system with FC4 is a testing server. There is no any client will access and mount file system on it. I have checked /etc/rc5.d/, I even do not have S57netfs, K57netfs, S20nfs, S86nfslock, K86nfslock files. But I do have K20nfs over there. When I boot system, I can see that starting NFS stated OK. Does this mean that NFS locking has been started whth the system booting? Why can not system automatically stopping NFS locking? I do think your way might work for this problem. I just want to make sure this is at least the better way than others. Please give me more tips on this. Thanks a lot.
 
Old 11-29-2005, 04:23 PM   #9
Mad Scientist
Member
 
Registered: May 2003
Posts: 167

Rep: Reputation: 30
All of those approaches that you list are variants of the cleaner method I gave you, the method of using "chkconfig --level". If you look in /etc/rc.d/rc5.d, you will notice all the elements starting with "S" or "K" are links to things in /etc/init.d. The "S" means these services will be started. The "K" means these services will be killed (or not started).

For whatever reason, NFS services are spread amongst netfs, nfs, and nfslock. I don't know why they're split that way, but I'm sure there's a good reason. If you don't need any of them (which it sounds like you don't), then just do a

Code:
chkconfig --level 2345 netfs off
chkconfig --level 2345 nfs off
chkconfig --level 2345 nfslock off
It will just create "K"-type entries in your /etc/rc.d/rcX.d directories, and you won't have to worry about those services starting up during boot.
 
Old 11-30-2005, 09:49 AM   #10
travellers
LQ Newbie
 
Registered: Jun 2005
Posts: 16

Rep: Reputation: 0
Mad Scientist:

It works. Thanks for your help.
 
Old 11-30-2005, 11:20 AM   #11
Mad Scientist
Member
 
Registered: May 2003
Posts: 167

Rep: Reputation: 30
No problem. I'm glad we figured it out.
 
Old 12-01-2005, 05:32 AM   #12
majara
Member
 
Registered: Apr 2005
Location: Burgos (Spain)
Distribution: Fedora Core 4
Posts: 46

Rep: Reputation: 15
Mad Scientist got the target!
Problem solved.

Gracias a todos.
 
Old 12-01-2005, 10:44 PM   #13
xbill311x
Member
 
Registered: Mar 2005
Location: Delaware
Distribution: Fedora Core 4
Posts: 93

Original Poster
Rep: Reputation: 15
Awesome, Mad Scientist,

Thank's for shedding light, it's much appriciated, and very helpfull!

Bill
 
Old 11-16-2007, 12:11 PM   #14
chipha
LQ Newbie
 
Registered: Mar 2007
Posts: 2

Rep: Reputation: 0
This page will help understand the "why" about this.

Unless you operate NFS and NFSLOCKING in all those boot levels, there is no need to worry about them. Read this page and it will explain in easy to understand English what each of the services are for and whether you need them or not.

http://www.mjmwired.net/resources/mjm-services-f8.html

Even though this is for Fedora-8 it holds true for Fedora-4 as well and there are links to other things there that I am sure you will find interesting.
HTH,
George

Last edited by chipha; 11-16-2007 at 12:20 PM. Reason: to make more clear
 
  


Reply

Tags
nfs


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
NFS Locking? Meabert Linux - Software 5 11-30-2005 09:52 AM
Stopping NFS locking failed. travellers Linux - Software 1 11-28-2005 12:51 PM
NFS locking up jmickens Linux - Enterprise 1 10-13-2005 06:41 PM
Samba/NFS locking up. - HELP - grenobel Linux - Networking 0 02-25-2005 11:33 AM
stopping NFS statd FAILED shanenin Linux - Software 7 12-07-2003 08:32 AM


All times are GMT -5. The time now is 05:56 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration