LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Fedora
User Name
Password
Fedora This forum is for the discussion of the Fedora Project.

Notices



Reply
 
Search this Thread
Old 12-19-2006, 11:10 AM   #1
MRMadhav
Member
 
Registered: Nov 2005
Location: Mauritius
Distribution: PCQLinux, SUSE Linux,Fedora Core 5, Fedora Core 6, Knoppix Live, Kubuntu Edgy, PCLinuxOS
Posts: 167

Rep: Reputation: 30
ndiswrapper device for SMC2802W stopped working after reboot


Hi, I have just installed a wireless g card on my Fedora core 6 pc and found out that it did not have a compatible linux driver, thus i decided to use ndiswrapper version 1.31 that i downloaded and installed by following the instructions that i found by googling a bit...

It was working perfectly, my card was connecting and i was able to access my local network and the internet, but after rebooting when i tried to activate the device i got this error:

Code:
ndiswrapper device wlan0 does not seem to be present, delaying initialisation.
when i type ndiswrapper -l , the device is just as it was, that is correctly installed:
Code:
2802w : driver installed
        device (1260:3890) present (alternate driver: prism54)
when i do iwconfig i get this:
Code:
lo        no wireless extensions.

eth0      no wireless extensions.

eth1      NOT READY!  ESSID:off/any
          Mode:Managed  Channel:0  Access Point: Not-Associated
          Tx-Power=31 dBm   Sensitivity=0/200
          Retry min limit:0   RTS thr=0 B   Fragment thr=0 B
          Encryption key:off
          Link Quality:0  Signal level:0  Noise level:0
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:0  Invalid misc:0   Missed beacon:0

sit0      no wireless extensions.

What exactly is the problem and why does it seem that eth1 is being seen as the wireless device when i configured wlan0 to be it?

Any help will be greatly appreciated!
 
Old 12-19-2006, 05:07 PM   #2
jakev383
QmailToaster Developer
 
Registered: Dec 2005
Location: Burlington, NC
Distribution: CentOS, Voyage, Debian, Fedora
Posts: 220

Rep: Reputation: 31
Try reinstalling the driver, and did you do the following?:
ndiswrapper -m
modprobe ndiswrapper
echo ndiswrapper >> /etc/modules
 
Old 12-20-2006, 12:40 AM   #3
MRMadhav
Member
 
Registered: Nov 2005
Location: Mauritius
Distribution: PCQLinux, SUSE Linux,Fedora Core 5, Fedora Core 6, Knoppix Live, Kubuntu Edgy, PCLinuxOS
Posts: 167

Original Poster
Rep: Reputation: 30
Hi jakev383, Thanks for your reply...
Yes i did those:
ndiswrapper -m
modprobe ndiswrapper

but not
echo ndiswrapper >> /etc/modules

as the file /etc/modules does not exist.
I already tried reinstalling the driver but not ndiswrapper, Do you think that it is necessary to reinstall ndiswrapper?

What about the eth1 that can be seen from the output of iwconfig? I never configured eth1 and if ever i try to ifup eth1 it tells me that no configuration has been written for that device. Do you think that i should configure eth1 instead of wlan0?
 
Old 12-20-2006, 08:31 AM   #4
jakev383
QmailToaster Developer
 
Registered: Dec 2005
Location: Burlington, NC
Distribution: CentOS, Voyage, Debian, Fedora
Posts: 220

Rep: Reputation: 31
Quote:
Originally Posted by MRMadhav
Hi jakev383, Thanks for your reply...
Yes i did those:
ndiswrapper -m
modprobe ndiswrapper

but not
echo ndiswrapper >> /etc/modules

as the file /etc/modules does not exist.
I already tried reinstalling the driver but not ndiswrapper, Do you think that it is necessary to reinstall ndiswrapper?

What about the eth1 that can be seen from the output of iwconfig? I never configured eth1 and if ever i try to ifup eth1 it tells me that no configuration has been written for that device. Do you think that i should configure eth1 instead of wlan0?
Sorry, /etc/modules was for Ubuntu.
You shouldn't have to recompile it. What looks to have happened is that it originally configured wlan0, and when you rebooted it changed to eth1. I'd say go ahead and configure that device.
 
Old 12-21-2006, 01:33 AM   #5
MRMadhav
Member
 
Registered: Nov 2005
Location: Mauritius
Distribution: PCQLinux, SUSE Linux,Fedora Core 5, Fedora Core 6, Knoppix Live, Kubuntu Edgy, PCLinuxOS
Posts: 167

Original Poster
Rep: Reputation: 30
Hi i went to configure eth1 and found out that it was not using ndiswrapper but the prism54 driver itself just as i first installed the card! This means that eth1 also is not working! But while following the steps that i found on the net, there was a line that added prism54 to a blacklist! So how is it possible that eth1 is still using prism54 driver?
 
Old 12-21-2006, 02:09 AM   #6
jschiwal
Guru
 
Registered: Aug 2001
Location: Fargo, ND
Distribution: SuSE AMD64
Posts: 15,733

Rep: Reputation: 655Reputation: 655Reputation: 655Reputation: 655Reputation: 655Reputation: 655
Is there an alias for the prism54 device still in /etc/modprobe.conf or one of the files in /etc/modprobe.conf/?
"egrep '(prism|eth1)' /etc/modprobe.conf /etc/modprobe.d/*" may be useful in finding relative lines. If there is commment it out. ( Add a comment line before or after so you can undo it easier if you need to later. Something like your initials and the date in the comment may make maintainence easier, plus supply a grep target for later)
Double check that /etc/modprobe.d/ndiswrapper exists. Does it say "alias wlan0 ndiswrapper"?

Try "depmod -a". It may have been interupted perhaps during the ndiswrapper installation. However, this is a Hail Mary attempt.

I don't know if Fedora Core uses an /etc/modules file to identify modules to lead early. If it does, see if prism54 is listed and remove it or comment it out. See if there is an equivalent listing somewhere that might contain a reference to the prism driver.

Last edited by jschiwal; 12-21-2006 at 07:13 PM.
 
Old 12-29-2006, 02:45 PM   #7
MRMadhav
Member
 
Registered: Nov 2005
Location: Mauritius
Distribution: PCQLinux, SUSE Linux,Fedora Core 5, Fedora Core 6, Knoppix Live, Kubuntu Edgy, PCLinuxOS
Posts: 167

Original Poster
Rep: Reputation: 30
Hurray! My wireless card is now working!!! I think the problem was with eth1 loading using the prism54 driver... though there was no entry in /etc/modprobe.conf for prism54 it was still being loaded! Then, i thought why the blacklist that i added in /etc/hotplug/blacklist was not working! Thus i vied the file and found out that the only entry was prism54. I deduced that this file was invalid, thus i decided to browse the folder /etc/modprobe.d/ and i found 2 interesting files 'blacklist' and 'balcklist-compat' that had identical contents. Thus, i added the line:

blacklist prism54

at the end of both files, and did 'ndiswrapper -r 2802w' to remove the wireless driver from ndiswrapper and rebooted.
This time no eth1 was found and no prism54 loaded!
thus i did 'ndiswrapper -i 2802W.inf' to add mny driver again
then 'ndiswrapper -l' to check if its correctly loaded
and continued with the configuration of ndiswrapper as i did the first time.
Then i tried 'ifup wlan0' and it worked!
I had my internet connection working correctly!
I rebooted my pc, and the configuration was still the same!
So now there is no problem, except a little nag....
During configuration, i made sure that the device would load at boot time and it does i see the message
Bringing up interface: wlan0 [ok]

However, when i log-in the device is not active! And the problem is that i have to activate it manually each time!, the plus side is that i have put the flag wich says that users are allowed to control the device to yes and i can activate it just by pressing activate on the screen 'network device control'

But, is there a way to make the device activate automatically during boot or when i log in?

Note that when i am not logged as root i cannot use ifup! it says command not found
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Iomega REV drive stopped working after reboot pwtct Linux - Hardware 1 05-02-2007 11:40 AM
Ndiswrapper just stopped working zotova Linux - Wireless Networking 3 09-11-2005 05:28 PM
Upgraded kernel on FC2, ndiswrapper stopped working vrooje Linux - Wireless Networking 5 08-01-2005 08:22 PM
Azureus stopped working after reboot pragun Linux - Software 3 01-18-2005 06:57 PM
Sound on A7V880 stopped working after reboot of FC3 Coda Fedora 4 11-17-2004 06:47 PM


All times are GMT -5. The time now is 09:39 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration