LinuxQuestions.org
Register a domain and help support LQ
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Fedora
User Name
Password
Fedora This forum is for the discussion of the Fedora Project.

Notices

Reply
 
Search this Thread
Old 08-05-2005, 09:05 PM   #1
boxerboy
Member
 
Registered: Jul 2005
Distribution: ubuntu5.04, ubuntu5.10, suse9.3, mandrake10.1, mandriva2006(beta), FC1-4, redhat9.0, debian sarge
Posts: 519

Rep: Reputation: 32
my clocks are weird


hi its me again. i have tried everything to get all 3 clocks to be the same. i set clock in fc4 and than my xp clock was off i wanna say something like 6 hrs. than i got set xp clock to right time nad fc4 clock is off about 6hrs. i changed the bios clock back to right time but its still doing it. is there a reason why they wont work together i am on est in usa if that helps. ive tried utc but at i have tried everything i can think of and everything ive seen on other posts. plz help me
 
Old 08-05-2005, 09:12 PM   #2
johnMG
Member
 
Registered: Jul 2003
Location: CT, USA
Distribution: Debian Sarge (server), Etch (work/home)
Posts: 601

Rep: Reputation: 31
I'm running FC4 and every time I reboot my clock is 4 hours behind. I have to set it 4 hours ahead every time I start up.

The month, day, and year are always correct.

No idea.
 
Old 08-05-2005, 09:29 PM   #3
Matir
Moderator
 
Registered: Nov 2004
Location: San Jose, CA
Distribution: Ubuntu
Posts: 8,507

Rep: Reputation: 118Reputation: 118
You should take a look at /etc/localtime. Generally speaking, /etc/localtime should be a symbolic link to your current timezone, in /usr/share/zoneinfo. This is mine:
Code:
$ ls -l /etc/localtime
lrwxrwxrwx  1 root root 27 Jan 21  2005 /etc/localtime -> /usr/share/zoneinfo/EST5EDT
 
Old 08-05-2005, 09:33 PM   #4
johnMG
Member
 
Registered: Jul 2003
Location: CT, USA
Distribution: Debian Sarge (server), Etch (work/home)
Posts: 601

Rep: Reputation: 31
My /etc/localtime is just some wacky-looking binary.

Though the 'file' command thinks differently:
[john@localhost ~]$ file /etc/localtime
/etc/localtime: timezone data

And, it's not a link to anything:

[john@localhost ~]$ ls -l /etc/localtime
-rw-r--r-- 1 root root 1267 Aug 5 21:13 /etc/localtime
 
Old 08-05-2005, 09:39 PM   #5
Matir
Moderator
 
Registered: Nov 2004
Location: San Jose, CA
Distribution: Ubuntu
Posts: 8,507

Rep: Reputation: 118Reputation: 118
Umm, that's odd. I guess Fedora does things differently. Do you have a /usr/share/zoneinfo dir?
 
Old 08-06-2005, 12:11 AM   #6
johnMG
Member
 
Registered: Jul 2003
Location: CT, USA
Distribution: Debian Sarge (server), Etch (work/home)
Posts: 601

Rep: Reputation: 31
> Do you have a /usr/share/zoneinfo dir?

Yup.

Code:
[john@localhost /usr/share/zoneinfo]$ ls -F
Africa/      Canada/  EST      GMT0       Iran         Mexico/   Poland      ROK        WET
America/     CET      EST5EDT  GMT-0      iso3166.tab  Mideast/  Portugal    Singapore  W-SU
Antarctica/  Chile/   Etc/     GMT+0      Israel       MST       posix/      SystemV/   zone.tab
Arctic/      CST6CDT  Europe/  Greenwich  Jamaica      MST7MDT   posixrules  Turkey     Zulu
Asia/        Cuba     Factory  Hongkong   Japan        Navajo    PRC         UCT
Atlantic/    EET      GB       HST        Kwajalein    NZ        PST8PDT     Universal
Australia/   Egypt    GB-Eire  Iceland    Libya        NZ-CHAT   right/      US/
Brazil/      Eire     GMT      Indian/    MET          Pacific/  ROC         UTC
 
Old 08-06-2005, 12:14 AM   #7
Matir
Moderator
 
Registered: Nov 2004
Location: San Jose, CA
Distribution: Ubuntu
Posts: 8,507

Rep: Reputation: 118Reputation: 118
Try doing like mine and create a symbolic link from /etc/localtime to /usr/share/zoneinfo/YOURTIMEZONEOFCHOICEHERE
 
Old 08-06-2005, 12:47 AM   #8
mkoljack
Member
 
Registered: Jan 2005
Location: Chicago
Distribution: Fedora Core 4, Suse 9.3
Posts: 186

Rep: Reputation: 30
boxerboy--I think we were working on the audit daemon problem and you were able to find the Bugzilla numbers. Anyway, I have no idea if this will help you, but I also had the same clock problem and I went into system settings=>date/time and enabled the network time protocol daemon using the default time networks. I clicked OK and the clock was set perfectly. I hope you are able to find the solution.
 
Old 08-07-2005, 09:12 PM   #9
johnMG
Member
 
Registered: Jul 2003
Location: CT, USA
Distribution: Debian Sarge (server), Etch (work/home)
Posts: 601

Rep: Reputation: 31
Weird.

Did a yum update, and now my date and time are fine between reboots.

Go figure.

/etc/localtime seems the same as before (it's still a binary file, not a symlink).
 
Old 08-07-2005, 10:38 PM   #10
boxerboy
Member
 
Registered: Jul 2005
Distribution: ubuntu5.04, ubuntu5.10, suse9.3, mandrake10.1, mandriva2006(beta), FC1-4, redhat9.0, debian sarge
Posts: 519

Original Poster
Rep: Reputation: 32
thank you the last time i did /etc/localtimeoh hell i cant reember but ty i will try it again tomorrow sometime and let u know how it went
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Syncronize Clocks newuser455 Linux - Newbie 2 07-15-2005 09:23 PM
XFree86 clocks error MACSRULE Linux - General 3 04-06-2004 05:31 AM
Synchronising servers' clocks Paulo Ges Linux - Hardware 1 09-05-2003 01:31 PM
Programs for displaying multiple, varied clocks? Thymox Linux - Software 4 11-01-2002 04:33 PM
Sync-ing Clocks across a network philfighter Linux - Networking 1 01-25-2002 04:39 AM


All times are GMT -5. The time now is 05:09 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration