LinuxQuestions.org
Register a domain and help support LQ
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Fedora
User Name
Password
Fedora This forum is for the discussion of the Fedora Project.

Notices



Reply
 
Search this Thread
Old 08-10-2004, 11:56 AM   #1
hkl8324
Member
 
Registered: Aug 2003
Location: Hong Kong, China
Distribution: Ubuntu 10.04
Posts: 234

Rep: Reputation: 30
mplayer compile problem


i have compile and it works...but the gmplyer part do not work..

when i type mplayer at the command prompt

it returned

[hkl8324@localhost download]$ gmplayer
MPlayer 1.0pre5-3.3.3 (C) 2000-2004 MPlayer Team

CPU: Intel Pentium M Banias 598.4 MHz (Family: 6, Stepping: 5)
Detected cache-line size is 64 bytes
CPUflags: MMX: 1 MMX2: 1 3DNow: 0 3DNow2: 0 SSE: 1 SSE2: 1
Compiled for x86 CPU with extensions: MMX MMX2 SSE SSE2

Reading config file /usr/local/etc/mplayer/mplayer.conf: not found
Reading config file /home/hkl8324/.mplayer/config
[cfg] read config file: /home/hkl8324/.mplayer/gui.conf
Reading config file /home/hkl8324/.mplayer/gui.conf
vo: X11 running at 1024x768 with depth 16 and 16 bpp (":0.0" => local display)
Reading /home/hkl8324/.mplayer/codecs.conf: Can't open '/home/hkl8324/.mplayer/codecs.conf': not found
Reading /usr/local/etc/mplayer/codecs.conf: Can't open '/usr/local/etc/mplayer/codecs.conf': not found
Using built-in default codecs.conf.
font: can't open file: /home/hkl8324/.mplayer/font/font.desc
Font /usr/local/share/mplayer/font/font.desc loaded successfully! (206 chars)
Linux RTC init error in ioctl (rtc_irqp_set 1024): premission denied
Try adding "echo 1024 > /proc/sys/dev/rtc/max-user-freq" to your system startup scripts.
Using usleep() timing
Can't open input config file /home/hkl8324/.mplayer/input.conf: not found
Can't open input config file /usr/local/etc/mplayer/input.conf: not found
Falling back on default (hardcoded) input config
Setting up LIRC support...
mplayer: could not connect to socket
mplayer: not found
Failed to open LIRC support.
You will not be able to use your remote control.
SKIN dir 1: '/home/hkl8324/.mplayer/Skin'
SKIN dir 2: '/usr/local/share/mplayer/Skin'
[skin] file ( /usr/local/share/mplayer/Skin/default/skin ) not found.
Skin not found (default).

i have followed the README in the mplayer source code tar ball file........

can anyone help me....

thanks

hkl8324
 
Old 08-10-2004, 09:37 PM   #2
Harryc
Member
 
Registered: Dec 2002
Location: New York, USA
Distribution: OpenSUSE 10.0
Posts: 220

Rep: Reputation: 32
I think you might be missing some libraries. Check this link and make sure all mentioned packages are installed on your system.

http://www.linuxit.com.br/modules.ph...1#videomplayer

As an FYI...RPM install of mplayer is MUCH easier .

http://fedoraguide.org/fc2/fc2beginn...tml#yummplayer
 
Old 08-11-2004, 07:14 AM   #3
justin_p
Member
 
Registered: Jan 2004
Location: Virginia, USA
Distribution: slack 13; I've used it all :)
Posts: 433

Rep: Reputation: 30
you might also want to try xine and totem. Make sure you put your codecs in the /usr/libwin32 folder in order to watch all the movie formats.
 
Old 08-11-2004, 11:33 AM   #4
hkl8324
Member
 
Registered: Aug 2003
Location: Hong Kong, China
Distribution: Ubuntu 10.04
Posts: 234

Original Poster
Rep: Reputation: 30
will rpm install allow me to play windows media 9 file...because it is my primary concern...
 
Old 08-11-2004, 11:37 AM   #5
XavierP
Moderator
 
Registered: Nov 2002
Location: Kent, England
Distribution: Lubuntu
Posts: 19,176
Blog Entries: 4

Rep: Reputation: 430Reputation: 430Reputation: 430Reputation: 430Reputation: 430
You are missing the skins for your mplayer installation. As far as the codecs go, grab the essential selection and/or the all in one selection. The codecs will be able to then play Windows media.
 
Old 08-11-2004, 12:29 PM   #6
hkl8324
Member
 
Registered: Aug 2003
Location: Hong Kong, China
Distribution: Ubuntu 10.04
Posts: 234

Original Poster
Rep: Reputation: 30
Quote:
Originally posted by XavierP
You are missing the skins for your mplayer installation. As far as the codecs go, grab the essential selection and/or the all in one selection. The codecs will be able to then play Windows media.
one more question... the many of the .conf files are missing....is then i need to create them or they are supposed to be gernerated during compiling???

thanks

Last edited by hkl8324; 08-11-2004 at 03:37 PM.
 
Old 08-11-2004, 12:33 PM   #7
XavierP
Moderator
 
Registered: Nov 2002
Location: Kent, England
Distribution: Lubuntu
Posts: 19,176
Blog Entries: 4

Rep: Reputation: 430Reputation: 430Reputation: 430Reputation: 430Reputation: 430
They are supposed to be generated, but it doesn't really matter, at least in my experience it doesn't - what you really need are:
Mplayer (./configure --enable-gui to get the gmplayer)
Codecs
Skins
Fonts
and you are away.
 
Old 08-11-2004, 03:42 PM   #8
hkl8324
Member
 
Registered: Aug 2003
Location: Hong Kong, China
Distribution: Ubuntu 10.04
Posts: 234

Original Poster
Rep: Reputation: 30
ok, i can use gmplayer now after i put the skin the to corret floder...
but i cant play wmv9 ...the error said that it had segmentation problem....
i put the win32 codec in the /usr/local/lib/cedec floder prior to compilation...
do i need to input some special parameter prior to compilation to enable windows media support???(i can player windows media V1,V2 and wmv8 video anyway)

i have do a search google..but it seems than everyone have a problem with wmv9.... is mplayer really able to play wmv9???

thanks again

Last edited by hkl8324; 08-11-2004 at 03:55 PM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
mplayer compile problem in SUSE 9.1 perfect_circle Suse/Novell 2 02-19-2005 09:40 AM
Suse 9.2 mplayer compile problem Phyrexicaid Suse/Novell 8 01-20-2005 09:17 PM
[SuSE] Mplayer won't compile Harkov Linux - Software 14 01-16-2005 06:23 AM
mplayer compile problem axlotl Linux - Software 6 03-16-2004 10:10 PM
How do I compile(install) Mplayer natesch Linux - Newbie 14 05-08-2002 02:53 AM


All times are GMT -5. The time now is 01:46 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration