LinuxQuestions.org
Did you know LQ has a Linux Hardware Compatibility List?
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Fedora
User Name
Password
Fedora This forum is for the discussion of the Fedora Project.

Notices



Reply
 
Search this Thread
Old 06-07-2006, 12:49 AM   #1
pankaj-garg
LQ Newbie
 
Registered: Apr 2005
Posts: 12

Rep: Reputation: 0
Question mouse not working in fc5


hi friends

i hv installed fc5 from the dvd. but it has not detected my mouse so am not able to use the mouse. pls tell me how i can get the mouse to work. i have a seriall mouse. i tried to add ttys0 to etc/X11/xorg.conf file but it gives an error on booting that unknwon protocal. please tell me how can i get the mouse to work.

thanks
 
Old 06-07-2006, 04:48 AM   #2
routers
Member
 
Registered: Aug 2005
Location: Malaysia - KULMY / CNXTH
Distribution: Slackware, Fedora, FreeBSD, Sun O/S 5.10, CentOS
Posts: 773
Blog Entries: 6

Rep: Reputation: 75
Quote:
i tried to add ttys0 to etc/X11/xorg.conf
where u get this idea ermm btw can u paste here

Section "InputDevice"

this is mine :

Quote:
Section "InputDevice"
Identifier "Mouse0"
Driver "mouse"
Option "Protocol" "IMPS/2"
Option "Device" "/dev/input/mice"
Option "ZAxisMapping" "4 5"
Option "Emulate3Buttons" "yes"
EndSection
 
Old 06-09-2006, 02:26 AM   #3
pankaj-garg
LQ Newbie
 
Registered: Apr 2005
Posts: 12

Original Poster
Rep: Reputation: 0
my etc/X11/xorg.conf is exactly the same as u have mentioned, but my mouse is not ps2. i have a serial mouse, now tell me what should i add for serial mouse in the mouse section.

thanks
 
Old 06-09-2006, 02:29 AM   #4
nadroj
Senior Member
 
Registered: Jan 2005
Location: Canada
Distribution: ubuntu
Posts: 2,539

Rep: Reputation: 59
make sure you use ttyS0, ie, capital 'S'
can you post your mouse section and the exact error?
 
Old 06-09-2006, 02:36 AM   #5
pankaj-garg
LQ Newbie
 
Registered: Apr 2005
Posts: 12

Original Poster
Rep: Reputation: 0
well i did add ttyS0, in the protocol section and then rebooted the system but then system gives a error that ttyS0 is unknown protocol and x server could not be started. it starts after a lot of time and then wheni check the conf file it is restored to the original format. when i add ttyS0 do i have to add IMPS/2 .
 
Old 06-09-2006, 02:43 AM   #6
nadroj
Senior Member
 
Registered: Jan 2005
Location: Canada
Distribution: ubuntu
Posts: 2,539

Rep: Reputation: 59
you use that as the device not the protocol. protocol should be IMPS/2, device should be /dev/ttyS0
 
Old 07-07-2006, 12:52 AM   #7
pankaj-garg
LQ Newbie
 
Registered: Apr 2005
Posts: 12

Original Poster
Rep: Reputation: 0
serial mouse not working in fc5

hi
my serial mouse is not working in FC5.
in the xorg.conf mouse section line
Option "Device" "/dev/input/mice", i have added Option "Device" "/dev/ttyS0".

but still my mouse is not working.

pls help me out.
 
Old 07-07-2006, 12:54 AM   #8
nadroj
Senior Member
 
Registered: Jan 2005
Location: Canada
Distribution: ubuntu
Posts: 2,539

Rep: Reputation: 59
did you add that line or replace it? can you copy and paste the full section for your mouse?
 
Old 07-07-2006, 01:02 AM   #9
pankaj-garg
LQ Newbie
 
Registered: Apr 2005
Posts: 12

Original Poster
Rep: Reputation: 0
This is my mouse section in xorg.conf file
Section "InputDevice"
Identifier "Mouse0"
Driver "mouse"
Option "Protocol" "IMPS/2"
Option "Device" "/dev/ttyS0"
Option "ZAxisMapping" "4 5"
Option "Emulate3Buttons" "yes"
EndSection

i hv replaced the line
 
Old 07-07-2006, 01:06 AM   #10
nadroj
Senior Member
 
Registered: Jan 2005
Location: Canada
Distribution: ubuntu
Posts: 2,539

Rep: Reputation: 59
try put ttyS1 instead of ttyS0, or maybe even 2 instead of 1.. save the file, and restart X (you dont have to do a full reboot)

if not ttyS work, try /dev/mouse
 
Old 09-20-2006, 01:51 AM   #11
vtel57
Member
 
Registered: Jul 2006
Location: Tampa, FL, USA
Distribution: Slackware64
Posts: 864

Rep: Reputation: 89
Just to interject here... I recently did a fresh install of FC5 and I too thought I had no mouse once the desktop loaded. However, the mouse was working. It was just invisible. Please make sure you that you really don't have any mouse activity. You can do this by moving your mouse around the screen. If you go over one of the menus, the tooltip will pop up. If that happens then the mouse is there. You just can't see it.

The remedy for me was to edit xorg.conf and add this line to the video card section:

Code:
Option     "HWcursor"     "false"
Evidently, there's some problem with FC5 auto-detecting certain mice in conjuction with newer Nvidia video hardware.

Hope this was helpful to you.

Regards,

~Eric
 
Old 12-31-2007, 02:11 PM   #12
sambajahjah
LQ Newbie
 
Registered: Jan 2005
Posts: 5

Rep: Reputation: 0
On Fedora 6 this worked

This is how I did it on Fedora 6:

Section "ServerLayout"
Identifier "single head configuration"
Screen 0 "Screen0" 0 0
InputDevice "Keyboard0" "CoreKeyboard"
Add > InputDevice "Mouse0" "CorePointer"
EndSection

Add > Section "InputDevice"
Add > Identifier "Mouse0"
Add > Driver "mouse"
Add > Option "Protocol" "Microsoft"
Add > Option "Device" "/dev/ttyS0"
Add > EndSection

You probably may have to alter the "/dev/ttyS0" to "/dev/ttyS1" or "/dev/ttyS2"

Hope it helps!


One Love.
 
  


Reply

Tags
mouse


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
ndiswrapper not working under FC5 darkalien_fc5 Linux - Hardware 7 05-22-2006 11:32 AM
FC5 and X11vnc - working? cbtg2006 Fedora 1 04-27-2006 06:15 AM
Dumb question: FC5..what kind of mouse? davidirasmith Fedora - Installation 3 04-26-2006 07:17 PM
FC5 64 Test 3 mouse pointer Nvidia Drivers garbo73 Fedora 7 03-29-2006 05:47 AM
How to get wireless working on FC5 Hangetsu Fedora 2 03-23-2006 02:31 PM


All times are GMT -5. The time now is 02:21 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration