LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Fedora
User Name
Password
Fedora This forum is for the discussion of the Fedora Project.

Notices

Reply
 
Search this Thread
Old 03-24-2004, 12:17 PM   #1
devfreak
Member
 
Registered: Mar 2004
Location: Maine
Distribution: gentoo 2004.1, ubuntu 4.10, FC3
Posts: 97

Rep: Reputation: 15
mount desktop icons


Hey guys, just want you to know that I have my fedora box almost perfect to my own specifications. Media keys, mouse side buttons, nvidia graphics card, all of it!

I got this problem, though: I wanted to auto mount some network shares, so I put some mount -t smbfs specifications in my fstab file.

This computer is truly networked, I have 10-15 shares I need to be wired into, and that's why I needed them to be auto mounted, but, alas, it's giving me 10-15 icons on my otherwise squeeky desktop.

How do I nuke/hide/exorcise these icons on my desktop that are for mounted shares?
 
Old 03-25-2004, 11:24 PM   #2
Ed-MtnBiker
Member
 
Registered: Oct 2003
Location: Reno, NV
Distribution: Fedora Core 3
Posts: 88

Rep: Reputation: 15
Too funny, I've got the opposite problem. I've got a samba share mounted through fstab, and I WANT it to appear on my desktop, and it doesn't! So what's in your /etc/fstab I wonder?

Here's mine:
[root@localhost root]# grep smbfs /etc/fstab
//192.168.168.4/nd560 /mnt/nd560 smbfs guest,dmask=777,fmask=777 0 0

Last edited by Ed-MtnBiker; 03-25-2004 at 11:35 PM.
 
Old 03-26-2004, 09:55 AM   #3
devfreak
Member
 
Registered: Mar 2004
Location: Maine
Distribution: gentoo 2004.1, ubuntu 4.10, FC3
Posts: 97

Original Poster
Rep: Reputation: 15
//Q/qe /home/aaron/mounts/qe smbfs username=aaron,password=password,uid=500,gid=500,fmask=777,dmask=777,rw

I bet the answer is in the zeros?
 
Old 03-26-2004, 10:00 AM   #4
devfreak
Member
 
Registered: Mar 2004
Location: Maine
Distribution: gentoo 2004.1, ubuntu 4.10, FC3
Posts: 97

Original Poster
Rep: Reputation: 15
Nevermind, I don't think it's the zeros.

I've mounted the cf slot of my multicard reader in almost the exact same way and for some reason it doens't show an icon.

Why do we have to reverse engineer this stuff? Why isn't it documented?

My new guess is that I have specified a user to own it, so it shows up on that user's desktop. I'll reboot and see.

Edit:

I have no idea what's wrong, dude. I did mine just like yours, with the exception that I had to specify user and password for the share, and it didn't work. How lame. My windows machine is winXP, yours must be 2000? because I don't know if XP allows guest account network sharing.

Last edited by devfreak; 03-26-2004 at 10:11 AM.
 
Old 03-26-2004, 10:19 AM   #5
jschiwal
Guru
 
Registered: Aug 2001
Location: Fargo, ND
Distribution: SuSE AMD64
Posts: 15,733

Rep: Reputation: 654Reputation: 654Reputation: 654Reputation: 654Reputation: 654Reputation: 654
If you go into the KDE 'Configure your desktop' menu item. (KDE Control Center),
select LookNFeel -> Behavior.
Click on the 'Device Icons' tab.
Unselect the Mounted Samba Share entry.
 
Old 03-26-2004, 10:36 AM   #6
Ed-MtnBiker
Member
 
Registered: Oct 2003
Location: Reno, NV
Distribution: Fedora Core 3
Posts: 88

Rep: Reputation: 15
Just the clue I needed....I added "users" to the options for that share in fstab, and it appeared on my desktop when I remounted it! wo-hoo!

[root@localhost root]# grep smbfs /etc/fstab
//192.168.168.4/nd560 /mnt/nd560 smbfs users,guest,dmask=777,fmask=777 0 0
 
Old 03-26-2004, 11:04 AM   #7
devfreak
Member
 
Registered: Mar 2004
Location: Maine
Distribution: gentoo 2004.1, ubuntu 4.10, FC3
Posts: 97

Original Poster
Rep: Reputation: 15
Quote:
Originally posted by jschiwal
If you go into the KDE 'Configure your desktop' menu item. (KDE Control Center),
select LookNFeel -> Behavior.
Click on the 'Device Icons' tab.
Unselect the Mounted Samba Share entry.
Now I just need to find the gnome equiv.
Thanks for the tip!
 
Old 03-26-2004, 11:59 AM   #8
devfreak
Member
 
Registered: Mar 2004
Location: Maine
Distribution: gentoo 2004.1, ubuntu 4.10, FC3
Posts: 97

Original Poster
Rep: Reputation: 15
wow, I just switched to KDE for a minute, and damn: they really have gnome/nautilus on the configuration front.

I went through virtually every setting with gconf-editor. I give up.

Last edited by devfreak; 03-26-2004 at 12:25 PM.
 
Old 03-27-2004, 10:58 PM   #9
devfreak
Member
 
Registered: Mar 2004
Location: Maine
Distribution: gentoo 2004.1, ubuntu 4.10, FC3
Posts: 97

Original Poster
Rep: Reputation: 15
fuck it, i'm switching to kde
 
Old 04-08-2004, 10:20 PM   #10
allofitsik
LQ Newbie
 
Registered: Sep 2003
Posts: 15

Rep: Reputation: 0
I am having the same problem. too many smbfs icons on the gnome desktop. deleting them seems to work as a terribly temporary solution (only for the current login period). the problem is that I do not want all users to have access to (or knowledge of) these mounts. even such a simple solution as having a login script for various users delete these icons on startup. is there a simple way to do that, or has anyone figured out how to ACTUALLY tell gnome not to show these links. there are infact just links that gnome must generate on every login. where would it do that?

thanks.
 
Old 08-24-2004, 02:02 PM   #11
airtyme
LQ Newbie
 
Registered: Aug 2004
Posts: 1

Rep: Reputation: 0
Pretty sure I found the answer to this one.

As it turns out, any entry in the fstab with the option 'user' listed has a desktop icon appear whenever it is mounted. Unfortunately, the checking on this isn't particularly stricty, and 'username' also appears to cause this behaviour. I simply removed the 'username=...' from my fstab, and it happily removed the icons once I'd umounted and mounted again. I'm guessing that just removing 'username' will not work for many people, and would suggest looking into the 'credentials' option that I came across somewhere else on the net. I dunno, I've never tried it.

Cheers,

...Steve...
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
GNOME 2.8 Desktop icons all generic.desktop sygin Debian 0 12-22-2004 11:58 PM
KDE and Show mount icons on desktop Lokheed Linux - Software 0 12-08-2004 01:52 AM
Gnome desktop mount icons r_jensen11 Linux - Software 5 09-12-2004 11:23 AM
Desktop Icons ktook Linux - Software 4 09-06-2004 10:47 PM
Desktop Icons?? mike400hp DamnSmallLinux 5 03-11-2004 08:32 AM


All times are GMT -5. The time now is 12:12 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration