LinuxQuestions.org
LinuxAnswers - the LQ Linux tutorial section.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Fedora
User Name
Password
Fedora This forum is for the discussion of the Fedora Project.

Notices

Reply
 
Search this Thread
Old 02-15-2005, 05:05 AM   #1
vyom
LQ Newbie
 
Registered: Feb 2005
Location: Bangalore, India
Distribution: RedHat 9.0, Fedora Core 3
Posts: 18

Rep: Reputation: 0
Question monitor probed wrongly during fc3 installation


hi guys,

this is my first post in this forum. i have got a strange problem with installation of fc3 on compaq machines.

when i boot from the fc3 installation cd, it probes for the wrong monitor. i have got a samtron 55v connected to the box. it detects it as syncmaster 550v. strange. this is happenening on one particular machine. the other machines work pretty fine: the same video card, same monitor, but no problem at all! also, after installation is complete, before reboot, it does not ask for the correctness of the DDC probed hardware (i am not sure whether this question will ever be asked, as i'm installing fc3 for the first time; someone else installed fc3 on the other systems).

the system has got intel 810 video card.

one more thing, the box where i'm trying to install fc3 was connected to a syncmaster a few days ago. will this have any effect? (plz forgive me if i sound stupid ).

i have even tried system-config-display. no use

i went thru the xorg.conf file and found the horizontal and vertical sync values were all right! somebody plz help me!!!!
 
Old 02-15-2005, 07:08 AM   #2
masand
Guru
 
Registered: May 2003
Location: INDIA
Distribution: Ubuntu, Solaris,CentOS
Posts: 5,522

Rep: Reputation: 58
still post ur xorg.conf file and other details

regards
 
Old 03-01-2005, 10:37 PM   #3
vyom
LQ Newbie
 
Registered: Feb 2005
Location: Bangalore, India
Distribution: RedHat 9.0, Fedora Core 3
Posts: 18

Original Poster
Rep: Reputation: 0
Lightbulb i got it fixed, but still not satisfied

hi,

finally i could fix the problem. i booted the system in init level 3 and executed system-config-display command . i chose the right monitor with appropriate horizontal and vertical frequencies. now i run use graphical mode quite easily. but there is a draw back here; i have to boot the system in text mode and use startx to go to graphical mode. the default setting to boot in graphical mode has still got some problems. any idea? here is my xorg.conf........



# Xorg configuration created by system-config-display

Section "ServerLayout"
Identifier "single head configuration"
Screen 0 "Screen0" 0 0
InputDevice "Mouse0" "CorePointer"
InputDevice "Keyboard0" "CoreKeyboard"
EndSection

Section "Files"

# RgbPath is the location of the RGB database. Note, this is the name of the
# file minus the extension (like ".txt" or ".db"). There is normally
# no need to change the default.
# Multiple FontPath entries are allowed (they are concatenated together)
# By default, Red Hat 6.0 and later now use a font server independent of
# the X server to render fonts.
RgbPath "/usr/X11R6/lib/X11/rgb"
FontPath "unix/:7100"
EndSection

Section "Module"
Load "dbe"
Load "extmod"
Load "fbdevhw"
Load "glx"
Load "record"
Load "freetype"
Load "type1"
Load "dri"
EndSection

Section "InputDevice"

# Specify which keyboard LEDs can be user-controlled (eg, with xset(1))
# Option "Xleds" "1 2 3"
# To disable the XKEYBOARD extension, uncomment XkbDisable.
# Option "XkbDisable"
# To customise the XKB settings to suit your keyboard, modify the
# lines below (which are the defaults). For example, for a non-U.S.
# keyboard, you will probably want to use:
# Option "XkbModel" "pc102"
# If you have a US Microsoft Natural keyboard, you can use:
# Option "XkbModel" "microsoft"
#
# Then to change the language, change the Layout setting.
# For example, a german layout can be obtained with:
# Option "XkbLayout" "de"
# or:
# Option "XkbLayout" "de"
# Option "XkbVariant" "nodeadkeys"
#
# If you'd like to switch the positions of your capslock and
# control keys, use:
# Option "XkbOptions" "ctrl:swapcaps"
# Or if you just want both to be control, use:
# Option "XkbOptions" "ctrl:nocaps"
#
Identifier "Keyboard0"
Driver "kbd"
Option "XkbModel" "pc105"
Option "XkbLayout" "us"
EndSection

Section "InputDevice"
Identifier "Mouse0"
Driver "mouse"
Option "Protocol" "IMPS/2"
Option "Device" "/dev/input/mice"
Option "ZAxisMapping" "4 5"
Option "Emulate3Buttons" "yes"
EndSection

Section "Monitor"
Identifier "Monitor0"
VendorName "Monitor Vendor"
ModelName "Samsung Samtron 55v"
DisplaySize 280 210
HorizSync 30.0 - 55.0
VertRefresh 50.0 - 120.0
Option "dpms"
EndSection

Section "Device"
Identifier "Videocard0"
Driver "i810"
VendorName "Videocard vendor"
BoardName "Intel 845"
EndSection

Section "Screen"
Identifier "Screen0"
Device "Videocard0"
Monitor "Monitor0"
DefaultDepth 24
SubSection "Display"
Viewport 0 0
Depth 16
Modes "800x600" "640x480"
EndSubSection
SubSection "Display"
Viewport 0 0
Depth 24
Modes "1024x768" "800x600" "640x480"
EndSubSection
EndSection

Section "DRI"
Group 0
Mode 0666
EndSection

Last edited by vyom; 03-01-2005 at 10:38 PM.
 
Old 03-02-2005, 09:18 AM   #4
masand
Guru
 
Registered: May 2003
Location: INDIA
Distribution: Ubuntu, Solaris,CentOS
Posts: 5,522

Rep: Reputation: 58
hi there

what do u mean buy this

" the default setting to boot in graphical mode has still got some problems. any idea?"

regards
 
Old 03-03-2005, 06:02 AM   #5
vyom
LQ Newbie
 
Registered: Feb 2005
Location: Bangalore, India
Distribution: RedHat 9.0, Fedora Core 3
Posts: 18

Original Poster
Rep: Reputation: 0
hi,

i mean, i cannot boot the system directly in graphical mode.

Last edited by vyom; 03-03-2005 at 06:03 AM.
 
Old 03-03-2005, 11:41 AM   #6
homey
Senior Member
 
Registered: Oct 2003
Posts: 3,057

Rep: Reputation: 56
Quote:
the system has got intel 810 video card.
The cd install of fc3 had some issues with the i810 video driver. If you do a yum update, that should not be a problem anymore.
Also, check the /etc/inittab file for the proper boot up level. If you want to boot into the gui mode like kde or gnome, then you should boot into level 5 . That would look like this....
id:5:initdefault:
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
RH9 wrongly configured monitor during setup CLKalyani Red Hat 3 11-10-2004 08:33 PM
Emu10k1 can't be probed. Why? zaltar Linux - Newbie 3 11-09-2003 04:31 AM
CD burner wrongly recognised? oski Mandriva 6 10-16-2003 05:30 PM
RedHat 7.3 installation problem : monitor not probed bsambit Linux - Newbie 0 12-08-2002 10:31 AM
HSF wrongly identified as HCF? multiskilled Linux - Newbie 1 12-03-2001 08:02 AM


All times are GMT -5. The time now is 11:01 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration