LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Fedora
User Name
Password
Fedora This forum is for the discussion of the Fedora Project.

Notices

Reply
 
Search this Thread
Old 03-14-2013, 02:59 PM   #3811
daftcat
mlbviewer Maintainer
 
Registered: Apr 2008
Posts: 1,748

Rep: Reputation: 76

Quote:
Originally Posted by randcoop View Post
I have both python 3.3 and python 2.7 installed (it's Arch linux).

I don't know how to get mlbviewer to use 2.7, though. Any suggestion?

Thanks again for your help.
Okay, I consulted the Arch python documentation https://wiki.archlinux.org/index.php/Python and there are two ways to do this.

Method 1: (by far, the easiest and safest): start mlbviewer as

Code:
$ python2 mlbviewer.py
Method 2: Assuming* /usr/local/bin is ahead of /usr/bin in your PATH (env | grep PATH), you can put a symlink in /usr/local/bin to python2

Code:
$ ln -s /usr/bin/python2 /usr/local/bin/python
*Assuming Arch isn't totally off its rocker, /usr/local/bin should be ahead of /usr/bin so that any user-built software is preferred over system installed binaries. But then again, I would have assumed that python2 would still be the default so all bets are off. Try method 1 first.
 
Old 03-15-2013, 05:00 AM   #3812
randcoop
LQ Newbie
 
Registered: Jun 2005
Posts: 16

Rep: Reputation: 0
My apologies. I should have consulted the Arch wiki before coming here. I wrongly assumed the problem was with mlbviewer.

Python2 command worked (although I now have an error with the parser listing page...but I'll go to work on that).

Thanks for your help on this.



Quote:
Originally Posted by daftcat View Post
Okay, I consulted the Arch python documentation https://wiki.archlinux.org/index.php/Python and there are two ways to do this.

Method 1: (by far, the easiest and safest): start mlbviewer as

Code:
$ python2 mlbviewer.py
Method 2: Assuming* /usr/local/bin is ahead of /usr/bin in your PATH (env | grep PATH), you can put a symlink in /usr/local/bin to python2

Code:
$ ln -s /usr/bin/python2 /usr/local/bin/python
*Assuming Arch isn't totally off its rocker, /usr/local/bin should be ahead of /usr/bin so that any user-built software is preferred over system installed binaries. But then again, I would have assumed that python2 would still be the default so all bets are off. Try method 1 first.
 
Old 03-15-2013, 05:46 AM   #3813
randcoop
LQ Newbie
 
Registered: Jun 2005
Posts: 16

Rep: Reputation: 0
So I've been trying to avoid bothering you again, but I can't get past the error: "There was a parser problem with the listings page".

After exiting the program on this error, I get this at the CLI:

Traceback (most recent call last):
File "mlbviewer.py", line 1630, in <module>
curses.wrapper(mainloop, mycfg.data)
File "/usr/lib/python2.7/curses/wrapper.py", line 43, in wrapper
return func(stdscr, *args, **kwds)
File "mlbviewer.py", line 500, in mainloop
+ len(coveragetoggle.get(cfg['coverage'])) + 2
UnboundLocalError: local variable 'is_adaptive' referenced before assignment



The last time this seems to appear in this thread is 2011. You suggested making sure speeds were correct. I have installed mlbhls. So the speeds in the config file are: 1200 and a min_bps of 500000, which I would think are fine.

Any suggestions?






Quote:
Originally Posted by randcoop View Post
My apologies. I should have consulted the Arch wiki before coming here. I wrongly assumed the problem was with mlbviewer.

Python2 command worked (although I now have an error with the parser listing page...but I'll go to work on that).

Thanks for your help on this.
 
Old 03-15-2013, 12:26 PM   #3814
daftcat
mlbviewer Maintainer
 
Registered: Apr 2008
Posts: 1,748

Rep: Reputation: 76
Quote:
Originally Posted by randcoop View Post
So I've been trying to avoid bothering you again, but I can't get past the error: "There was a parser problem with the listings page".

After exiting the program on this error, I get this at the CLI:

Traceback (most recent call last):
File "mlbviewer.py", line 1630, in <module>
curses.wrapper(mainloop, mycfg.data)
File "/usr/lib/python2.7/curses/wrapper.py", line 43, in wrapper
return func(stdscr, *args, **kwds)
File "mlbviewer.py", line 500, in mainloop
+ len(coveragetoggle.get(cfg['coverage'])) + 2
UnboundLocalError: local variable 'is_adaptive' referenced before assignment



The last time this seems to appear in this thread is 2011. You suggested making sure speeds were correct. I have installed mlbhls. So the speeds in the config file are: 1200 and a min_bps of 500000, which I would think are fine.

Any suggestions?
Looks like you're running an old version.

Checkout to the latest (different directory):

Code:
svn checkout svn://svn.code.sf.net/p/mlbviewer/code/trunk mlbviewer-2013
And when I post about "SVN revision..." etc, do an "svn up" to that revision.
 
Old 03-16-2013, 07:05 AM   #3815
randcoop
LQ Newbie
 
Registered: Jun 2005
Posts: 16

Rep: Reputation: 0
Can't say thank you enough. Great program, great patience with people like me, great help forum

Works perfectly.


Quote:
Originally Posted by daftcat View Post
Looks like you're running an old version.

Checkout to the latest (different directory):

Code:
svn checkout svn://svn.code.sf.net/p/mlbviewer/code/trunk mlbviewer-2013
And when I post about "SVN revision..." etc, do an "svn up" to that revision.
 
Old 03-17-2013, 08:50 PM   #3816
daftcat
mlbviewer Maintainer
 
Registered: Apr 2008
Posts: 1,748

Rep: Reputation: 76
Quote:
Originally Posted by randcoop View Post
Can't say thank you enough. Great program, great patience with people like me, great help forum

Works perfectly.
Glad it's working for you.
 
Old 03-17-2013, 08:56 PM   #3817
daftcat
mlbviewer Maintainer
 
Registered: Apr 2008
Posts: 1,748

Rep: Reputation: 76
Red face

Quote:
Originally Posted by BostonPeng View Post
I had an idea I needed to close the player between videos. That looks pretty cool. I'll wait to take it for a spin since I'm also running tests for SolydK's Update Pack 1 and don't want to confuse me or my laptop too much. I know when you roll it out it'll probably be well worth waiting for.
In the middle of a rewrite. I might hack something together for you with mlbplay and hold off on making the mlbviewer changes until I'm done (or closer to done) with the rewrite. I have about 60% of the GUI done and none of it is talking with the business end of the program (getting and playing media.). Soon I hope. I don't want to be rewriting when I and supposed to be fixing (hopefully 2013 won't have that much to fix.)
 
Old 03-21-2013, 03:07 PM   #3818
daftcat
mlbviewer Maintainer
 
Registered: Apr 2008
Posts: 1,748

Rep: Reputation: 76
Rewrite is going well. Mostly done.

Quick poll:
Does anyone use the bookmarks feature?
Would any of you miss it if it didn't make it into the rewrite?
 
Old 03-22-2013, 01:54 AM   #3819
mkomko
Member
 
Registered: Mar 2010
Posts: 67

Rep: Reputation: 0
I didn't know there was a bookmarks feature....
 
Old 03-22-2013, 02:48 AM   #3820
daftcat
mlbviewer Maintainer
 
Registered: Apr 2008
Posts: 1,748

Rep: Reputation: 76
Quote:
Originally Posted by mkomko View Post
I didn't know there was a bookmarks feature....
No guarantees it still works. I broke it for a season or two and no-one reported it. It may or may not still work. I kind of want to reclaim those keys for a top secret new feature or two that I'm working on.

The problem with the feature is that it may only work for that season. If they make changes in 2013, I don't try for previous season compatibility anymore. I do branch at the end of the season so theoretically, the last checkin on the 2012 branch would work with any 2012 bookmarks. But you would need a 2011 checkout of mlbviewer for 2011 bookmarks, etc.

Hmmm...one thing at a time, but maybe I'll finally implement a key mapping file so you can have both cakes and eat them too.

Last edited by daftcat; 03-22-2013 at 02:53 AM.
 
Old 03-25-2013, 03:26 AM   #3821
daftcat
mlbviewer Maintainer
 
Registered: Apr 2008
Posts: 1,748

Rep: Reputation: 76
SVN revision 385: Huge rewrite - please update and report problems

Hi guys!

I did a huge rewrite of mlbviewer mostly to clean up the code but also to make certain pieces of the code a LOT easier to read and maintain.

While I have done my best to keep it feature equivalent to the old code, I have not included LIRC support yet or the bookmarks feature. The bookmarks feature I will likely not put back in but I will put the LIRC code back in, if requested (even though I have no way to test it.)

I would like everyone to update to this revision. I will not maintain the old code.

I don't believe I have captured everywhere a request can go wrong. So you may get crashes. If you do get a crash, please post the stack trace, the full text, so I can fix it.
 
Old 03-25-2013, 03:35 AM   #3822
daftcat
mlbviewer Maintainer
 
Registered: Apr 2008
Posts: 1,748

Rep: Reputation: 76
BostonPeng, highlights as a playlist is included in rev385. The 'y' key will create a /tmp/highlights.m3u8 and play it using whatever command you put in top_plays_player. Although, really, right now, I think it only supports mplayer because I use the -playlist argument. If you want vlc or any other player, let me know and I'll add another option like highlights_playlist_player that you can use to specify the correct command.

I know using the 'y' key doesn't make intuitive sense, but it's next to the 't' key so think of it that way. You can use the 'y' key from either the listings screen or the top plays screen itself. Finally, there's no way for me to know what correct game order of the highlights should be. The highlights.xml I parse does not contain that information. Can you watch the condensed games ('c' key) or do you need a subscription for those?
 
Old 03-25-2013, 09:26 AM   #3823
BostonPeng
Member
 
Registered: Jul 2009
Location: Boston, MA
Distribution: SolydK Testing + KDE 4.9.5
Posts: 88

Rep: Reputation: Disabled
I'll have to grab the latest code and give it a spin! I thought condensed games required a subscription but it looks like they don't, although it looks like they're only condensing one game per day for now.

ETA: Maybe I do need a subscription for condensed games because when I try to watch them via mlbviewer I get dumped back to the games listing although I can watch them on the MLB website.

Last edited by BostonPeng; 03-25-2013 at 09:44 AM.
 
Old 03-25-2013, 11:01 AM   #3824
daftcat
mlbviewer Maintainer
 
Registered: Apr 2008
Posts: 1,748

Rep: Reputation: 76
Quote:
Originally Posted by BostonPeng View Post
I'll have to grab the latest code and give it a spin! I thought condensed games required a subscription but it looks like they don't, although it looks like they're only condensing one game per day for now.

ETA: Maybe I do need a subscription for condensed games because when I try to watch them via mlbviewer I get dumped back to the games listing although I can watch them on the MLB website.
Did you try Saturday's Twins at Tampa Bay game? That's the most recent one with CG available. Mlbviewer will say in the status if condensed game is available. Otherwise, it will give you a requested media not found error.
 
Old 03-25-2013, 11:05 AM   #3825
BostonPeng
Member
 
Registered: Jul 2009
Location: Boston, MA
Distribution: SolydK Testing + KDE 4.9.5
Posts: 88

Rep: Reputation: Disabled
I did try that game, but it wouldn't open for some reason.
 
  


Reply

Tags
help, install, installation, instructions, seek, vlc, windows


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
mlb.com gameday audio stream statmobile Linux - Newbie 6 05-06-2008 10:16 PM
link dies intermittently-seemingly at random- between win<->linux not linux<->linux?? takahaya Linux - Networking 10 03-09-2007 10:37 PM
triple boot linux/linux/linux No Windows involved toastermaker Linux - Newbie 12 03-02-2006 10:40 PM
Redhat (rhel v2.1) bootup problem with linux (linux vs linux-up) namgor Linux - Software 2 06-24-2004 02:49 PM


All times are GMT -5. The time now is 03:26 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration