LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Fedora
User Name
Password
Fedora This forum is for the discussion of the Fedora Project.

Notices

Reply
 
Search this Thread
Old 02-15-2012, 04:53 PM   #3451
daftcat
mlbviewer Maintainer
 
Registered: Apr 2008
Posts: 1,746

Rep: Reputation: 76
First Spring Training Game - I'll be on vacation


First Spring Training Game is scheduled for Friday Mar 2, 2012. I don't know when the broadcasts will begin. I will be traveling for two weeks beginning Mar 1 and returning Mar 14. Any problems that you may encounter in the first couple weeks of Spring Training I may not be able to address until I return. Any hackers and brave souls (the code has become ugly over the years), please post patches if you get things working and I'll review them for incorporation as soon as I return (if not before.)
 
Old 02-16-2012, 12:20 AM   #3452
mkomko
Member
 
Registered: Mar 2010
Posts: 67

Rep: Reputation: 0
I'm already looking forward to a great season with mlbviewer!

Have fun on your trip!
 
Old 02-18-2012, 08:07 AM   #3453
chrisVV
Member
 
Registered: Aug 2010
Posts: 109

Rep: Reputation: 1
I have just got my re-subscription particulars through and I am pleased to see that my MLB annual basic membership is rolled through at 2010/11 prices. This may though not apply to everyone or to premium, as I only have my e-mail to go on.

One thing I see is that basic membership now offers some things only available on premium last year, including HD quality and live windback. That may require tweaks to mlbviewer if it assumes that that these aren't available for basic members. There are other new features on both basic and premium which will no doubt muck up mlbviewer until tweaked. I also see that MLB At Bat for mobile devices will no longer work on basic membership and that may have some knock-on consequences on the interface for mlbviewer, who knows.

Time will tell.

I have also noticed that the latest flash player actually achieves a modicum of hardware acceleration in full screen mode on both my netbook and my desktop for the first time, but it is still markedly inferior to using mlbviewer with vlc or mplayer.
 
Old 02-19-2012, 02:49 AM   #3454
daftcat
mlbviewer Maintainer
 
Registered: Apr 2008
Posts: 1,746

Rep: Reputation: 76
I can say for sure that live windback will not be a feature mlbviewer can support. Mlbviewer is merely a media location broker: parses listings, performs authentication, finds the media URL to launch a media player. Windback would have to be implemented in the media player itself. That said, if you guys want the feature, I suggest you contact mplayer/librtmp developers and offer to purchase a subscription or a trial subscription for them to be able to develop and test it with.

iPhone, Xbox, etc are merely other entries in the listings. New platform support shouldn't create any problems for the existing web stream platform.

HD quality support depends on whether they are using the standard web stream method (RTMP) or NexDef (HLS.) As always, standard support will be first priority. "NexDef" is always a moving target. Even over the course of the season, the implementation has been known to change. At this point, I'm willing to say NexDef is a bonus if we can get it to work, rather than a hard expectation for mlbviewer.

Finally, spring training will likely work with very few bug fixes necessary. That does not say whether regular season will also work so smoothly. MLBAM has historically used the previous year's implementation for Spring Training while they finish up development and testing of current year implementation. It is generally only the last week or so of Spring Training that they are able to roll out new year implementation for public beta. That said, last year was a pretty smooth transition because not much changed from prior year. I think the multi-year content deal they signed with Yahoo helped stabilize MLB.TV as it doesn't seem like they are reinventing the network each year like the first two or three seasons of mlbviewer.
 
Old 03-04-2012, 01:35 PM   #3455
berni42
LQ Newbie
 
Registered: Jul 2010
Posts: 16

Rep: Reputation: 0
Question Status: Final (No video) ?

Just in case I am doing something dumb. Here is what I did:

$ svn co https://mlbviewer.svn.sourceforge.ne...hes/nexdef2011 nexdef2011
<snip> Version 317.
$ cd nexdef2011
$ python mlbviewer.py

Then press back arrow to yesturdays date. Slelect first in the list:-

7:05 PM: Detroit Tigers at Atlanta Braves (Archived)

Worryingly the status at the bottom of left shows: Status: Final (No video)

Press ENTER gives status:-

An error occurred in locating the game stream:
No event-id to locate media streams.

Is it me, or is MLB.TV simply not available yet?

Last edited by berni42; 03-05-2012 at 02:02 AM. Reason: fixed svn co command
 
Old 03-04-2012, 02:14 PM   #3456
snowpine
Senior Member
 
Registered: Feb 2009
Posts: 3,912

Rep: Reputation: 1045Reputation: 1045Reputation: 1045Reputation: 1045Reputation: 1045Reputation: 1045Reputation: 1045Reputation: 1045
Emphasis added:

Quote:
Originally Posted by berni42 View Post
Worryingly the status at the bottom of left shows: Status: Final (No video)
Not all spring training games are televised. If you go to mlb.com/mediacenter you'll see that game is not available there either.
 
Old 03-05-2012, 02:10 AM   #3457
berni42
LQ Newbie
 
Registered: Jul 2010
Posts: 16

Rep: Reputation: 0
Great stear, thanks. mlb.com/mediacenter does show the Yankees game is available.

Here is the full list...

AVAILABLE GAMES FOR 3/3/2012 (Use arrow keys to change days) Help
───────────────────────────────────────────────────────────────────────────────
7:05 PM: Detroit Tigers at Atlanta Braves (Archived)
7:05 PM: New York Yankees at Philadelphia Phillies (Archived)
7:05 PM: Pittsburgh Pirates at Toronto Blue Jays (Archived)
7:05 PM: Tampa Bay Rays at Minnesota Twins (Archived)
7:05 PM: Washington Nationals at Houston Astros (Archived)
8:35 PM: Northeastern University at Boston Red Sox
9:05 PM: Arizona Diamondbacks at San Francisco Giants (Archived)
9:05 PM: Cleveland Indians at Cincinnati Reds (Archived)
9:05 PM: Oakland Athletics at Seattle Mariners (Archived)
9:10 PM: Arizona Diamondbacks at Colorado Rockies (Archived)
1:05 AM: Boston College at Boston Red Sox (Archived)

But all above give:-

An error occurred in locating the game stream:
No event-id to locate media streams.

Ah well... :-)
 
Old 03-05-2012, 03:15 AM   #3458
chrisVV
Member
 
Registered: Aug 2010
Posts: 109

Rep: Reputation: 1
Quote:
Originally Posted by snowpine View Post
Not all spring training games are televised. If you go to mlb.com/mediacenter you'll see that game is not available there either.
None of the games (even the three that were streamed and are now archived) play for me with mlbviewer. Presumably the stream id format has changed and mlbviewer will need to catch up. I am not much interested in spring training, but I did watch a little of one of them using flash (yikes).
 
Old 03-05-2012, 10:53 PM   #3459
daftcat
mlbviewer Maintainer
 
Registered: Apr 2008
Posts: 1,746

Rep: Reputation: 76
Still on vacation. Limited net access. Use flash until next week when I return home. If any geeky types want to debug this using Firebug and provide a patch, I'd be happy to include that in SVN if I get a chance next weekend to look at it.
 
Old 03-06-2012, 04:29 AM   #3460
fang2415
Member
 
Registered: Jan 2007
Posts: 159

Rep: Reputation: 15
Just wanted to point out that all the games I can find so far only have audio streams. (That's what the "No video" status message at the bottom of the listings screen should mean -- I know for Cubs games at least that that is correct because the first televised game isn't until Saturday the 10th.) So if you're trying to just press enter to get the video stream, the event-id error is the expected behavior.

So far I've been able to sucessfully access the streams for all the "No video" games using the "a" key from the listings screen. (A few games have the status "No media", which I assume means there's no audio either.) For some reason mplayer seems to be having trouble with the streams, but when I change the audio_player setting to vlc they play just fine.

So no patches are necessary on my end so far; hopefully this will work for others.

Last edited by fang2415; 03-06-2012 at 04:37 AM.
 
Old 03-06-2012, 04:47 AM   #3461
fang2415
Member
 
Registered: Jan 2007
Posts: 159

Rep: Reputation: 15
Ah, but I just now noticed that MLB Mediacenter does show that a bunch of games should have been televised so far even though mlbviewer shows that they don't have a video stream available. So yeah I'm guessing that they changed the video links slightly and that a patch would be necessary after all.

I may try to do some hacking on it later but I'm not sure if I'll have enough time or enough skillz, so if anybody else knows how do to this it'd be much appreciated.
 
Old 03-10-2012, 07:17 PM   #3462
fang2415
Member
 
Registered: Jan 2007
Posts: 159

Rep: Reputation: 15
Okay, I think I've cracked the issue with the video links. In short, MLB is no longer listing any flash links, so all that's there are the HTTP_CLOUD_WIRED links.

Here is the patch (I hope, my diff skills are lacking):

Code:
--- mlbviewer/branches/nexdef2011/MLBviewer/mlbtv.py	2012-03-11 01:01:14.872242097 +0000
+++ mlbviewer/branches/nexdef2011/MLBviewer/mlbtv_patched.py	2012-03-11 01:07:15.046028159 +0000
@@ -454,7 +454,7 @@
                if tmp['playback_scenario'] in \
                      ('FLASH_128K_256X144', 'FLASH_500K_400X224',
                       'FLASH_800K_400X448', 'FLASH_1200K_800X448', 
-                      'FLASH_1800K_800X448'):
+                      'FLASH_1800K_800X448', 'HTTP_CLOUD_WIRED'):
                    try:
                        tmp['blackout']
                    except:
I also needed to change the "speed=" line in my .mlb/config file to:

Code:
speed=swarm
That appeared to work, but then mplayer choked and when I changed it to VLC I got a sign-on restriction error. Also, I believe I was using revision 316; now that I've upgraded to 317, the listings page won't even load! That looks independent of the previous problem, but it is one more thing to debug...

Hope this is helpful to somebody anyway!
 
Old 03-10-2012, 07:49 PM   #3463
fang2415
Member
 
Registered: Jan 2007
Posts: 159

Rep: Reputation: 15
Ah, forgot that I also had to change mlbviewer.py. Here is the patch for that one, which should get the listings to load:

Code:
--- mlbviewer/branches/nexdef2011/mlbviewer.py	2012-03-11 01:01:14.856242111 +0000
+++ mlbviewer/branches/nexdef2011/mlbviewer_patched.py	2012-03-11 01:32:11.753449916 +0000
@@ -234,7 +234,8 @@
         "500"  : "[ 500K]",
         "800"  : "[ 800K]",
         "1200" : "[1200K]",
-        "1800" : "[1800K]"}
+        "1800" : "[1800K]",
+        "swarm": "[swarm]"}
 
     coveragetoggle = {
         "away" : "[AWAY]",
Incidentally, I believe this fix also requires "use_nexdef=1" to be in the config file. (And since I'm using mlbhls, I also need "use_mlbhd=1".)

As you can tell from the timestamps, it's late here, so I hope I'm not screwing anything up! Once again, these two patches seems to get everything to work but I can't test it further now due to the sign-on restriction. Hope others find it helpful until our Resident Genius Daftcat gets back from vacation!

Last edited by fang2415; 03-10-2012 at 08:00 PM.
 
Old 03-11-2012, 06:00 AM   #3464
chrisVV
Member
 
Registered: Aug 2010
Posts: 109

Rep: Reputation: 1
Unfortunately your patches don't work for me with the MLB basic package, after testing it on yesterday's archived games. With the two patches applied, the previous error "No event-id to locate media stream" still occurs unless "swarm" is specified as the speed in $/.mlb/config. With swarm specified as the speed, playing an archived stream gets a little further, but after spending about 3 seconds thinking about it gives a "Requested Media Not Found" error instead. (Specifying swarm as the speed in config also causes speed selection using the P key to bomb out.)

The patches might possibly work with the 2012 nexdef.jar server (which, out of interest, I did get working a few days ago with flash and the mozilla plugin), but MLB.TV are now streaming the full speed range (128K up to high def) using the standard (non-swarmcast/nexdef) stream, so it looks as if there must be some other new stream keys than just the HTTP_CLOUD_WIRED one which need to be catered for if you are not using mlbhls.
 
Old 03-11-2012, 07:24 AM   #3465
fang2415
Member
 
Registered: Jan 2007
Posts: 159

Rep: Reputation: 15
Quote:
Originally Posted by chrisVV View Post
Unfortunately your patches don't work for me with the MLB basic package, after testing it on yesterday's archived games. With the two patches applied, the previous error "No event-id to locate media stream" still occurs unless "swarm" is specified as the speed in $/.mlb/config. With swarm specified as the speed, playing an archived stream gets a little further, but after spending about 3 seconds thinking about it gives a "Requested Media Not Found" error instead. (Specifying swarm as the speed in config also causes speed selection using the P key to bomb out.)

The patches might possibly work with the 2012 nexdef.jar server (which, out of interest, I did get working a few days ago with flash and the mozilla plugin), but MLB.TV are now streaming the full speed range (128K up to high def) using the standard (non-swarmcast/nexdef) stream, so it looks as if there must be some other new stream keys than just the HTTP_CLOUD_WIRED one which need to be catered for if you are not using mlbhls.
I'm also on the basic package, and last night I was able to download a few innings of Friday's Cubs game, but this morning I'm getting the Requested Media Not Found error. Back to debugging for me...

I'm not quite sure how to interpret the stream keys, but it's clear that there are no longer individual streams for each speed. There are some new ones, which are marked "HTTP_CLOUD_WIRED_WEB" and "FMS_CLOUD"; those look like nexdef-type links to me. Maybe MLB is even running the low-speed video through nexdef? Anyway, you can see what's going on by comparing these two pages:

http://gdx.mlb.com/components/game/m...ay_08/grid.xml is from Friday;
http://gdx.mlb.com/components/game/m...ay_09/grid.xml is from last July.

Mind you, whatever I've done is a hack even if it works; doing it properly will probably require more intelligent eyeballs than mine!

Now, back to seeing if I can get the hack working again...
 
  


Reply

Tags
help, install, installation, instructions, seek, vlc, windows


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
mlb.com gameday audio stream statmobile Linux - Newbie 6 05-06-2008 10:16 PM
link dies intermittently-seemingly at random- between win<->linux not linux<->linux?? takahaya Linux - Networking 10 03-09-2007 10:37 PM
triple boot linux/linux/linux No Windows involved toastermaker Linux - Newbie 12 03-02-2006 10:40 PM
Redhat (rhel v2.1) bootup problem with linux (linux vs linux-up) namgor Linux - Software 2 06-24-2004 02:49 PM


All times are GMT -5. The time now is 02:17 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration