LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Fedora
User Name
Password
Fedora This forum is for the discussion of the Fedora Project.

Notices

Reply
 
Search this Thread
Old 06-27-2010, 06:42 PM   #3001
kweisen
Member
 
Registered: May 2006
Location: Stewartsville, NJ
Distribution: fedora 14 & MInt 15
Posts: 50

Rep: Reputation: 0

Quote:
Originally Posted by daftcat View Post
I've fixed the gameday audio bug on both the trunk (mlbviewer) and the nexdef branch.

Since I am now looking at the language value in the domain-attributes, I may implement a preferred language setting for gameday audio. I don't really have a whole lot of time right now, but it doesn't seem too hard to do once I do get some time again.
Daftcat:

It now works - thanks for the fix.
 
Old 06-28-2010, 02:12 PM   #3002
daftcat
mlbviewer Maintainer
 
Registered: Apr 2008
Posts: 1,766

Rep: Reputation: 76
Update on nexdef

It has been a wild month for me but I might actually have a few moments of time to re-visit mlbviewer and nexdef this week. I poked around with the old (v93) and new (v108) autobahn.jar and found something very interesting last night. The new autobahn.jar has an embedded RTMP server. So I thought, well, heck, if I can construct the command-line correctly, maybe I can just use rtmpdump against it. Well, what do you know? I had archived games playing using rtmpdump against the embedded server. It's going to take me some time to get the code from the test tools into the actual mlbviewer library code, but it looks promising that nexdef might finally be fully supported.

In the meantime, I recommend you continue to use the old autobahn.jar (v93) as I've had very little success getting my existing code working with the new autobahn.jar.

Direct link to the old MacOS X installer (instructions to extract the autobahn.jar are a page or two back):

http://mlb.mlb.com/media/player/nexd...definstall.dmg

When I get the new code tested and checked in, I'll update the README with instructions to extract the autobahn.jar from the MacOS X installer as well as the direct link to the installer.
 
Old 06-29-2010, 03:01 AM   #3003
daftcat
mlbviewer Maintainer
 
Registered: Apr 2008
Posts: 1,766

Rep: Reputation: 76
Rev 108 of autobahn is not super stable when it comes to closing of stream, but I have archive and innings working in my test code. Theoretically, I have live games working but I won't know until tomorrow afternoon when live games start up again. I may not be able to support stream switching like last year but I'll look into that later.

If all goes well, I'll have a testing revision ready tomorrow evening with an official sourceforge release due later in the week. I'll be relying on you guys to test this code and I'll be updating the documentation (and doing another round of code clean-up) over the course of the week to get it ready for general use. Again, I'll be relying on the more experienced users here to help out the less experienced users as my time really isn't what it used to be.
 
Old 06-29-2010, 09:39 PM   #3004
daftcat
mlbviewer Maintainer
 
Registered: Apr 2008
Posts: 1,766

Rep: Reputation: 76
SVN Revision 260 (nexdef2010 branch): Sourceforge Candidate 1

This is it. With the newest version of autobahn.jar (rev 108), I was finally able to support both live and archived nexdef games plus jump to innings. What's still missing is the ability to select a specific stream. However, I have added the "strict=true" option to the nexdef url which should lock you on whatever stream it started with. Please test this and let me know if it is locking on the correct stream for you. To set the stream to lock on, adjust the max_bps parameter to the maximum quality you want nexdef to use. Maximum quality is 3000000 (3 million.)

So what seems to be working in this revision (remember it's nexdef2010 branch):

Live and archived non-nexdef video
Live and archived nexdef video
Jump to innings for both modes
Gameday audio
Condensed Games
Top Plays

What isn't working yet:
Stream selection menu

I have also updated the documentation including a NEXDEF-2010.txt file which tells you where to get the mlbnexdefinstall.dmg file (Mac OS X installer) and how to extract autobahn.jar file from it.

Please give this revision some good testing. This will likely be what goes on to sourceforge for any new users.
 
Old 06-30-2010, 12:29 AM   #3005
fancyclown
LQ Newbie
 
Registered: Oct 2008
Posts: 6

Rep: Reputation: 0
Hi!

I installed mlbviewer on Snow Leopard today because I was veeeeeerryyy tired of the stupid stuttering full-screen flash playback in Firefox.

The 1800k playback works great and is really smooth but when I try nexdef it gets all fuzzy and the pq is not good.... and after a while everything stops working and quits out of mplayer.

Is this a problem with nexdef? I haven't been able to use it for a long time even when using Firefox or Safari, it just wont work.

Anyway, thanks for letting me watch MLB smoothly




EDIT Oh and I did this to install: svn co https://mlbviewer.svn.sourceforge.ne...hes/nexdef2010 nexdef2010

If I try to update it to see if I got an old version it says "Checked out revision 260" in terminal.

Last edited by fancyclown; 06-30-2010 at 12:55 AM.
 
Old 06-30-2010, 01:35 PM   #3006
daftcat
mlbviewer Maintainer
 
Registered: Apr 2008
Posts: 1,766

Rep: Reputation: 76
Quote:
Originally Posted by fancyclown View Post
Hi!

I installed mlbviewer on Snow Leopard today because I was veeeeeerryyy tired of the stupid stuttering full-screen flash playback in Firefox.

The 1800k playback works great and is really smooth but when I try nexdef it gets all fuzzy and the pq is not good.... and after a while everything stops working and quits out of mplayer.

Is this a problem with nexdef? I haven't been able to use it for a long time even when using Firefox or Safari, it just wont work.

Anyway, thanks for letting me watch MLB smoothly




EDIT Oh and I did this to install: svn co https://mlbviewer.svn.sourceforge.ne...hes/nexdef2010 nexdef2010

If I try to update it to see if I got an old version it says "Checked out revision 260" in terminal.
I'm assuming you are using the latest autobahn.jar (v108) as I know the nexdef code in rev 260 won't work with earlier versions of autobahn.jar.

Yeah, I am also seeing flakey stability from nexdef. I think the flash client is implementing retries and fallback procedures. I am running out of tricks to try to get stability out of the playback. I'm hoping it is a transitory network issue as sometimes I can watch several innings and sometimes I can't get through a half inning.

I'm restoring what I believe is the "turn off auto-adjust stream" setting and making it false by default. This means unless you set "strict_stream=True" in your config file, you're going to allow nexdef to jump around the different stream settings when it needs to. In practice, this works better for some than others. So that's one thing you can try yourself. Try it with "strict_stream=False" and try again with "strict_stream=True" and see if there is any difference.

This is in revision 261 which I just checked in.
 
Old 06-30-2010, 02:45 PM   #3007
zeom
LQ Newbie
 
Registered: Aug 2009
Posts: 5

Rep: Reputation: 1
Can somebody please be so kind and post the md5sum (or similar) for the
v108 autobahn.jar the includes the rtmp server?

The reason I'm asking is, while I downloaded the .dmg multiple times, the
extracted .jar I get always seems to be the same as in v104.

Thanks
 
Old 06-30-2010, 05:28 PM   #3008
daftcat
mlbviewer Maintainer
 
Registered: Apr 2008
Posts: 1,766

Rep: Reputation: 76
Quote:
Originally Posted by zeom View Post
Can somebody please be so kind and post the md5sum (or similar) for the
v108 autobahn.jar the includes the rtmp server?

The reason I'm asking is, while I downloaded the .dmg multiple times, the
extracted .jar I get always seems to be the same as in v104.

Thanks
Quote:
5e51839a5727715aa53cab757e77ca6c autobahn.jar
Things you can try:

1. Remove any existing copy of autobahn.jar you have.

2. Do a 'mount' or 'df -h' to see if you have mlbnexdefinstall.img already mounted. Umount that.

3. Remove any existing mlbnexdefinstall.* files you have.

4. Remove the Library directory that is extracted from Archive.pax.

5. Then repeat the steps in NEXDEF-2010.txt file to download and extract the jar file.
 
Old 06-30-2010, 11:11 PM   #3009
edouble312
Member
 
Registered: Apr 2009
Posts: 108

Rep: Reputation: 16
Quote:
Originally Posted by fancyclown View Post
Hi!

I installed mlbviewer on Snow Leopard today because I was veeeeeerryyy tired of the stupid stuttering full-screen flash playback in Firefox.

The 1800k playback works great and is really smooth but when I try nexdef it gets all fuzzy and the pq is not good.... and after a while everything stops working and quits out of mplayer.

Is this a problem with nexdef? I haven't been able to use it for a long time even when using Firefox or Safari, it just wont work.

Anyway, thanks for letting me watch MLB smoothly



EDIT Oh and I did this to install: svn co https://mlbviewer.svn.sourceforge.ne...hes/nexdef2010 nexdef2010

If I try to update it to see if I got an old version it says "Checked out revision 260" in terminal.
two things to know:

macports mplayer-devel is what you want to be using if you aren't already...

also, make sure you're running the latest nexdef. If you know how to extract the autobahn.jar from the osx installer you can use that as a java applet. If not, it should work just fine with the LATEST nexdef snow leopard install from mlb.com

Last edited by edouble312; 06-30-2010 at 11:13 PM.
 
Old 07-01-2010, 02:56 AM   #3010
fancyclown
LQ Newbie
 
Registered: Oct 2008
Posts: 6

Rep: Reputation: 0
Quote:
Originally Posted by edouble312 View Post
two things to know:

macports mplayer-devel is what you want to be using if you aren't already...

also, make sure you're running the latest nexdef. If you know how to extract the autobahn.jar from the osx installer you can use that as a java applet. If not, it should work just fine with the LATEST nexdef snow leopard install from mlb.com
Do I really need macports mplayer-devel? I used macports to install all the dependencies and then I used "svn checkout svn://svn.mplayerhq.hu/mplayer/trunk mplayer". Evrything seems to be working fine?

Oooooooh I just found this in the REQUIREMENTS-2010.txt:


Step 3: Run the configure script with, at a minimum, the following options:

$ cd mplayer
$ sh configure --enable-dynamic-plugins --prefix=/usr

It's very important you use --prefix=/usr as you want to install this new version of mplayer over your pre-distributed package.




So the dynamic-plugins stuff is a must have huh? Should I reinstall mplayer over the other svn version then?

About nexdef, I have tried both the latest OSX version as it is and extracted autobahn.jar and used the java thingie. The result have been the same.

Thanks for the help!
 
Old 07-01-2010, 01:46 PM   #3011
daftcat
mlbviewer Maintainer
 
Registered: Apr 2008
Posts: 1,766

Rep: Reputation: 76
Quote:
Originally Posted by fancyclown View Post
Do I really need macports mplayer-devel? I used macports to install all the dependencies and then I used "svn checkout svn://svn.mplayerhq.hu/mplayer/trunk mplayer". Evrything seems to be working fine?

Oooooooh I just found this in the REQUIREMENTS-2010.txt:


Step 3: Run the configure script with, at a minimum, the following options:

$ cd mplayer
$ sh configure --enable-dynamic-plugins --prefix=/usr

It's very important you use --prefix=/usr as you want to install this new version of mplayer over your pre-distributed package.




So the dynamic-plugins stuff is a must have huh? Should I reinstall mplayer over the other svn version then?

About nexdef, I have tried both the latest OSX version as it is and extracted autobahn.jar and used the java thingie. The result have been the same.

Thanks for the help!
Maybe. Maybe not on the dynamic-plugins.

I can't find any good reason to enable it or disable it. So I thought, what the heck, and went for it.

When REQUIREMENTS-2009.txt file was written last year, we had to take a patch from the ffmpeg team to get the flash video working last year. It was hot off the SVN presses. These days, most distros have refreshed their mplayer package and probably include this code. So if macports mplayer works, there's really no reason to build from SVN anymore. I leave it there in case someone has an older distro or older binary version of mplayer that doesn't have this patch.

Last edited by daftcat; 07-01-2010 at 01:48 PM.
 
Old 07-04-2010, 03:12 PM   #3012
fang2415
Member
 
Registered: Jan 2007
Posts: 159

Rep: Reputation: 15
ERROR: Download: Failed writing, exiting!

Hey guys,

Been a while since I used mlbviewer so I'm pretty out of date on whatever hacks are currently necessary, so I'll have to ask here:

I'm trying to use audio only and I can't get any games to play. Looks like it's fetching the url stream fine, but when it tries to play the media I get "ERROR: Download: Failed writing, exiting!".

Any ideas, or ideas on how to get better debug info?
 
Old 07-05-2010, 08:47 AM   #3013
kweisen
Member
 
Registered: May 2006
Location: Stewartsville, NJ
Distribution: fedora 14 & MInt 15
Posts: 50

Rep: Reputation: 0
Quote:
Originally Posted by fang2415 View Post
Hey guys,

Been a while since I used mlbviewer so I'm pretty out of date on whatever hacks are currently necessary, so I'll have to ask here:

I'm trying to use audio only and I can't get any games to play. Looks like it's fetching the url stream fine, but when it tries to play the media I get "ERROR: Download: Failed writing, exiting!".

Any ideas, or ideas on how to get better debug info?
I was having a similar problem and here's what worked for me:



$ cd mlbviewer
$ svn up

Also, may have to try this:

$ cp MediaService.xsd ~/.mlb
$ rm -r /tmp/suds/*

good luck


May want to look at the posts starting on page 197 ... for more info.
 
Old 07-05-2010, 01:47 PM   #3014
fang2415
Member
 
Registered: Jan 2007
Posts: 159

Rep: Reputation: 15
Hmm, thanks, am already at v261, but come to think of it I think something might have gone wrong with the suds install so I'll doublecheck that (I don't have a /tmp/suds). Although would that even matter if I'm getting the stream url fine? I would have thought that by that point the only thing that could be going wrong would be rtmpdump/media player?

Also no time now but will check page 197, thanks for the tip. This thread could use another thread to keep track of where all the info is on the thread.

f
 
Old 07-06-2010, 01:49 AM   #3015
fang2415
Member
 
Registered: Jan 2007
Posts: 159

Rep: Reputation: 15
Hah, okay, turns out that (I thought) I had commented out the default mplayer options in .mlb/config; after setting show_player_command=1, I realized that it was trying to run "rtmpdump blahblah|mplayer #-cache 64 -really-quiet -". Doubt that's the desired behavior, but pretty easy to work around. Although still not sure why that would throw "ERROR: Download"...

Anyway, after fixing that (by getting rid of the #), I remembered why I had put it in in the first place: mplayer does seem to be doing something, but all it shows is "1027kb / 43 s" (or something similar) -- the numbers keep increasing for a few minutes with no sound, then the player cuts. My mplayer is pretty old (1.0rc2-4.3.2-DFSG-free, from Debian Lenny); I guess I could (ugh) try compiling a newer one.

Also, I'm getting access restrictions frequently. Is there a reason why mlbviewer might be failing to log out properly?

Guess I'll try vlc tomorrow when the access ban wears off, then if that doesn't work, bite the bullet and compile a new mplayer...
 
  


Reply

Tags
help, install, installation, instructions, seek, vlc, windows


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
mlb.com gameday audio stream statmobile Linux - Newbie 6 05-06-2008 10:16 PM
link dies intermittently-seemingly at random- between win<->linux not linux<->linux?? takahaya Linux - Networking 10 03-09-2007 10:37 PM
triple boot linux/linux/linux No Windows involved toastermaker Linux - Newbie 12 03-02-2006 10:40 PM
Redhat (rhel v2.1) bootup problem with linux (linux vs linux-up) namgor Linux - Software 2 06-24-2004 02:49 PM


All times are GMT -5. The time now is 07:08 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration