LinuxQuestions.org
Visit the LQ Articles and Editorials section
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Fedora
User Name
Password
Fedora This forum is for the discussion of the Fedora Project.

Notices



Reply
 
Search this Thread
Old 04-18-2010, 11:04 AM   #2686
mchapter
Member
 
Registered: Apr 2010
Location: austin, tx
Distribution: osx 10.8.3
Posts: 46

Rep: Reputation: 17

Quote:
Originally Posted by thegenix View Post
edouble you are right on that one, I tried right now and it worked and I saw the listings but now when I select a game I get:

Traceback (most recent call last):
File "mlbviewer.py", line 1508, in <module>
curses.wrapper(mainloop, mycfg.data)
File "/usr/lib/python2.6/curses/wrapper.py", line 44, in wrapper
return func(stdscr, *args, **kwds)
File "mlbviewer.py", line 1159, in mainloop
stream = available[current_cursor][2][myteam]
IndexError: list index out of range
I'm going to guess that the stream you selected isn't available. Once you've highlighted your game press 'p' to cycle through and see which are available. Someone else here said they mostly see 800 or 1200 for archived games, the highest I've seen (out of a small sample size this year) is 1200 for a live game.
 
Old 04-18-2010, 11:14 AM   #2687
mchapter
Member
 
Registered: Apr 2010
Location: austin, tx
Distribution: osx 10.8.3
Posts: 46

Rep: Reputation: 17
Quote:
Originally Posted by daftcat View Post
Current state: meh!

One way you could help is if you can download either Firebug or HTTPFox and try to capture the local.swarmcast.net traffic using the flash player. Also, if you know your way around Boxee source, I could use some help on that front too. So far, I haven't been able to find where the MLBtv plugin is.

My best guess is that NexDef might not be available in mlbviewer until the end of the month. This should also give MLB.TV some time to work through any April jitters that happen every year.
Well, I've finally gotten Nexdef to kinda work in firefox 3.6.3, on Ubuntu 8.1, with the flash plugin version 10.0 r32, and I've got firebug installed, so now I just need to know what to look for. I'll keeping playing with it though and see if anything useful comes up.
 
Old 04-18-2010, 01:59 PM   #2688
linux_option
LQ Newbie
 
Registered: Jul 2008
Distribution: CentOS, Fedora, OpenWRT
Posts: 8

Rep: Reputation: 0
grrrrr. Trying to watch the Phils/Marlins game right now, and its giving a similar error as last time. But Gameday audio works? weird. I still haven't contacted support yet, but if this log indicates a similar location issue, I will.

http://pastebin.com/J1WBFutm
 
Old 04-19-2010, 12:42 AM   #2689
daftcat
mlbviewer Maintainer
 
Registered: Apr 2008
Posts: 1,767

Rep: Reputation: 76
Quote:
Originally Posted by linux_option View Post
grrrrr. Trying to watch the Phils/Marlins game right now, and its giving a similar error as last time. But Gameday audio works? weird. I still haven't contacted support yet, but if this log indicates a similar location issue, I will.

http://pastebin.com/J1WBFutm
Same problem as before: location cannot be determined.

Gameday audio doesn't require location verification, isn't subject to blackout rules.

Get this to work with the flash client. Try to add an address to your mlb.com profile. If those fail, then you'll have to call mlb support. Really, I can't help you on this.
 
Old 04-19-2010, 12:46 AM   #2690
daftcat
mlbviewer Maintainer
 
Registered: Apr 2008
Posts: 1,767

Rep: Reputation: 76
Quote:
Originally Posted by mchapter View Post
Well, I've finally gotten Nexdef to kinda work in firefox 3.6.3, on Ubuntu 8.1, with the flash plugin version 10.0 r32, and I've got firebug installed, so now I just need to know what to look for. I'll keeping playing with it though and see if anything useful comes up.
Look for traffic going to/from local.swarmcast.net or 127.0.0.1. Also, try changing stream quality and see if you still have nexdef or if it goes back to standard definition. I want to see something other than a "describe" url (e.g. describe/base64:...)
 
Old 04-19-2010, 12:50 AM   #2691
daftcat
mlbviewer Maintainer
 
Registered: Apr 2008
Posts: 1,767

Rep: Reputation: 76
Quote:
Originally Posted by thegenix View Post
marc@marc-desktop:~/mlbviewer$ python mlbviewer.py
Traceback (most recent call last):
File "mlbviewer.py", line 1508, in <module>
curses.wrapper(mainloop, mycfg.data)
File "/usr/lib/python2.6/curses/wrapper.py", line 44, in wrapper
return func(stdscr, *args, **kwds)
File "mlbviewer.py", line 388, in mainloop
+ len(coveragetoggle.get(cfg['coverage'])) + 2
UnboundLocalError: local variable 'hd_available' referenced before assignment


Any ideas what's wrong?

I'm on 64-bit 10.04 Ubuntu.
This looks like an old error/old line numbers. Please make sure you have updated to the most recent SVN revision. Either "svn up" or if you have never used svn, follow the svn instructions in the README file.
 
Old 04-20-2010, 06:36 AM   #2692
daftcat
mlbviewer Maintainer
 
Registered: Apr 2008
Posts: 1,767

Rep: Reputation: 76
Revision 236: Jump to Inning Support for Archived, non-nexdef games

This revision adds support for the Jump To Innings feature ('i' key) for non-nexdef, archived games. Jump to Innings is not supported for live games.

Notes:

You'll need at least rtmpdump v1.7 or higher to support the -start option.

http://rtmpdump.mplayerhq.hu/.


If you get an error about dlopen(), dlclose(), dlerror() when building rtmpdump, edit the Makefile and change this line:

Code:
LIB_OPENSSL=-lssl -lcrypto
to this:

Code:
LIB_OPENSSL=-ldl -lssl -lcrypto
 
Old 04-20-2010, 11:00 AM   #2693
bodly
LQ Newbie
 
Registered: Mar 2009
Distribution: Kubuntu
Posts: 24

Rep: Reputation: 16
Quote:
Originally Posted by daftcat View Post
You'll need at least rtmpdump v1.7 or higher to support the -start option.
Works with flvstreamer too.

Thanks Daftcat.
 
Old 04-20-2010, 11:08 AM   #2694
CCRS8
LQ Newbie
 
Registered: Apr 2010
Location: Durham, NC, USA
Distribution: Ubuntu
Posts: 28

Rep: Reputation: 1
problem parsing listings page

I used mlbviewer on Ubuntu for the 2008 season when mlb.tv moved to silverlight, but last year when they moved back to flash I just used Firefox/Flash. I didn't actually realize that mlbviewer was updated to work for last season until a few days ago when I investigated whether it worked for this season (since all of a sudden Firefox/Flash has weird menus and text popping up over top of the video). I wish I had known that it worked last season, as it is a much better solution and I could have gotten high def!

Anyway, I've updated mlbviewer via svn and I now have 0.1alpha12 (revision 235). I edited my config file with my credentials (which I verified work via Firefox/Flash). Now when I run mlbviewer, I get an error saying that there is a problem parsing the listings page (when I run mlblistings.py I get the listings, though). I can't even get to the place where I can attempt to play the video.

Any advice? I'm using Ubuntu 9.10. Ideally I'd like to use vlc to play the video, but that's just nitpicking - first step is to get to the listings page.

Thank you so much for your work on mlbviewer!
 
Old 04-20-2010, 11:09 AM   #2695
bmorganpa
LQ Newbie
 
Registered: Apr 2010
Posts: 1

Rep: Reputation: 0
Hi, I am new to mlbviewer this season but I got it running on both my linux and windows machines without too much trouble thanks to this thread and the documentation. I know there is an issue with nexdef on linux and people's accounts got shutdown, but I was wondering if this would work on windows or not or if there would be the same issue? Thanks again.
 
Old 04-20-2010, 11:43 AM   #2696
daftcat
mlbviewer Maintainer
 
Registered: Apr 2008
Posts: 1,767

Rep: Reputation: 76
Quote:
Originally Posted by CCRS8 View Post
I used mlbviewer on Ubuntu for the 2008 season when mlb.tv moved to silverlight, but last year when they moved back to flash I just used Firefox/Flash. I didn't actually realize that mlbviewer was updated to work for last season until a few days ago when I investigated whether it worked for this season (since all of a sudden Firefox/Flash has weird menus and text popping up over top of the video). I wish I had known that it worked last season, as it is a much better solution and I could have gotten high def!

Anyway, I've updated mlbviewer via svn and I now have 0.1alpha12 (revision 235). I edited my config file with my credentials (which I verified work via Firefox/Flash). Now when I run mlbviewer, I get an error saying that there is a problem parsing the listings page (when I run mlblistings.py I get the listings, though). I can't even get to the place where I can attempt to play the video.

Any advice? I'm using Ubuntu 9.10. Ideally I'd like to use vlc to play the video, but that's just nitpicking - first step is to get to the listings page.

Thank you so much for your work on mlbviewer!
If you ran setup.py to install mlbviewer back in 2008, you might want to run it again to make sure you've installed over the old files.

Mlbviewer picked up some extra requirements last year. Did you go through REQUIREMENTS-2009.txt and make sure you've installed pyxml, suds, and rtmpdump?

In the config file, speed=400 is no longer supported for 2010. If you want the low speed, choose speed=500. Valid speed choices for 2010 are 128, 500, 800, 1200, 1800. High def isn't supported yet. Their implementation in the plugin has changed from last year so I'm still working on it.

You can try removing your config file (or renaming it) and let mlbviewer create a new one with defaults necessary from last year's implementation. You'll have to put in your email and pass again, but at least you'll be caught up on default configuration.

Finally, you can add debug=True to your config so when the parser problem occurs, it will produce a stack trace. Post that stack trace here so I can attempt to locate the problem code.
 
Old 04-20-2010, 11:50 AM   #2697
daftcat
mlbviewer Maintainer
 
Registered: Apr 2008
Posts: 1,767

Rep: Reputation: 76
Quote:
Originally Posted by bmorganpa View Post
Hi, I am new to mlbviewer this season but I got it running on both my linux and windows machines without too much trouble thanks to this thread and the documentation. I know there is an issue with nexdef on linux and people's accounts got shutdown, but I was wondering if this would work on windows or not or if there would be the same issue? Thanks again.
Same code whether it's windows or linux. It wasn't an issue of autobahn.jar vs mlb-nexdef-autobahn.exe. It was the mlbviewer code that formatted requests to these plugins.

I'm still working on it. I haven't been able to get the plugin to work reliably on either platform using the official client. Unless I can get those to work, I won't have the http traces to go off for making mlbviewer work with it.

The season is still young and 1800K is a pretty stream. Be patient.
 
Old 04-20-2010, 11:55 AM   #2698
CCRS8
LQ Newbie
 
Registered: Apr 2010
Location: Durham, NC, USA
Distribution: Ubuntu
Posts: 28

Rep: Reputation: 1
Quote:
Originally Posted by daftcat View Post
If you ran setup.py to install mlbviewer back in 2008, you might want to run it again to make sure you've installed over the old files.

Mlbviewer picked up some extra requirements last year. Did you go through REQUIREMENTS-2009.txt and make sure you've installed pyxml, suds, and rtmpdump?

In the config file, speed=400 is no longer supported for 2010. If you want the low speed, choose speed=500. Valid speed choices for 2010 are 128, 500, 800, 1200, 1800. High def isn't supported yet. Their implementation in the plugin has changed from last year so I'm still working on it.

You can try removing your config file (or renaming it) and let mlbviewer create a new one with defaults necessary from last year's implementation. You'll have to put in your email and pass again, but at least you'll be caught up on default configuration.

Finally, you can add debug=True to your config so when the parser problem occurs, it will produce a stack trace. Post that stack trace here so I can attempt to locate the problem code.
Sorry - didn't mean to confuse. I reformatted my computer last October and did a clean install of Ubuntu 9.10, so this was a clean install of mlbviewer with a new config file. The only thing I did to the config file was set the high-def setting to 0 (because I read that nexdef was not yet figured out for 2010) and add my login credentials.

I saw the requirements-2009.txt file and installed what was listed. The only thing I am not certain I installed correctly is the latest version of rtmpdump (version 2.2, I think), but if I understand the process correctly, I wouldn't know if rtmpdump was a problem until I actually tried to play a game, right?

Anyway, I'm at work now, but when I get home I'll set debug to True and post results after re-verifying that I installed things correctly and resync with svn (saw that you have revision 236).

Thanks!
 
Old 04-20-2010, 12:57 PM   #2699
rashley
LQ Newbie
 
Registered: Apr 2010
Posts: 6

Rep: Reputation: 0
game picture is really narrow

I set up mlbviewer yesterday with rtmpdump 2.2 and followed the other instructions in the REQUIREMENTS 2009 file and the mPlayer screen comes up and everything works but the actual game is displayed using the middle third of the mPlayer window. The players are a bit skinnier than they should be. Hey, I always heard TV adds 10 lbs!!

This is such a vast improvement over the choppy Flash that I feel guilty complaining at all. Maybe there is something I can easily do to change things. I've also noticed that the xterm displays subsequent wrapped lines after the game is selected, (credits and some debug stuff) starting halfway across the window. Perhaps these are related issues.

Thanks a lot for your effort.
 
Old 04-20-2010, 01:59 PM   #2700
fumblejack
LQ Newbie
 
Registered: Apr 2010
Location: Canada
Distribution: Mint
Posts: 1

Rep: Reputation: 0
I have no problem viewing the games through Firefox using the embedded flash player. I had the nextDef installed last year and running just fine. Now that MLB has upgraded the plugin, it wants me to upgrade. Has anyone found the new nextDef for Linux install? I have been checking forums but haven't found anything yet.
 
  


Reply

Tags
help, install, installation, instructions, seek, vlc, windows


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
mlb.com gameday audio stream statmobile Linux - Newbie 6 05-06-2008 11:16 PM
link dies intermittently-seemingly at random- between win<->linux not linux<->linux?? takahaya Linux - Networking 10 03-09-2007 11:37 PM
triple boot linux/linux/linux No Windows involved toastermaker Linux - Newbie 12 03-02-2006 11:40 PM
Redhat (rhel v2.1) bootup problem with linux (linux vs linux-up) namgor Linux - Software 2 06-24-2004 03:49 PM


All times are GMT -5. The time now is 03:07 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration