LinuxQuestions.org
View the Most Wanted LQ Wiki articles.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Fedora
User Name
Password
Fedora This forum is for the discussion of the Fedora Project.

Notices



Reply
 
Search this Thread
Old 04-06-2010, 12:17 PM   #2521
Theophile
Member
 
Registered: Jan 2003
Posts: 283

Rep: Reputation: 35

Quote:
Originally Posted by rjwood View Post
Thanks for the help! Funny thing is this problem is only occurring with mlbviewer. I have videos on my system that work fine.
Okay, good. Now this:
Code:
mplayer -vo help
 
Old 04-06-2010, 12:33 PM   #2522
rjwood
Member
 
Registered: Jan 2006
Distribution: UBUNTU
Posts: 130

Rep: Reputation: 16
Quote:
Originally Posted by Theophile View Post
Okay, good. Now this:
Code:
mplayer -vo help
Here you go!
Quote:
rob@rob-desktop:~$ mplayer -vo help
MPlayer SVN-r31016-4.4.1 (C) 2000-2010 MPlayer Team
Available video output drivers:
x11 X11 ( XImage/Shm )
xover General X11 driver for overlay capable video output drivers
fbdev Framebuffer Device
fbdev2 Framebuffer Device
v4l2 V4L2 MPEG Video Decoder Output
directfb Direct Framebuffer Device
dfbmga DirectFB / Matrox G200/G400/G450/G550
xvidix X11 (VIDIX)
cvidix console VIDIX
null Null video output
mpegpes MPEG-PES to DVB card
yuv4mpeg yuv4mpeg output for mjpegtools
png PNG file
jpeg JPEG file
tga Targa output
pnm PPM/PGM/PGMYUV file
md5sum md5sum of each frame

rob@rob-desktop:~$
 
Old 04-06-2010, 02:12 PM   #2523
daftcat
mlbviewer Maintainer
 
Registered: Apr 2008
Posts: 1,767

Rep: Reputation: 76
I don't see "xv X11/Xv" in that list.

That could be a problem. Theophile can confirm.

Check if you have libxv-dev installed:

Code:
$ sudo dpkg --get-selections | grep -v deinstall | grep libxv-dev
libxv-dev                                       install
If you don't have that, install it:

Code:
$ sudo apt-get install libxv-dev
Then rebuild mplayer.
 
Old 04-06-2010, 02:20 PM   #2524
rmbellovin
LQ Newbie
 
Registered: Apr 2010
Posts: 21

Rep: Reputation: 0
Quote:
Originally Posted by daftcat View Post
Turns out these were both related to the changes in the playback scenario names made since last year. I'm almost dumbstruck at how simple the fixes were.

Test them both and tell me if they are working now. Might be a small consolation since none of the archives are working yet.
Top plays works for me (without sound), but condensed game doesn't. When I get rid of -really-quiet, mplayer says
Quote:
No stream found to handle url rtmp://[...]
 
Old 04-06-2010, 02:57 PM   #2525
rjwood
Member
 
Registered: Jan 2006
Distribution: UBUNTU
Posts: 130

Rep: Reputation: 16
Quote:
Originally Posted by daftcat View Post
I don't see "xv X11/Xv" in that list.

That could be a problem. Theophile can confirm.

Check if you have libxv-dev installed:

Code:
$ sudo dpkg --get-selections | grep -v deinstall | grep libxv-dev
libxv-dev                                       install
If you don't have that, install it:

Code:
$ sudo apt-get install libxv-dev
Then rebuild mplayer.
I went ahead and recompiled mplayer after reinstalling libxv-dev and not really any difference - in fact the picture is slightly more scrunched.

Is it possible this issue is due to the mplayer being for 64 bit? I have a 32 bit Ubuntu system installed. Just a guess!

Also I installed mlbviewer on my laptop and I'm not getting a picture at all - the terminal times like the video is coming in but no picture.

This is becoming tiresome - thanks for hanging with me.
 
Old 04-06-2010, 03:03 PM   #2526
rjwood
Member
 
Registered: Jan 2006
Distribution: UBUNTU
Posts: 130

Rep: Reputation: 16
Now I'm not getting a picture at all on either computer.
 
Old 04-06-2010, 03:19 PM   #2527
Theophile
Member
 
Registered: Jan 2003
Posts: 283

Rep: Reputation: 35
Quote:
Originally Posted by rjwood View Post
I went ahead and recompiled mplayer after reinstalling libxv-dev and not really any difference - in fact the picture is slightly more scrunched.

Is it possible this issue is due to the mplayer being for 64 bit? I have a 32 bit Ubuntu system installed. Just a guess!

Also I installed mlbviewer on my laptop and I'm not getting a picture at all - the terminal times like the video is coming in but no picture.

This is becoming tiresome - thanks for hanging with me.
The problem is that we don't know what you did to install mplayer. You still have your compiled version installed. You should not have to compile anything so we have to make sure to remove it from your system. Do this:
Code:
sudo apt-get --purge remove mplayer mencoder
Afterwards, make sure there is no 'mplayer' binary in either /usr/bin or /usr/local/bin . Do this:
Code:
/usr/bin/mplayer
/usr/local/bin/mplayer
You should get "No such file or directory" for both.

Now do this:
Code:
sudo apt-get install mplayer
After it finishes, do this command again, and paste the output:
Code:
/usr/bin/mplayer -vo help
 
Old 04-06-2010, 03:23 PM   #2528
rjwood
Member
 
Registered: Jan 2006
Distribution: UBUNTU
Posts: 130

Rep: Reputation: 16
after the purge
Quote:
rob@rob-desktop:~$ /usr/bin/mplayer
MPlayer SVN-r31016-4.4.1 (C) 2000-2010 MPlayer Team
Usage: mplayer [options] [url|path/]filename

Basic options: (complete list in the man page)
-vo <drv> select video output driver ('-vo help' for a list)
-ao <drv> select audio output driver ('-ao help' for a list)
vcd://<trackno> play (S)VCD (Super Video CD) track (raw device, no mount)
dvd://<titleno> play DVD title from device instead of plain file
-alang/-slang select DVD audio/subtitle language (by 2-char country code)
-ss <position> seek to given (seconds or hh:mm:ss) position
-nosound do not play sound
-fs fullscreen playback (or -vm, -zoom, details in the man page)
-x <x> -y <y> set display resolution (for use with -vm or -zoom)
-sub <file> specify subtitle file to use (also see -subfps, -subdelay)
-playlist <file> specify playlist file
-vid x -aid y select video (x) and audio (y) stream to play
-fps x -srate y change video (x fps) and audio (y Hz) rate
-pp <quality> enable postprocessing filter (details in the man page)
-framedrop enable frame dropping (for slow machines)

Basic keys: (complete list in the man page, also check input.conf)
<- or -> seek backward/forward 10 seconds
down or up seek backward/forward 1 minute
pgdown or pgup seek backward/forward 10 minutes
< or > step backward/forward in playlist
p or SPACE pause movie (press any key to continue)
q or ESC stop playing and quit program
+ or - adjust audio delay by +/- 0.1 second
o cycle OSD mode: none / seekbar / seekbar + timer
* or / increase or decrease PCM volume
x or z adjust subtitle delay by +/- 0.1 second
r or t adjust subtitle position up/down, also see -vf expand

* * * SEE THE MAN PAGE FOR DETAILS, FURTHER (ADVANCED) OPT
 
Old 04-06-2010, 03:29 PM   #2529
daftcat
mlbviewer Maintainer
 
Registered: Apr 2008
Posts: 1,767

Rep: Reputation: 76
Quote:
Originally Posted by rjwood View Post
after the purge
Do:

Code:
$ mplayer -vo help
That will show what video drivers this version of mplayer supports.
 
Old 04-06-2010, 03:29 PM   #2530
rjwood
Member
 
Registered: Jan 2006
Distribution: UBUNTU
Posts: 130

Rep: Reputation: 16
And the other
Quote:
rob@rob-desktop:~$ /usr/local/bin/mplayer
bash: /usr/local/bin/mplayer: No such file or directory
rob@rob-desktop:~$
I purged again and still get the same thing in /usr/bin/mplayer
 
Old 04-06-2010, 03:31 PM   #2531
rjwood
Member
 
Registered: Jan 2006
Distribution: UBUNTU
Posts: 130

Rep: Reputation: 16
....
Quote:
ob@rob-desktop:~$ mplayer -vo help
MPlayer SVN-r31016-4.4.1 (C) 2000-2010 MPlayer Team
Available video output drivers:
x11 X11 ( XImage/Shm )
xover General X11 driver for overlay capable video output drivers
fbdev Framebuffer Device
fbdev2 Framebuffer Device
v4l2 V4L2 MPEG Video Decoder Output
directfb Direct Framebuffer Device
dfbmga DirectFB / Matrox G200/G400/G450/G550
xvidix X11 (VIDIX)
cvidix console VIDIX
null Null video output
mpegpes MPEG-PES to DVB card
yuv4mpeg yuv4mpeg output for mjpegtools
png PNG file
jpeg JPEG file
tga Targa output
pnm PPM/PGM/PGMYUV file
md5sum md5sum of each frame
 
Old 04-06-2010, 03:32 PM   #2532
daftcat
mlbviewer Maintainer
 
Registered: Apr 2008
Posts: 1,767

Rep: Reputation: 76
Quote:
Originally Posted by rmbellovin View Post
Top plays works for me (without sound), but condensed game doesn't. When I get rid of -really-quiet, mplayer says
Try adding:

Code:
top_plays_player=mplayer -cache 2048
to your ~/.mlb/config file.

I'm pretty sure I have a catch in there to copy your video_player to top_plays_player if top_plays_player is not in config but I never know with that code these days.
 
Old 04-06-2010, 03:32 PM   #2533
Theophile
Member
 
Registered: Jan 2003
Posts: 283

Rep: Reputation: 35
See below

Last edited by Theophile; 04-06-2010 at 03:34 PM.
 
Old 04-06-2010, 03:33 PM   #2534
rmbellovin
LQ Newbie
 
Registered: Apr 2010
Posts: 21

Rep: Reputation: 0
The problem I was having with playing video with sound turned out to be that mplayer hadn't been compiled with faad support. I recompiled and now I've got sound. The reason gameday audio worked is that that was just an mpeg stream, which is handled differently.
 
Old 04-06-2010, 03:34 PM   #2535
daftcat
mlbviewer Maintainer
 
Registered: Apr 2008
Posts: 1,767

Rep: Reputation: 76
Quote:
Originally Posted by rjwood View Post
....
I'm going to defer to Theophile and let him decide whether you should re-install or re-compile.
 
  


Reply

Tags
help, install, installation, instructions, seek, vlc, windows


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
mlb.com gameday audio stream statmobile Linux - Newbie 6 05-06-2008 11:16 PM
link dies intermittently-seemingly at random- between win<->linux not linux<->linux?? takahaya Linux - Networking 10 03-09-2007 11:37 PM
triple boot linux/linux/linux No Windows involved toastermaker Linux - Newbie 12 03-02-2006 11:40 PM
Redhat (rhel v2.1) bootup problem with linux (linux vs linux-up) namgor Linux - Software 2 06-24-2004 03:49 PM


All times are GMT -5. The time now is 04:37 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration