LinuxQuestions.org
Go Job Hunting at the LQ Job Marketplace
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Fedora
User Name
Password
Fedora This forum is for the discussion of the Fedora Project.

Notices

Reply
 
Search this Thread
Old 10-07-2009, 07:21 PM   #2251
mswift42
Member
 
Registered: Mar 2009
Posts: 39

Rep: Reputation: 16

I am sorry for the hassles you have to go through.
At least I can enjoy the TBS feed, except for the horrible announcers. Europe rocks !!! (not the band)
 
Old 10-08-2009, 10:27 AM   #2252
pajamian
LQ Newbie
 
Registered: Oct 2009
Posts: 15

Rep: Reputation: 0
I just installed mlbviewer for the postseason and when I tested an archived game tonight I get the following error:
Traceback (most recent call last):
File "/usr/local/bin/mlbviewer.py", line 1508, in <module>
curses.wrapper(mainloop, mycfg.data)
File "/usr/lib/python2.6/curses/wrapper.py", line 44, in wrapper
return func(stdscr, *args, **kwds)
File "/usr/local/bin/mlbviewer.py", line 1201, in mainloop
u = g.soapurl()
File "/usr/local/lib/python2.6/dist-packages/MLBviewer/mlbtv.py", line 1261, in soapurl
return self.nexdef_url(game_url)
File "/usr/local/lib/python2.6/dist-packages/MLBviewer/mlbtv.py", line 1271, in nexdef_url
url = nexdef_base + 'describe' + '/base64:' + game_url + '&refetch=true'
TypeError: cannot concatenate 'str' and 'NoneType' objects

This is an upgrade from last year, so it might be leftover crap from the old config file:
# See README for explanation of these settings.
# user and pass are required except for Top Plays
user=**********
pass=**********

show_player_command=1

audio_player=xterm -e mplayer -cache 64 -quiet -playlist

top_plays_player=

time_offset=

audio_follow=ana

video_player=gmplayer -cache 2048 -quiet

debug=0

speed=800

x_display=

blackout=
 
Old 10-08-2009, 04:24 PM   #2253
bosox
Member
 
Registered: May 2009
Posts: 53

Rep: Reputation: 15
daftcat,

is there anyway i can run mlbviewer through a proxy/ssh tunnel? i have a 100/100 server in europe that i could use for this, although i don't know if the latency would be a problem. otherwise i guess i could try to use openvpn, but i have very limited experience with that.

Last edited by bosox; 10-08-2009 at 05:13 PM.
 
Old 10-08-2009, 09:31 PM   #2254
thecjester
LQ Newbie
 
Registered: Oct 2009
Posts: 2

Rep: Reputation: 0
Commercial break in progress

So, I've returned to Linux and am trying to play with this mlbviewer. I've read through a lot of the thread here, but I haven't noticed anyone experiencing this issue. Whenever I try to watch a game, live or archived, all I'm getting is "The game is about to start" or "Commercial break in progress." I've left it running and it never comes back.

Can anyone provide some insight into what I might be missing?

Thanks in advance,

CJ
 
Old 10-09-2009, 12:37 AM   #2255
daftcat
mlbviewer Maintainer
 
Registered: Apr 2008
Posts: 1,748

Rep: Reputation: 76
Quote:
Originally Posted by bosox View Post
daftcat,

is there anyway i can run mlbviewer through a proxy/ssh tunnel? i have a 100/100 server in europe that i could use for this, although i don't know if the latency would be a problem. otherwise i guess i could try to use openvpn, but i have very limited experience with that.
Sorry, man. It's explicitly against the MLB.TV Terms Of Service to circumvent blackout restrictions under threat of fines, early termination, and possible legal action (BOLD PRINT in the ToS.)

Plus it would be very bad for the project for me to tell you how to do it. That said, it is possible (at least it was last year) but you'd have to mess with the python code. I leave that as an exercise for you and wash my hands clean of this endeavor.
 
Old 10-09-2009, 12:43 AM   #2256
daftcat
mlbviewer Maintainer
 
Registered: Apr 2008
Posts: 1,748

Rep: Reputation: 76
Quote:
Originally Posted by pajamian View Post
I just installed mlbviewer for the postseason and when I tested an archived game tonight I get the following error:
Traceback (most recent call last):
File "/usr/local/bin/mlbviewer.py", line 1508, in <module>
curses.wrapper(mainloop, mycfg.data)
File "/usr/lib/python2.6/curses/wrapper.py", line 44, in wrapper
return func(stdscr, *args, **kwds)
File "/usr/local/bin/mlbviewer.py", line 1201, in mainloop
u = g.soapurl()
File "/usr/local/lib/python2.6/dist-packages/MLBviewer/mlbtv.py", line 1261, in soapurl
return self.nexdef_url(game_url)
File "/usr/local/lib/python2.6/dist-packages/MLBviewer/mlbtv.py", line 1271, in nexdef_url
url = nexdef_base + 'describe' + '/base64:' + game_url + '&refetch=true'
TypeError: cannot concatenate 'str' and 'NoneType' objects

This is an upgrade from last year, so it might be leftover crap from the old config file:
# See README for explanation of these settings.
# user and pass are required except for Top Plays
user=**********
pass=**********

show_player_command=1

audio_player=xterm -e mplayer -cache 64 -quiet -playlist

top_plays_player=

time_offset=

audio_follow=ana

video_player=gmplayer -cache 2048 -quiet

debug=0

speed=800

x_display=

blackout=
Read the REQUIREMENTS-2009 file and make sure you do all the steps listed. Also, read the section in the README on SVN and make sure you update to the latest revision (214.) I wasn't planning on updating the Sourceforge release since there's very little of the season left. Also, decide whether you want to do NexDef (Premium subscriber) or rtmpdump (standard) and make sure to follow the appropriate instructions. For NexDef, gmplayer will probably work. For rtmpdump, you probably need to use raw mplayer unless you know for sure that gmplayer supports piping from standard input (e.g. rtmpdump <someurl> | gmplayer -)

Good luck!
 
Old 10-09-2009, 12:45 AM   #2257
daftcat
mlbviewer Maintainer
 
Registered: Apr 2008
Posts: 1,748

Rep: Reputation: 76
Quote:
Originally Posted by thecjester View Post
So, I've returned to Linux and am trying to play with this mlbviewer. I've read through a lot of the thread here, but I haven't noticed anyone experiencing this issue. Whenever I try to watch a game, live or archived, all I'm getting is "The game is about to start" or "Commercial break in progress." I've left it running and it never comes back.

Can anyone provide some insight into what I might be missing?

Thanks in advance,

CJ
Not a clue. I saw that with 2007 archives last year (only 2009 really works with this year's mlbviewer code) but I haven't seen that this year. Try starting fresh. Backup and remove your ~/.mlb directory and let mlbviewer create the skeleton config. Then fill in your user and pass, and copy the MediaService.* files in.
 
Old 10-09-2009, 02:53 AM   #2258
GoJaysGo
LQ Newbie
 
Registered: Oct 2009
Posts: 1

Rep: Reputation: 0
Quote:
Originally Posted by thecjester View Post
So, I've returned to Linux and am trying to play with this mlbviewer. I've read through a lot of the thread here, but I haven't noticed anyone experiencing this issue. Whenever I try to watch a game, live or archived, all I'm getting is "The game is about to start" or "Commercial break in progress." I've left it running and it never comes back.

Can anyone provide some insight into what I might be missing?

Thanks in advance,

CJ
This issue has started for me in the playoffs, specifically the "game starting soon" message. I live in Europe so am able to watch playoff games live with the regular TBS feed (not playoffs.tv). I've been a user of mlbviewer for the last two years and have never had this issue before. I use nexdef as I have not had any luck installing rtmpdump.

I've tried to see if using the test scripts etc helps but they have not. I noticed that the starttime may be incorrect (although probably not). For example last nights LAD vs STL game had a start time of 56230000. I assume this is a milliseconds since midnight in the Eastern time zone? This also is happening when I try to watch the archived game. Same start time, just watching the blue screen of boredom.

I changed the start time manually while the COL PHI game was on then rerun the mplayer command I didn't see the "Starting Soon" screen but about 3 seconds of actual gameplay before mplayer stopped.

daftcat, if you know a quick hack to the code that might work I have no issue editing my local copy so you don't have to go through the full effort of testing and committing an svn change. I am using svn revision 214 and my live_from_start variable is not set in my config file.

Thanks so much for your great effort in creating mlbviewer! It has drastically reduced the rage I feel towards mlbam and their inferior products.
 
Old 10-09-2009, 08:20 AM   #2259
daftcat
mlbviewer Maintainer
 
Registered: Apr 2008
Posts: 1,748

Rep: Reputation: 76
Commercial break in progress....

I verified that using the jump to innings feature (the "i" key) and selecting top of the 1st ("t1") will get you right to the beginning of the game.

This only works for NexDef users, but the rtmpdump (non-NexDef) does not seem to be affected by this "commercial break in progress" problem.
 
Old 10-10-2009, 12:26 AM   #2260
thecjester
LQ Newbie
 
Registered: Oct 2009
Posts: 2

Rep: Reputation: 0
Quote:
Originally Posted by daftcat View Post
Commercial break in progress....

I verified that using the jump to innings feature (the "i" key) and selecting top of the 1st ("t1") will get you right to the beginning of the game.

This only works for NexDef users, but the rtmpdump (non-NexDef) does not seem to be affected by this "commercial break in progress" problem.
Yup, worked like a charm. Thanks for the assistance.

CJ
 
Old 10-11-2009, 12:40 PM   #2261
pajamian
LQ Newbie
 
Registered: Oct 2009
Posts: 15

Rep: Reputation: 0
I upgraded to thelatest svn as you suggested, deleted the .mlb directory and started over with it, and have already read through the 2009 file. For some reason mlbviewer is trying to play the flash stream, and does not appear to see the other streams. How can I continue to troubleshoot? Any suggestions?
 
Old 10-11-2009, 11:47 PM   #2262
daftcat
mlbviewer Maintainer
 
Registered: Apr 2008
Posts: 1,748

Rep: Reputation: 76
Quote:
Originally Posted by pajamian View Post
I upgraded to thelatest svn as you suggested, deleted the .mlb directory and started over with it, and have already read through the 2009 file. For some reason mlbviewer is trying to play the flash stream, and does not appear to see the other streams. How can I continue to troubleshoot? Any suggestions?
Are you trying to get the postseason.tv working with the camera angles?

That's not supported...yet.

If you live in one of the blackout areas (US, Canada, Virgin Islands, etc.), you will only be able to watch the archived games which are available about 90 minutes after game finishes.

I have other priorities during the week. If I get a chance, I'll try to support postseason.tv. In the meantime, if you can't wait for the archives, I suggest picking the least annoying camera angle (probably the home plate press box) and just watch one of those using the flash player on the mlb.com website. Your other option is to try the steps posted about a page back here.
 
Old 10-12-2009, 01:13 AM   #2263
pajamian
LQ Newbie
 
Registered: Oct 2009
Posts: 15

Rep: Reputation: 0
Quote:
Originally Posted by daftcat View Post
Are you trying to get the postseason.tv working with the camera angles?

That's not supported...yet.
Nope, just the regular TBS feed, either the nextdef one or the standard feed (nextdef would be nice, but I just want something better than the flash player on the website at this point).

Quote:
If you live in one of the blackout areas (US, Canada, Virgin Islands, etc.), you will only be able to watch the archived games which are available about 90 minutes after game finishes.
I'm in New Zealand and the games are definitely *not* blacked out here.

Quote:
I have other priorities during the week. If I get a chance, I'll try to support postseason.tv. In the meantime, if you can't wait for the archives, I suggest picking the least annoying camera angle (probably the home plate press box) and just watch one of those using the flash player on the mlb.com website.
The flash player on the website has been working for me for the standard and nextdef feeds but the video is extremely choppy. I am hoping that mlbviewer with mplayer will not have the choppiness (yeah, I know I have to recompile mplayer from svn as per the 2009 file, but I'm just trying to get it working here).

Quote:
Your other option is to try the steps posted about a page back here.
I'll look into that as well, thanks.
 
Old 10-12-2009, 01:07 PM   #2264
daftcat
mlbviewer Maintainer
 
Registered: Apr 2008
Posts: 1,748

Rep: Reputation: 76
Quote:
Originally Posted by pajamian View Post
Nope, just the regular TBS feed, either the nextdef one or the standard feed (nextdef would be nice, but I just want something better than the flash player on the website at this point).



I'm in New Zealand and the games are definitely *not* blacked out here.



The flash player on the website has been working for me for the standard and nextdef feeds but the video is extremely choppy. I am hoping that mlbviewer with mplayer will not have the choppiness (yeah, I know I have to recompile mplayer from svn as per the 2009 file, but I'm just trying to get it working here).



I'll look into that as well, thanks.
Okay, thanks for the info.

So what's the problem you are still facing?

For nexdef, you need the autobahn.jar file and you're starting it as "java -jar autobahn.jar"?

Also for nexdef, you should set max_bps in your config file and also use_nexdef:

Quote:
# in bits per sec so high def is 3 million
max_bps=3000000

# you can also use the 'n' key to toggle this
use_nexdef=True
The max_bps setting is equivalent to saying, start with the highest quality stream that doesn't exceed this setting. Mapped to the bars, it's roughly 3M (7 bars), 2.2M (6 bars), 1.8M (5 bars), 1.2M (4 bars), 800K (3 bars), 500K (2 bars), 164K (1 bar). In the mlbviewer window, the view changes to a nexdef screen after a stream is selected. From here, you can select a different speed or lock in the speed you have (equivalent of unchecking the auto-adjust in the flash player.)

With svn revision 214, you should be picking up the main tbs stream only.

So what's still not working for you?
 
Old 10-12-2009, 01:23 PM   #2265
daftcat
mlbviewer Maintainer
 
Registered: Apr 2008
Posts: 1,748

Rep: Reputation: 76
coming very soon....postseason.tv support

I have an early hack to support postseason.tv for those of us in the blackout areas. You don't need to pay mlbam an additional $10 for the package if you are already an mlb.tv subscriber.

Here's the thing, though. Since I live on the west coast, nearly all of those post-season games which are in ET are very inconvenient times for me for testing. I lucked out that there was still a game on last night when I hacked up this code. Unfortunately, the game was over by the time I got the camera switching code finally working. And I can't test again until the next live broadcast that is also convenient for me on the west coast (game 5 tomorrow if there is one or the LCS games this weekend.) I'll likely miss all of today's game.

Here's what I'm going to do.

I'm going to check in the code in another hour or two (when I get a chance to go home and plug in the laptop.) There will be a new file called postseason.py (a fork of mlbviewer.py) and a few library changes. For those who can watch the game live today, please help me out with some testing. I'll have more howto details when I check in the code.

Check back here before the start of the game today.
 
  


Reply

Tags
help, install, installation, instructions, seek, vlc, windows


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
mlb.com gameday audio stream statmobile Linux - Newbie 6 05-06-2008 10:16 PM
link dies intermittently-seemingly at random- between win<->linux not linux<->linux?? takahaya Linux - Networking 10 03-09-2007 10:37 PM
triple boot linux/linux/linux No Windows involved toastermaker Linux - Newbie 12 03-02-2006 10:40 PM
Redhat (rhel v2.1) bootup problem with linux (linux vs linux-up) namgor Linux - Software 2 06-24-2004 02:49 PM


All times are GMT -5. The time now is 09:36 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration