LinuxQuestions.org
View the Most Wanted LQ Wiki articles.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Fedora
User Name
Password
Fedora This forum is for the discussion of the Fedora Project.

Notices



Reply
 
Search this Thread
Old 05-03-2009, 01:07 PM   #1606
JackRubysDog
Member
 
Registered: Feb 2009
Posts: 40

Rep: Reputation: 15

I'm beginning to really dislike YDL. The distros have nothing! So far I've had to download and compile aclocal, automake, autoconf, even gcc!

Forty-five minutes in and I'm on step 5 of 22.
 
Old 05-03-2009, 01:20 PM   #1607
daftcat
mlbviewer Maintainer
 
Registered: Apr 2008
Posts: 1,767

Rep: Reputation: 76
Quote:
Originally Posted by bennettg View Post
Where can one find RC2 and the readme?
I suppose it wouldn't hurt to grab it a day early. You'll need svn anyway for getting the latest MPlayer.

If you don't already have svn, it's called subversion and it should be available in whichever package management system your Linux distribution uses. You can also get it here.

Once you have svn installed, you will need to checkout mlbviewer:

Code:
svn co https://mlbviewer.svn.sourceforge.net/svnroot/mlbviewer/trunk mlbviewer
Start with the REQUIREMENTS-2009.txt file.

After you've met the requirements and mlbviewer.py starts up okay, you can either give it a go straight away, or you can read the README for more detailed information on mlbviewer.py usage.

Sorry it's not easier but it's a small price to pay for yummy baseball goodness without that choppy flash player.
 
Old 05-03-2009, 01:21 PM   #1608
daftcat
mlbviewer Maintainer
 
Registered: Apr 2008
Posts: 1,767

Rep: Reputation: 76
Quote:
Originally Posted by JackRubysDog View Post
I'm beginning to really dislike YDL. The distros have nothing! So far I've had to download and compile aclocal, automake, autoconf, even gcc!

Forty-five minutes in and I'm on step 5 of 22.
It's good for you. It'll put hair on your chest. You won't be able to call yourself a newbie by the time you reach step 22.
 
Old 05-03-2009, 02:17 PM   #1609
JackRubysDog
Member
 
Registered: Feb 2009
Posts: 40

Rep: Reputation: 15
Quote:
Originally Posted by daftcat View Post
It's good for you. It'll put hair on your chest. You won't be able to call yourself a newbie by the time you reach step 22.
Got to the last step ... and ...

mlbviewer is broke again >

Traceback (most recent call last):
File "mlbviewer.py", line 1225, in ?
curses.wrapper(mainloop, mycfg.data)
File "/usr/lib/python2.4/curses/wrapper.py", line 44, in wrapper
return func(stdscr, *args, **kwds)
File "mlbviewer.py", line 346, in mainloop
raise KeyError,mycoverage
KeyError: '147'

You're doing this on purpose, aren't you?
 
Old 05-03-2009, 03:04 PM   #1610
chomiak
LQ Newbie
 
Registered: Apr 2009
Posts: 28

Rep: Reputation: 15
Autobahn.jar and debian unstable

Running debian unstable I cannot install autobahn.jar. I get the word Aborted. I saw mentions of extracting the pax which may have ben related to this issue but I didn't understand what this meant. Thanks for any help.
 
Old 05-03-2009, 03:15 PM   #1611
poorboywilly
Member
 
Registered: Apr 2009
Posts: 120

Rep: Reputation: 18
Quote:
Originally Posted by JackRubysDog View Post
Got to the last step ... and ...

mlbviewer is broke again >

Traceback (most recent call last):
File "mlbviewer.py", line 1225, in ?
curses.wrapper(mainloop, mycfg.data)
File "/usr/lib/python2.4/curses/wrapper.py", line 44, in wrapper
return func(stdscr, *args, **kwds)
File "mlbviewer.py", line 346, in mainloop
raise KeyError,mycoverage
KeyError: '147'

You're doing this on purpose, aren't you?
I'm getting this error too.
 
Old 05-03-2009, 03:45 PM   #1612
daftcat
mlbviewer Maintainer
 
Registered: Apr 2008
Posts: 1,767

Rep: Reputation: 76
Quote:
Originally Posted by poorboywilly View Post
I'm getting this error too.
Fixed and checked in.
 
Old 05-03-2009, 03:47 PM   #1613
daftcat
mlbviewer Maintainer
 
Registered: Apr 2008
Posts: 1,767

Rep: Reputation: 76
Quote:
Originally Posted by chomiak View Post
Running debian unstable I cannot install autobahn.jar. I get the word Aborted. I saw mentions of extracting the pax which may have ben related to this issue but I didn't understand what this meant. Thanks for any help.
You don't have to worry about pax.

Download the autobahn.jar file from http://mlb.com/nexdef-jars/ and run as:

Code:
java -jar autobahn.jar
You need a java compatible with java version 1.4.1 or newer.
 
Old 05-03-2009, 03:50 PM   #1614
daftcat
mlbviewer Maintainer
 
Registered: Apr 2008
Posts: 1,767

Rep: Reputation: 76
Quote:
Originally Posted by JackRubysDog View Post
Got to the last step ... and ...

mlbviewer is broke again >

Traceback (most recent call last):
File "mlbviewer.py", line 1225, in ?
curses.wrapper(mainloop, mycfg.data)
File "/usr/lib/python2.4/curses/wrapper.py", line 44, in wrapper
return func(stdscr, *args, **kwds)
File "mlbviewer.py", line 346, in mainloop
raise KeyError,mycoverage
KeyError: '147'

You're doing this on purpose, aren't you?
Blame the Yankees!

My stream selection code anticipates that there will be coverage for all games, but it didn't take into account rained out games where the coverage is null. I think I have this fixed now (and checked in) but you guys will put it through its paces. I won't be available until late tonight, so I wish you all luck.
 
Old 05-03-2009, 04:16 PM   #1615
chomiak
LQ Newbie
 
Registered: Apr 2009
Posts: 28

Rep: Reputation: 15
Quote:
Originally Posted by daftcat View Post
You don't have to worry about pax.
Download the autobahn.jar file from http://mlb.com/nexdef-jars/ and run as:

Code:
java -jar autobahn.jar
You need a java compatible with java version 1.4.1 or newer.

Java version says 1.5.0; running command as above; result: Aborted.
 
Old 05-03-2009, 05:04 PM   #1616
Theophile
Member
 
Registered: Jan 2003
Posts: 283

Rep: Reputation: 35
Quote:
Originally Posted by chomiak View Post
Java version says 1.5.0; running command as above; result: Aborted.
Which JRE are you trying to use? I'm running the Sun JRE from the Ubuntu Intrepid repo and it's version 1.6.0_10.
 
Old 05-03-2009, 05:40 PM   #1617
JackRubysDog
Member
 
Registered: Feb 2009
Posts: 40

Rep: Reputation: 15
Quote:
Originally Posted by Theophile View Post
Here, try this page:

http://wiki.ps2dev.org/ps3:mediacenter

Start the instructions about half-way down the page at the heading: "Install SPU Medialib"

Basically, you're going to want to grab the libraries necessary for PS3 accelerated drivers, then the patch for mplayer, then recompile mplayer. If you've already build mplayer from svn, these instructions should be relatively trivial for you at this point.

Good luck!
Didn't work. Tried to start at the place you suggested but there were so many bits missing I had to go back and back until I was on the verge of installing gentoo. So I gave up and jumped forwards, installed libps3fb okay, but then the patch of mplayer didn't work (the fifth bit of the patch failed). Tried mlbviewer with mplayer -vo ps3 -fs -zoom but the video driver errored and wouldn't initialise. So it was so the 2" by 4" window and a telescope to see the Cubs beat the Marlins again

I don't think I've ever got on with mlbviewer and mplayer on the ps3. I used vlc last year. Is videolan about to release a mlbviewer-ready version?
 
Old 05-03-2009, 06:00 PM   #1618
chomiak
LQ Newbie
 
Registered: Apr 2009
Posts: 28

Rep: Reputation: 15
Quote:
Originally Posted by Theophile View Post
Which JRE are you trying to use? I'm running the Sun JRE from the Ubuntu Intrepid repo and it's version 1.6.0_10.
Installed -java6-jre; ran update-java-alternatives --jre --set java-6-sun. I then was able to install autobahn.jar.
 
Old 05-03-2009, 07:00 PM   #1619
chomiak
LQ Newbie
 
Registered: Apr 2009
Posts: 28

Rep: Reputation: 15
sign-on restrictions

It's really frustrating. I'm not logged in to the website and/or games any other way, yet I only get one, or maybe sometimes two, tries with mlbviewer before I get the sign-on restrictions error. Right now am trying with gameday audio though thiking about upgrading to premium. i'm thinking that if an attemptto get a game is unsuccessful, maybe i'm not logged out so when I try again I get the sign-on restriction. Tried removing the cookie and sessionkey but still end up waiting. will it help if I just remove them after an attempt instead of waiting to be banned?
I loved this program last year so am sticking with it till I get things working.
 
Old 05-03-2009, 07:38 PM   #1620
Theophile
Member
 
Registered: Jan 2003
Posts: 283

Rep: Reputation: 35
chomiak,

I can't help with the sign-on restrictions, but to clear up any other confusion, the autobahn.jar is useless unless you have a Premium subscription. That's the backbone of the "NexDef" plugin which is a Premium-only feature.
 
  


Reply

Tags
help, install, installation, instructions, seek, vlc, windows


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
mlb.com gameday audio stream statmobile Linux - Newbie 6 05-06-2008 11:16 PM
link dies intermittently-seemingly at random- between win<->linux not linux<->linux?? takahaya Linux - Networking 10 03-09-2007 11:37 PM
triple boot linux/linux/linux No Windows involved toastermaker Linux - Newbie 12 03-02-2006 11:40 PM
Redhat (rhel v2.1) bootup problem with linux (linux vs linux-up) namgor Linux - Software 2 06-24-2004 03:49 PM


All times are GMT -5. The time now is 01:47 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration