LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Fedora
User Name
Password
Fedora This forum is for the discussion of the Fedora Project.

Notices

Reply
 
Search this Thread
Old 03-23-2005, 01:04 PM   #1
JMCraig
Member
 
Registered: Feb 2003
Location: Utah, USA
Distribution: Red Hat EL/CentOS, Ubuntu/Debian
Posts: 113

Rep: Reputation: 15
Question Missing window controls w/ Gnome


Hi Folks,

I donno what I've messed up, but it's a pain. I've lost my windows controls (minimize, maximize, close, window title bar) when I'm in Gnome. If I switch to KDE (using switchdesk), the window controls are there. Can someone tell me where the critical parameter/setting is located?

Sheesh! (I wish I could even remember/figure out how I got it into this state....)

John
 
Old 03-24-2005, 02:25 AM   #2
Engmar
Member
 
Registered: Oct 2003
Location: The Forest
Distribution: Ubuntu, LFS, DSL
Posts: 127

Rep: Reputation: 16
One thing you could check: Go to the Gnome Configuration Editor (usually under System Tools).
apps -> metacity -> general -> make sure button_layout says something like
Code:
menu:minimize,maximize,close
This would give you the default configuration. If this value is already there I'm not sure what the problem could be.

edit: Ah I see you are missing the whole title bar. In that same area in the Configuration Editor, do you have "application_based" checked off?

edit2: Oh, did you try changing window border themes?

Last edited by Engmar; 03-24-2005 at 02:30 AM.
 
Old 03-24-2005, 09:55 AM   #3
JMCraig
Member
 
Registered: Feb 2003
Location: Utah, USA
Distribution: Red Hat EL/CentOS, Ubuntu/Debian
Posts: 113

Original Poster
Rep: Reputation: 15
No luck so far. New clue?

Engmar, thanks for the suggestions!

The Config. Editor settings are apparently as they should be.

Changing themes changes the colors, but doesn't give me the window controls....

One more clue: If I click on the "Click here to hide all windows and show the desktop" icon, I get this:

"Your window manager does not support the show desktop button, or you are not running a window manager."

So, maybe I don't have a window manager at all.... Where do I find that setting and what should it be?

Thanks!

John
 
Old 03-26-2005, 09:18 AM   #4
Engmar
Member
 
Registered: Oct 2003
Location: The Forest
Distribution: Ubuntu, LFS, DSL
Posts: 127

Rep: Reputation: 16
Wow, strange. Do you have Metacity installed?
 
Old 03-26-2005, 01:36 PM   #5
JMCraig
Member
 
Registered: Feb 2003
Location: Utah, USA
Distribution: Red Hat EL/CentOS, Ubuntu/Debian
Posts: 113

Original Poster
Rep: Reputation: 15
Engmar,

It certainly looks like it's installed. What I presume has happened is that I've inadvertently changed something so that Gnome has no window manager associated with it.

Code:
# rpm -qa | grep metacity
metacity-2.8.6-2
Is there someplace you know of that I should check?

John
 
Old 03-26-2005, 03:31 PM   #6
JMCraig
Member
 
Registered: Feb 2003
Location: Utah, USA
Distribution: Red Hat EL/CentOS, Ubuntu/Debian
Posts: 113

Original Poster
Rep: Reputation: 15
OK; now I have a workaround, but there's got to be someplace to tell it to do this some other way. If I enter:

Code:
#/usr/bin/metacity &
My windows grow title bars and expected icons....

So where is this supposed to be that it isn't?

Thanks,

John
 
Old 03-26-2005, 06:04 PM   #7
Engmar
Member
 
Registered: Oct 2003
Location: The Forest
Distribution: Ubuntu, LFS, DSL
Posts: 127

Rep: Reputation: 16
Have you installed any other window managers ie.Sawfish?

You could try having Gnome save the session settings (after you have restarted Metacity) while logging out, then log back in and see if Metacity comes up.

Of course, unless another window manager is killing off Metacity, none of this answers the question why Metacity crashed in the first place.

Last edited by Engmar; 03-26-2005 at 06:06 PM.
 
Old 03-28-2005, 10:06 AM   #8
JMCraig
Member
 
Registered: Feb 2003
Location: Utah, USA
Distribution: Red Hat EL/CentOS, Ubuntu/Debian
Posts: 113

Original Poster
Rep: Reputation: 15
Thanks for sticking with this! No, I didn't install any other window managers.

For now, with metacity having been started, Gnome is using it (whether I "Save Settings" or not). I'm not sure what'll happen when I reboot.

What script would be the spot that would typically start metacity?

John
 
Old 03-28-2005, 10:26 AM   #9
futhark
Member
 
Registered: Nov 2003
Location: Montréal (Can)
Distribution: FC4
Posts: 110

Rep: Reputation: 15
Happens to me in KDE from time to time, and I restart kwin& manually when it does. It's because the window manager crashes.

If your window borders never appear when you login into gnome, then maybe it's because the win manager crashes on startup or it's not starting at all. Up to you to investigate.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Missing gui controls in xine AntonyW Linux - Newbie 3 10-25-2005 05:06 PM
Changing Gnome controls theme doesn't change look. Nekow42 Linux - Software 2 08-14-2005 08:16 PM
Root window, am i missing the point here? jollyjoice Mandriva 10 11-17-2004 10:08 AM
missing gnome option in gnome-keybinding-properties fedora core 1? lrt2003 Fedora 0 04-18-2004 08:35 PM
GNOME is using KDE controls Projekt2 Debian 8 02-22-2004 08:59 PM


All times are GMT -5. The time now is 04:09 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration