LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Fedora
User Name
Password
Fedora This forum is for the discussion of the Fedora Project.

Notices

Reply
 
Search this Thread
Old 07-12-2005, 02:03 PM   #1
LinuxStart
Member
 
Registered: Nov 2004
Distribution: Shrike
Posts: 55

Rep: Reputation: 15
Messed up httpd.conf in FC4 Help!


Hi, i was toying around in the httpd conf file in FC4 and i messed it up really bad, now httpd wont start. I forgot to make a backup copy of it. I just installed fedora so everything is default.

If anybody could post their default copy of httpd.con especially around lines 800- 900 sinec thats where i was toying aropund, it would be much appreciated.

Please help.

Thank you.
 
Old 07-12-2005, 03:43 PM   #2
masand
Guru
 
Registered: May 2003
Location: INDIA
Distribution: Ubuntu, Solaris,CentOS
Posts: 5,522

Rep: Reputation: 58
why don't u first remove the httpd package and then reinstall that package from the CD

regards
 
Old 07-12-2005, 03:45 PM   #3
LinuxStart
Member
 
Registered: Nov 2004
Distribution: Shrike
Posts: 55

Original Poster
Rep: Reputation: 15
because then i have dependency problems, i would have to remove a whole bunch of other things too.
 
Old 07-12-2005, 03:46 PM   #4
rose_bud4201
Member
 
Registered: Aug 2002
Location: St Louis, MO
Distribution: Xubuntu, RHEL, Solaris 10
Posts: 927

Rep: Reputation: 30
There appears to be a copy here - will that help?
 
Old 07-12-2005, 03:52 PM   #5
LinuxStart
Member
 
Registered: Nov 2004
Distribution: Shrike
Posts: 55

Original Poster
Rep: Reputation: 15
unfortunately it doesnt. that one is quite a bit different from mine
the error im getting is that at line 830 there's an "</Directory>" without a "<Directory>", that part is like totally messed up from 800 to 830.
 
Old 07-12-2005, 04:05 PM   #6
rose_bud4201
Member
 
Registered: Aug 2002
Location: St Louis, MO
Distribution: Xubuntu, RHEL, Solaris 10
Posts: 927

Rep: Reputation: 30
Can you post that section, from wherever you think the starting <DIRECTORY> tag is until line 830? We can try to help you sort it out :-)
 
Old 07-12-2005, 04:10 PM   #7
LinuxStart
Member
 
Registered: Nov 2004
Distribution: Shrike
Posts: 55

Original Poster
Rep: Reputation: 15
# Alias /error/include/ "/your/include/path/"
#
# which allows you to create your own set of files by starting with the
# /var/www/error/include/ files and
# copying them to /your/include/path/, even on<Directory /home/*/public_html>
AllowOverride Options FileInfo AuthConfig Limit
Options Indexes Includes FollowSymLinks SymLinksifOwnerMatch ExecCGI MultiViews
<Limit GET POST OPTIONS>
Order allow,deny
Allow from all
</Limit>
<LimitExcept GET POST OPTIONS>
Order deny,allow
Allow from all
</LimitExcept>
</Directory> a per-VirtualHost basis. (this is the problem line)
#
 
Old 07-12-2005, 04:23 PM   #8
masand
Guru
 
Registered: May 2003
Location: INDIA
Distribution: Ubuntu, Solaris,CentOS
Posts: 5,522

Rep: Reputation: 58
ok
then move the httpd.conf file

install the httpd package by

rpm -ivh --nodeps --force httpd...rpm
 
Old 07-12-2005, 04:28 PM   #9
LinuxStart
Member
 
Registered: Nov 2004
Distribution: Shrike
Posts: 55

Original Poster
Rep: Reputation: 15
error: open of httpd.rpm failed: No such file or directory
 
Old 07-12-2005, 04:47 PM   #10
masand
Guru
 
Registered: May 2003
Location: INDIA
Distribution: Ubuntu, Solaris,CentOS
Posts: 5,522

Rep: Reputation: 58
hey !!
get that rpm from the fedora CD
copy that to some directory
and go to that path

then install ot as i mentioned
and u need to specify the ful file name of the rpm filr httpd
for that
write
rpm -ivh --force httpd
and press TAB
and u will get the ful file name
you need to be in that directory where u have the httpd rpm or specify the path where that httpd rpm is

regards
 
Old 07-12-2005, 05:15 PM   #11
Nathanael
Member
 
Registered: May 2004
Location: Karlsruhe, Germany
Distribution: debian, gentoo, os x (darwin), ubuntu
Posts: 940

Rep: Reputation: 32
how about looking into /usr/share/doc/
in your webserver directory or a httpd directory you might find something like an example directory which could the file you are looking for.
 
Old 07-12-2005, 05:26 PM   #12
rose_bud4201
Member
 
Registered: Aug 2002
Location: St Louis, MO
Distribution: Xubuntu, RHEL, Solaris 10
Posts: 927

Rep: Reputation: 30
Quote:
</Directory> a per-VirtualHost basis. (this is the problem line)
Yeah..httpd.conf works like an HTML document - tags need to be in pairs. So the problem is, you don't have an opening <Directory> tag. The comment right above in the section you pasted seems to say that you're working with the section for /error/include/, and my httpd.conf file says this:

#
# Customizable error responses come in three flavors:
# 1) plain text 2) local redirects 3) external redirects
#
# Some examples:
#ErrorDocument 500 "The server made a boo boo."
#ErrorDocument 404 /missing.html
#ErrorDocument 404 "/cgi-bin/missing_handler.pl"
#ErrorDocument 402 http://www.example.com/subscription_info.html
#

#
# Putting this all together, we can internationalize error responses.
#
# We use Alias to redirect any /error/HTTP_<error>.html.var response to
# our collection of by-error message multi-language collections. We use
# includes to substitute the appropriate text.
#
# You can modify the messages' appearance without changing any of the
# default HTTP_<error>.html.var files by adding the line:
#
# Alias /error/include/ "/your/include/path/"
#
# which allows you to create your own set of files by starting with the
# @exp_errordir@/include/ files and copying them to /your/include/path/,
# even on a per-VirtualHost basis. The default include files will display
# your Apache version number and your ServerAdmin email address regardless
# of the setting of ServerSignature.
#
# The internationalized error documents require mod_alias, mod_include
# and mod_negotiation. To activate them, uncomment the following 30 lines.

# Alias /error/ "@exp_errordir@/"
#
# <Directory "@exp_errordir@">
# AllowOverride None
# Options IncludesNoExec
# AddOutputFilter Includes html
# AddHandler type-map var
# Order allow,deny
# Allow from all
# LanguagePriority en cs de es fr it ja ko nl pl pt-br ro sv tr
# ForceLanguagePriority Prefer Fallback
# </Directory>


Which I take to mean that somehow you copied part of an earlier part of the document into this section. The <LimitExcept> section is waaay earlier - see here

Last edited by rose_bud4201; 07-12-2005 at 05:28 PM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Httpd.conf And Httpd2.conf ???? alejandroye Linux - General 2 11-07-2004 01:23 AM
httpd.conf & ssl.conf kevinm2 Linux - Security 12 08-31-2004 02:25 PM
httpd.conf bumfan Linux - General 1 04-29-2004 06:14 PM
saving changes to apache2/conf/httpd.conf file Zaius Linux - Newbie 6 01-10-2004 12:45 AM
httpd chokes on ScriptAlias line in Apache httpd.conf lhoff Linux - Software 1 07-14-2003 11:32 PM


All times are GMT -5. The time now is 11:53 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration