LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Fedora (http://www.linuxquestions.org/questions/fedora-35/)
-   -   Madwifi-0.9.2 / Fedora 6 install problem (http://www.linuxquestions.org/questions/fedora-35/madwifi-0-9-2-fedora-6-install-problem-524227/)

volekvolek 01-30-2007 07:55 PM

Madwifi-0.9.2 / Fedora 6 install problem
 
HI :

I am trying to build the latest Madwifi-0.9.2 against Fedora 6.
Compile goes ahead with no problem. at make install , I get the follwoing :

[root@localhost 2.6.19-1.2895.fc6-i686]# /sbin/modprobe ath_pci
WARNING: Error inserting ath_hal (/lib/modules/2.6.19-1.2895.fc6/net/ath_hal.ko): Invalid module format
WARNING: Error inserting wlan (/lib/modules/2.6.19-1.2895.fc6/net/wlan.ko): Invalid module format
FATAL: Error inserting ath_pci (/lib/modules/2.6.19-1.2895.fc6/net/ath_pci.ko): Invalid module format
[root@localhost 2.6.19-1.2895.fc6-i686]#

uname -a
Linux localhost.localdomain 2.6.19-1.2895.fc6 #1 SMP Wed Jan 10 18:32:37 EST 2007 i686 i686 i386 GNU/Linux

rpm -q --queryformat '%{NAME}-%{VERSION}-%{RELEASE}.%{ARCH}\n' kernel
kernel-2.6.18-1.2798.fc6.i586
kernel-2.6.19-1.2895.fc6.i586
[root@localhost:

gcc -v = gcc version 4.1.1 20070105 (Red Hat 4.1.1-51)

It was suggested on other threads that this might be due to the wrong kernel binaries "i586", or compiling with different gcc version vs what kernel was compiled with .

Any thoughts ?

unSpawn 01-31-2007 04:00 AM

Any thoughts ?
If yours is a stock kernel-2.6.19-1.2895.fc6.i586, then you can install Madwifi w/o compiling or dkms by downloading the madwifi-hal-kmdl and madwifi-kmdl RPM's for your kernel from Atrpm.

volekvolek 01-31-2007 12:04 PM

Madifi-0.9.2 Fedora 6 install/load problem
 
Thanks unSpawn. I have to say the file names on Atrmp are something to be desired for by the folks who have never visited that site. A notation on top of the page would help as in what file is for what. There are so many version etc. Yes some do make sense and I can tell what kernel and what platform they belong to.

Do I need to install both of the rpm's you mentioned?

I would have liked to compile/install things myself, I might just wait for the next kernel release and give it another try.

Regards

volekvolek 01-31-2007 02:06 PM

uname -a
Linux localhost.localdomain 2.6.19-1.2895.fc6 #1 SMP Wed Jan 10 18:32:37 EST 2007 i686 i686 i386 GNU/Linux


I downloaded ,

madwifi-devel-0.9.3-31_r1865.fc6.at.i386.rpm (Installed)
madwifi-hal-kmdl-2.6.19-1.2895.fc6-0.9.3-31_r1865.fc6.at.i686.rpm
madwifi-kmdl-2.6.19-1.2895.fc6-0.9.3-31_r1865.fc6.at.i686.rpm


However I get a dependency errors on the above files.

rpm -ivh madwifi-kmdl-2.6.19-1.2895.fc6-0.9.3-31_r1865.fc6.at.i686.rpm
error: Failed dependencies:
madwifi-hal-kmdl-2.6.19-1.2895.fc6 = 1:0.9.3-31_r1865.fc6.at is needed by madwifi-kmdl-2.6.19-1.2895.fc6-0.9.3-31_r1865.fc6.at.i686
[root@localhost downloads]#

rpm -i madwifi-hal-kmdl-2.6.19-1.2895.fc6-0.9.3-31_r1865.fc6.at.i686.rpm
error: Failed dependencies:
madwifi-kmdl-2.6.19-1.2895.fc6 = 1:0.9.3-31_r1865.fc6.at is needed by madwifi-hal-kmdl-2.6.19-1.2895.fc6-0.9.3-31_r1865.fc6.at.i686


same results if I change the order .

Any thoughts ?

unSpawn 01-31-2007 03:45 PM

I have to say the file names on Atrmp are something to be desired for
That's a bloody understatement...


Do I need to install both of the rpm's you mentioned?
Yes. Try "rpm --test -i madwifi-kmdl-2.6.19-1.2895.fc6-0.9.3-31_r1865.fc6.at.i686.rpm madwifi-hal-kmdl-2.6.19-1.2895.fc6-0.9.3-31_r1865.fc6.at.i686.rpm", then if there's no probs remove the "--test" flag.


I would have liked to compile/install things myself
I always do too, favouring configurability and stability over generic stuff, but I got FC6 installed to play with and I must say this works well, no WPA probs or whatever. Only thing was Atheros isn't mentioned in the system-config-network tools if you configure a new wireless connection like you would expect (..) so just populate a /etc/sysconfig/network-scripts/ifcfg-ath0 with the right parameters from ifup-wireless.


All times are GMT -5. The time now is 03:32 AM.