LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Fedora (http://www.linuxquestions.org/questions/fedora-35/)
-   -   Long pause during boot up (http://www.linuxquestions.org/questions/fedora-35/long-pause-during-boot-up-189728/)

the theorist 06-04-2004 02:08 PM

Long pause during boot up
 
I get a two minute pause during bootup on my Fedora 2 machine. Right after picking the kernel on the grub menu, the last line you see is: audit: (02423----big long number---2343) initialized. Then comes two minutes of nothing, and then the normal service startup display starts (with the OK or FAIL and so on).

What's the deal with the pause? Can I stop it? I don't know what scripts or programs are controlling the boot up sequence at that point. I don't know what the audit line is for, either.

moax_cp 06-04-2004 02:10 PM

I am having this same problem but I have not idea what is causing it.

darthtux 06-04-2004 02:44 PM

From a Fedora2 FAQ

Q:.
How do I turn system-call auditing on/off at boot?

A:.
Add audit=1 to your kernel command line to turn system-call auditing on. Add audit=0 to your kernel command line to turn system-call auditing off.

System-call auditing is off by default. When on, it provides information about the system-call that was executing when SELinux generated a denied message. This may be helpful when debugging policy.

the theorist 06-04-2004 05:02 PM

darthtux: Assuming the "kernel command line" is in the relevant section of grub.conf, I changed the kernel line to (just adding audit=0)
Code:

kernel /vmlinuz-2.6.6 ro root=LABEL=/ rhgb quiet audit=0
I rebooted and still had the pause. Maybe your post was meant purely as relevant information and not a fix. Either way, I still have a big annoying pause.

aline 06-04-2004 06:39 PM

Just keep kernel /vmlinuz-2.6.6 ro root=LABEL=/ in your grub.conf. You'll see all kernel messages and any problem that is causing the delay, my guess is that not having any kernel messages makes the boot-process seem to take longer.

the theorist 06-05-2004 01:01 AM

aline: I've kept the original kernel command line. But your message reminded me I should look in /var/log/dmesg for any error messages from bootup! There's a lot of stuff in there; most of it apparently being kudzu messages for hardware detection.

Below is the section about detecting disk drives. I have one SATA hard drive which gets detected as /dev/hde, and one IDE optical drive at /dev/hdc. Could the non-detection of /dev/hdg be hanging bootup for a couple minutes? I didn't even think my motherboard (ASUS A7N8X-E Deluxe) could have more than two SATA drives (which would be hde and hdf). moax_cp, do you have a similar situation?

Code:

ide: Assuming 33MHz system bus speed for PIO modes; override with idebus=xx
NFORCE2: IDE controller at PCI slot 0000:00:09.0
NFORCE2: chipset revision 162
NFORCE2: not 100% native mode: will probe irqs later
NFORCE2: 0000:00:09.0 (rev a2) UDMA133 controller
    ide0: BM-DMA at 0xf000-0xf007, BIOS settings: hda:DMA, hdb:DMA
    ide1: BM-DMA at 0xf008-0xf00f, BIOS settings: hdc:DMA, hdd:DMA
hdc: LITE-ON DVDRW SOHW-812S, ATAPI CD/DVD-ROM drive
Using anticipatory io scheduler
ide1 at 0x170-0x177,0x376 on irq 15
SiI3112 Serial ATA: IDE controller at PCI slot 0000:01:0b.0
SiI3112 Serial ATA: chipset revision 2
SiI3112 Serial ATA: 100% native mode on irq 11
    ide2: MMIO-DMA , BIOS settings: hde:pio, hdf:pio
    ide3: MMIO-DMA , BIOS settings: hdg:pio, hdh:pio
hde: ST3160023AS, ATA DISK drive
ide2 at 0xe084d080-0xe084d087,0xe084d08a on irq 11
hdg: no response (status = 0xfe)
hdg: no response (status = 0xfe), resetting drive
hdg: no response (status = 0xfe)

hde: max request size: 64KiB
hde: 312581808 sectors (160041 MB) w/8192KiB Cache, CHS=19457/255/63
 hde: hde1 hde2 hde3 hde4
hdc: ATAPI 63X DVD-ROM DVD-R CD-R/RW drive, 2048kB Cache, UDMA(33)
Uniform CD-ROM driver Revision: 3.20
ide-floppy driver 0.99.newide

How could I stop detection of /dev/hdg, if thats the problem? Nothing else looked too bad in dmesg.

aline 06-05-2004 04:29 AM

See how your bios configuration looks. Your bios might report a device that actually doesn't exist. But I think that this is a SATA issue, put hdg=noprobe or hdg=none to your kernel line to ignore hdg.

the theorist 06-05-2004 01:51 PM

aline: Your advice about hdg=none worked great! Now there is almost no pause at that step during boot.
So my kernel command line is
Code:

kernel /vmlinuz-2.6.6 ro root=LABEL=/ rhgb quiet hdg=none
I didn't see anything for SATA configuration in my BIOS. There is a RAID utility, but since I only have one SATA drive it doesn't do anything.

Thanks!


All times are GMT -5. The time now is 01:03 AM.