LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Fedora (http://www.linuxquestions.org/questions/fedora-35/)
-   -   login error can's start session due to internal error (http://www.linuxquestions.org/questions/fedora-35/login-error-cans-start-session-due-to-internal-error-472622/)

wiisikke 08-10-2006 07:36 AM

login error can's start session due to internal error
 
i've a problem starting fc5

Everything is starting up OK.
the loginbox appears
When i login with a user or as root i get an error:

Cannot start the session due to some internal error"

Then I get the description in another error message and it states

/etc/gdm/Presession/Default: Registering your session with wtmp and utmp
/etc/gdm/Presession/Default: running: /usr/bin/sessreg -a -w /var/log/wtmp -u /var/run/utmp -x "var/gdm/:0.Xservers" -h "" -1 ":0" "josien"
session_child_run: could not exec /etc/X11/xinit/xsession gnome-session

If I start in failsafe mode it gives a simular error.

the only way to get a terminal is to use linux rescue.

can anyone plase help.

Lenard 08-10-2006 08:54 AM

Try turning off selinux at boottime;

When the grub splash screen is displayed press any key

Select the Linux boot choice and press the 'e' key

Select the kernel line and press the 'e' key again

At the end of the line add a space followed by selinux=0

When done press the 'Enter' key followed by the 'b' key

If you can log on then you need to adjust your selinux security policy or disable selinux permanently.

http://fedora.redhat.com/docs/selinux-faq-fc5/

wiisikke 08-10-2006 09:03 AM

Thanks Lenard,

it works fine again thanks a lot !!!

send2amitgandhi 05-11-2010 01:29 AM

Quote:

Originally Posted by Lenard (Post 2374009)
Try turning off selinux at boottime;

When the grub splash screen is displayed press any key

Select the Linux boot choice and press the 'e' key

Select the kernel line and press the 'e' key again

At the end of the line add a space followed by selinux=0

When done press the 'Enter' key followed by the 'b' key

If you can log on then you need to adjust your selinux security policy or disable selinux permanently.

http://fedora.redhat.com/docs/selinux-faq-fc5/

Thanks ..dear then solution works for me ...

Best regards,
Amit Gandhi


All times are GMT -5. The time now is 02:28 AM.