LinuxQuestions.org
LinuxAnswers - the LQ Linux tutorial section.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Fedora
User Name
Password
Fedora This forum is for the discussion of the Fedora Project.

Notices

Reply
 
Search this Thread
Old 08-10-2006, 08:36 AM   #1
wiisikke
LQ Newbie
 
Registered: Aug 2006
Distribution: fedora FC-5
Posts: 2

Rep: Reputation: 0
login error can's start session due to internal error


i've a problem starting fc5

Everything is starting up OK.
the loginbox appears
When i login with a user or as root i get an error:

Cannot start the session due to some internal error"

Then I get the description in another error message and it states

/etc/gdm/Presession/Default: Registering your session with wtmp and utmp
/etc/gdm/Presession/Default: running: /usr/bin/sessreg -a -w /var/log/wtmp -u /var/run/utmp -x "var/gdm/:0.Xservers" -h "" -1 ":0" "josien"
session_child_run: could not exec /etc/X11/xinit/xsession gnome-session

If I start in failsafe mode it gives a simular error.

the only way to get a terminal is to use linux rescue.

can anyone plase help.
 
Old 08-10-2006, 09:54 AM   #2
Lenard
Senior Member
 
Registered: Dec 2005
Location: Indiana
Distribution: RHEL/CentOS/SL 5 i386 and x86_64 pata for IDE in use
Posts: 4,790

Rep: Reputation: 56
Try turning off selinux at boottime;

When the grub splash screen is displayed press any key

Select the Linux boot choice and press the 'e' key

Select the kernel line and press the 'e' key again

At the end of the line add a space followed by selinux=0

When done press the 'Enter' key followed by the 'b' key

If you can log on then you need to adjust your selinux security policy or disable selinux permanently.

http://fedora.redhat.com/docs/selinux-faq-fc5/
 
Old 08-10-2006, 10:03 AM   #3
wiisikke
LQ Newbie
 
Registered: Aug 2006
Distribution: fedora FC-5
Posts: 2

Original Poster
Rep: Reputation: 0
Thanks Lenard,

it works fine again thanks a lot !!!
 
Old 05-11-2010, 02:29 AM   #4
send2amitgandhi
LQ Newbie
 
Registered: Oct 2008
Posts: 2

Rep: Reputation: 0
Quote:
Originally Posted by Lenard View Post
Try turning off selinux at boottime;

When the grub splash screen is displayed press any key

Select the Linux boot choice and press the 'e' key

Select the kernel line and press the 'e' key again

At the end of the line add a space followed by selinux=0

When done press the 'Enter' key followed by the 'b' key

If you can log on then you need to adjust your selinux security policy or disable selinux permanently.

http://fedora.redhat.com/docs/selinux-faq-fc5/
Thanks ..dear then solution works for me ...

Best regards,
Amit Gandhi
 
  


Reply

Tags
login


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
start qt error show session management error... wylhistory Linux - Software 2 05-04-2009 05:32 AM
Error while trying to start a program on a local X session. Vorik Linux - Software 0 01-28-2005 02:50 PM
Error USB-HUC on booting due in mdk10 due to mx700 Boudewijn Mandriva 4 10-09-2004 09:36 AM
can't start remote X session PAM error felkin Linux - General 6 08-25-2004 09:27 PM
I can't start Win XP due to disk error after RH9 instalation ! sydzmizaar Linux - General 5 11-24-2003 04:35 AM


All times are GMT -5. The time now is 03:36 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration