LinuxQuestions.org
Did you know LQ has a Linux Hardware Compatibility List?
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Fedora
User Name
Password
Fedora This forum is for the discussion of the Fedora Project.

Notices



Reply
 
Search this Thread
Old 01-25-2004, 08:16 PM   #1
hecresper
Member
 
Registered: Dec 2002
Location: California
Distribution: Slackware & FreeBSD
Posts: 169

Rep: Reputation: 30
Loaded madwifi drivers but still can't use wireless card


Hi,

I'm very happy with Fedora Core 1 on my laptop. I got the ethernet pcmcia card working without a problem, but I have a wireless card for this laptop, too. I knew about the MADWIFI project for Atheros-chipset based cards like mine. I used the MADWIFI drivers in Slackware before on this same laptop.

These are the steps I took to get started installing the wireless card with MADWIFI:

installed the development and kernel source packages
installed sharutils package
downloaded the latest cvs tree from madwifi to a local folder
ran make
ran make install
rebooted

The laptop sees that hardware is there, but I cannot get it to connect to the network.

I placed the following commands in /etc/rc.local:

ifconfig ath0 up
ifconfig ath0 192.168.1.21
iwpriv ath0 mode 1 <-- to force 802.11a

The device seems to be working but cannot ping other computers, much less ping a web site outside of my home network.

What am I missing?

Thanks.

Last edited by hecresper; 01-25-2004 at 08:18 PM.
 
Old 01-25-2004, 08:27 PM   #2
jtshaw
Senior Member
 
Registered: Nov 2000
Location: Seattle, WA USA
Distribution: Ubuntu @ Home, RHEL @ Work
Posts: 3,892
Blog Entries: 1

Rep: Reputation: 66
You need to add a default route to that uses that interface.

You do this using the route command. You can find information on that command by doing man route.
 
Old 01-26-2004, 01:12 AM   #3
hecresper
Member
 
Registered: Dec 2002
Location: California
Distribution: Slackware & FreeBSD
Posts: 169

Original Poster
Rep: Reputation: 30
Well, since I might use this laptop else where besides my home network, I decided that the wifi card should use dhcp.

The thing is I was using the wrong command. I shouldve been using dhclient ath0 to get IP addy from my home dhcp server.

But there is still an issue. After typing dhclient ath0, I get the following output over and over:

/sbin/dhclient-script: configuration for ath0 not found.
Listening on LPF/ath0/00:06:25:0c:ad:c8
Sending on LPF/ath0/00:06:25:0c:ad:c8
Sending on Socket/fallback
DHCPDISCOVER on ath0 to 255.255.255.255 port 67 interval 5
DHCPOFFER from 192.168.1.1
DHCPREQUEST on ath0 to 255.255.255.255 port 67
DHCPACK from 192.168.1.1

So it is communicating with the dhcp server, but something is preventing the card from getting the offered addy. I goggled with the first line as a search criteria but nothing turns up that relates to my issue.
 
Old 01-26-2004, 12:13 PM   #4
hecresper
Member
 
Registered: Dec 2002
Location: California
Distribution: Slackware & FreeBSD
Posts: 169

Original Poster
Rep: Reputation: 30
I dropped into the #redhat channel at irc.freenode.net and someone asked me if I had ifcfg-ath0 in place. I created the missing script, which was no easy task. It took some trial and error to get the script just right.

I saved the script in:

/etc/sysconfig/network-scripts/

and

/etc/sysconfig/networking/devices/

as ifcfg-ath0.

Note: I'll post the script contents when I get home today.

Well, even after putting tha script in place, I'm still having issues. The wireless card gets initialized, it grabs an IP address and I can surf the 'net or ping other computers for only 5 secs. The it drops the connection but it comes back. When the connection comes back, it is super slow.

Laptop Specs:

Pentium 3 - 500MHz
256MB RAM
8GB Hard Drive
2 Batteries
WiFi Card: Linksys WPC51AB
WiFi Drivers: From MADWIFI Project @ Sourceforget.net
OS: Fedora Core 1
 
Old 01-27-2004, 09:20 AM   #5
hecresper
Member
 
Registered: Dec 2002
Location: California
Distribution: Slackware & FreeBSD
Posts: 169

Original Poster
Rep: Reputation: 30
Here is my edited ifcfg-ath0 script:

ONBOOT='yes'
DEVICE='ath0'
BOOTPROTO='dhcp'
HWADDR='00:06:25:0c:ad:c8'
WIRELESS='yes'
WIRELESS_MODE='automatic'
WIRELESS_ESSID='MyHome'
WIRELESS_IWPRIV_OPTIONS='mode 1'

I've also added this line in /etc/modules.conf:

alias ath0 ath_hal

When I use STARTUPMODE='hotplug', the card still doesn't work.

Also, when I use the command: ifup ath0, I get the following message:

Cannot get driver information: Operation Not Supported

Then it gets stuck on:

Determining IP information for ath0...

Last edited by hecresper; 01-27-2004 at 08:59 PM.
 
Old 01-27-2004, 08:59 PM   #6
hecresper
Member
 
Registered: Dec 2002
Location: California
Distribution: Slackware & FreeBSD
Posts: 169

Original Poster
Rep: Reputation: 30
Someone out there has got to have a laptop with RedHat installed on it and using an Atheros-based wireless card. I cannot be the only person in the Linux world doing this.

Please Help!

Thanks.
 
Old 01-28-2004, 12:24 AM   #7
jost_d
LQ Newbie
 
Registered: Mar 2003
Location: California
Distribution: Fedora
Posts: 3

Rep: Reputation: 0
Smile

RedHat 9 and Fedora 1 come with a useful configuration utility called 'redhat-config-network' or 'neat'. This utility works nicely in setting up the ifcfg-eth0 (...) files including wireless support. The only problem: you cannot enter ath0 as a hardware device. But there is an easy workaround:
1) delete the ifcfg-ath0 files (the one I have seen posted above, is wrong)
2) create a new wireless configuration using 'neat', naming the configuration ath0 using the device eth0.
3) edit the ifcfg-ath0 files and change the DEVICE entry from eth? to ath0
4) plugin your wireless card and everything should happen automagically.

here is my ifcfg-ath0 file:
[root@lopi network-scripts]# more ifcfg-ath0
# Please read /usr/share/doc/initscripts-*/sysconfig.txt
# for the documentation of these parameters.
USERCTL=yes
PEERDNS=yes
GATEWAY=
ONBOOT=no
TYPE=Wireless
DHCP_HOSTNAME=lopi
IPADDR=
DEVICE=ath0
HWADDR=00:0x:yy:zz:aa:bb
BOOTPROTO=dhcp
DOMAIN=
NETMASK=
ESSID=
CHANNEL=
MODE=Managed
RATE=Auto
IWPRIV="mode 2"

NOTE
Fedora now stores WEP keys in a separate file. But 'neat' takes care of that.

CAUTION
some applications cache routing and resolve information such as kde, mozilla, and sendmail. So, if you have any of these running while your wireless network comes online, you need to restart them -- or, much better, do the following:
1) install and enable nscd.
2) create a script called '/etc/dhclient-exit-hooks' which contains the lines
sleep 5 # let's hope the interface is bound by now
/sbin/service nscd restart
/sbin/service sendmail restart

that's it, hope this helps

PS
another RedHat caveat is that if you unplug the wireless card (or shutting down PCMCIA during suspend), hotplug (ie cardmgr) does not correctly down the iface: the dhclient daemon stays running. When the card is then activated again, there are two dhclient daemons. Therefore, in setups where the card is shut down during suspend I recommend killing all dhclient daemons in the suspend scripts.
 
Old 01-28-2004, 02:40 AM   #8
hecresper
Member
 
Registered: Dec 2002
Location: California
Distribution: Slackware & FreeBSD
Posts: 169

Original Poster
Rep: Reputation: 30
Thanks for your reply.

That is some great information.

I was not able to get the card configured by using the ifcfg script.
I have to issue the ifconfig and iwconfig commands manually for it to work.
I don't know why that is.
Also there is something flaky and I don't know if it's my AP or the card itself.

My final solution was to create a text file with the commands I typed in term and made that file executable. Then I placed a link to it on my desktop.

Oh! For some reason the card does not like to be in the system while is booting. LOL

After a shutdown or right before it starts loading the kernel, the card has to be out. Weird!

Thanks for everyone's input in this huge tinkering session.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
How do I install madwifi wireless drivers? xxsubz78x Linux - Newbie 19 09-28-2005 09:04 PM
madwifi drivers for HL W400 wireless PCI ftorcal Linux - Hardware 0 01-20-2005 10:03 AM
madwifi wireless NIC drivers quit after kernel upgrade m_a_b Linux - Laptop and Netbook 5 08-16-2004 12:35 PM
wireless drivers loaded and working, but no ip address, and can't use internet versaulis Linux - Wireless Networking 0 06-30-2004 03:09 PM
wireless card modules not loaded if eth0 not connected denchi Linux - Wireless Networking 1 03-14-2004 08:26 PM


All times are GMT -5. The time now is 08:18 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration