LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Fedora
User Name
Password
Fedora This forum is for the discussion of the Fedora Project.

Notices



Reply
 
Search this Thread
Old 04-04-2006, 03:46 AM   #1
huru
LQ Newbie
 
Registered: Mar 2006
Location: Trondheim - Norway
Distribution: Fedora Core 5
Posts: 16

Rep: Reputation: 0
Load modules (ndiswrapper) at boot in FC5


Hi, what is the correct method to make a module load at boot time in Fedora Core 5.
In the ndiswrapper-WiKi it says to add a "ndiswrapper" line in /etc/modules, but this file/directory doesn't exist. I've read something somewhere about putting modprobe ndiswrapper in /etc/rc.d/rc.local but I suspect that isn't the correct method.
 
Old 04-04-2006, 09:38 AM   #2
Lenard
Senior Member
 
Registered: Dec 2005
Location: Indiana
Distribution: RHEL/CentOS/SL 5 i386 and x86_64 pata for IDE in use
Posts: 4,790

Rep: Reputation: 56
Try putting the file in /etc/modprobe.d or try doing;

locate modprobe.conf.dist

to find where to put it.
 
Old 04-07-2006, 05:00 AM   #3
huru
LQ Newbie
 
Registered: Mar 2006
Location: Trondheim - Norway
Distribution: Fedora Core 5
Posts: 16

Original Poster
Rep: Reputation: 0
I have the ndiswrapper file containing "alias wlan0 ndiswrapper", but this (as it says in the ndiswrapper install wiki) doesn't load the module automatically at boot time.
I've tried to put "modprobe ndiswrapper" in /etc/rc.d/rc.local, and this loads the module, but NetworkManager doesn't list the wireless option. If I restart the NetworkManager service the wireless comes up fine. The same thing happens when I load the module manually, so I suspect the NetworkManager is started before "modprobe ndiswrapper" is loaded. So again... Where do I put "ndiswrapper" or "modprobe ndiswrapper" or whatever to make the module load when it should (before NetworkManager is started at least) at boot time?
 
Old 04-07-2006, 07:29 AM   #4
Lenard
Senior Member
 
Registered: Dec 2005
Location: Indiana
Distribution: RHEL/CentOS/SL 5 i386 and x86_64 pata for IDE in use
Posts: 4,790

Rep: Reputation: 56
Put the ndiswrapper file in the folder /etc/modprobe.d or add the line "alias wlan0 ndiswrapper" to the /etc/modprobe.conf file.
 
Old 04-07-2006, 01:26 PM   #5
huru
LQ Newbie
 
Registered: Mar 2006
Location: Trondheim - Norway
Distribution: Fedora Core 5
Posts: 16

Original Poster
Rep: Reputation: 0
Already tried that... lsmod show no ndiswrapper loaded after reboot. I still have to modprobe and restart NetworkManager.
 
Old 04-07-2006, 02:57 PM   #6
Lenard
Senior Member
 
Registered: Dec 2005
Location: Indiana
Distribution: RHEL/CentOS/SL 5 i386 and x86_64 pata for IDE in use
Posts: 4,790

Rep: Reputation: 56
OK, quick question is your Fedora Core 5 installation the 64-bit version?

Please update your profile to reflect the Distribution in either case and if x86_64 also reflect that.

The reason I'm asking if your running x86_64 is a known bug with the 64-bit Broadcom Corporation BCM4318 [AirForce One 54g] drivers, they need to start them twice.

Try in your /etc/rc.d/rc.local file doing;

/sbin/modprobe -r ndiswrapper
/sbin/modprobe ndiswrapper
/sbin/ifup wlan0
 
Old 04-07-2006, 03:57 PM   #7
huru
LQ Newbie
 
Registered: Mar 2006
Location: Trondheim - Norway
Distribution: Fedora Core 5
Posts: 16

Original Poster
Rep: Reputation: 0
The distribution I use is Fedora Core 5 (not 64bit). There is no ndiswrapper line in dmesg right after boot.
 
Old 04-07-2006, 04:24 PM   #8
Lenard
Senior Member
 
Registered: Dec 2005
Location: Indiana
Distribution: RHEL/CentOS/SL 5 i386 and x86_64 pata for IDE in use
Posts: 4,790

Rep: Reputation: 56
Then you might want to read this (I just found it myself);

http://www.linuxquestions.org/linux/..._Fedora_Core_5
 
Old 04-07-2006, 05:35 PM   #9
huru
LQ Newbie
 
Registered: Mar 2006
Location: Trondheim - Norway
Distribution: Fedora Core 5
Posts: 16

Original Poster
Rep: Reputation: 0
Yes I'v seen it. But I can't see any relevant answers in it. Everything compiles fine, and the driver installs just fine. The module loads, and I'm typing this wireless. I can't remember that this was a problem in FC4. Did it have /etc/modules ?
In the FC5 release notes (http://fedora.redhat.com/docs/releas...fc5/#id3092853) it says:
"The udev method now handles all module loading, both on system boot and for hotplugged devices."
Is this the answer? If so, how to...?
 
Old 04-07-2006, 06:06 PM   #10
Lenard
Senior Member
 
Registered: Dec 2005
Location: Indiana
Distribution: RHEL/CentOS/SL 5 i386 and x86_64 pata for IDE in use
Posts: 4,790

Rep: Reputation: 56
No, I do not think so..... see that I'm running a custom CentOS4.3 system which has the udev and hal versions (rebuilt from the source) from FC5 installed without any issues with my wireless, except I have to load the driver twice (the bug I mentioned). Some times selinux can be a problem, try turning it off at boot time and see what happens;

http://fedora.redhat.com/docs/selinu...fc5/#id2978670

What does the command 'ndiswrapper -l' show?
 
Old 04-08-2006, 11:24 AM   #11
huru
LQ Newbie
 
Registered: Mar 2006
Location: Trondheim - Norway
Distribution: Fedora Core 5
Posts: 16

Original Poster
Rep: Reputation: 0
# ndiswrapper -l
Installed drivers:
bcmwl5 driver installed, hardware present

Now I have inserted the modprobe commands + ifup in .../rc.local as suggested above.
The module loads after NetworkManager is started, and NetworkManager doesn't know of any wireless connection before it is restarted.
In /var/log/messages (only relevant parts) (all of this happens at boot)
Code:
Apr  8 16:36:58 localhost NetworkManager: <information> starting...
Apr  8 16:36:58 localhost kernel: ADDRCONF(NETDEV_UP): eth0: link is not ready
Apr  8 16:36:58 localhost NetworkManager: <information> eth0: Device is fully-supported using driver 'tg3'.
Apr  8 16:36:58 localhost NetworkManager: <information> nm_device_init(): waiting for device's worker thread to start
Apr  8 16:36:58 localhost NetworkManager: <information> nm_device_init(): device's worker thread started, continuing.
Apr  8 16:36:58 localhost NetworkManager: <information> Now managing wired Ethernet (802.3) device 'eth0'.
Apr  8 16:36:58 localhost NetworkManager: <information> Deactivating device eth0.
Apr  8 16:36:59 localhost kernel: ndiswrapper version 1.11 loaded (preempt=no,smp=no)
Apr  8 16:36:59 localhost kernel: ndiswrapper: driver bcmwl5 (Broadcom,11/02/2005, 4.10.40.0) loaded
Apr  8 16:36:59 localhost kernel: ACPI: PCI Interrupt 0000:03:03.0[A] -> GSI 17
(level, low) -> IRQ 18
Apr  8 16:36:59 localhost kernel: ndiswrapper: using irq 18
Apr  8 16:37:00 localhost kernel: wlan0: vendor: ''
Apr  8 16:37:00 localhost kernel: wlan0: ndiswrapper ethernet device 00:14:a5:4f:3f:b0 using driver bcmwl5, 14E4:4318.5.conf
Apr  8 16:37:00 localhost kernel: wlan0: encryption modes supported: WEP; TKIP with WPA, WPA2, WPA2PSK; AES/CCMP with WPA, WPA2, WPA2PSK
Apr  8 16:37:00 localhost kernel: ndiswrapper (iw_set_bitrate:520): setting bit
rate failed (C00000BB)
Then I do "service NetworkManager restart" and get: (not in boot anymore:-)

Code:
Apr  8 16:45:12 localhost NetworkManager: <information> Caught terminiation signal
Apr  8 16:45:12 localhost NetworkManager: <information> Deactivating device eth0.
Apr  8 16:45:12 localhost NetworkManager: <information> starting...
Apr  8 16:45:12 localhost NetworkManager: <information> wlan0: Device is fully-supported using driver 'ndiswrapper'.
Apr  8 16:45:12 localhost NetworkManager: <information> nm_device_init(): waiting for device's worker thread to start
Apr  8 16:45:12 localhost NetworkManager: <information> nm_device_init(): device's worker thread started, continuing.
Apr  8 16:45:12 localhost NetworkManager: <information> Now managing wireless (802.11) device 'wlan0'.
Apr  8 16:45:12 localhost NetworkManager: <information> Deactivating device wlan0.
Apr  8 16:45:14 localhost NetworkManager: <information> eth0: Device is fully-supported using driver 'tg3'.
Apr  8 16:45:14 localhost NetworkManager: <information> nm_device_init(): waiting for device's worker thread to start
Apr  8 16:45:14 localhost NetworkManager: <information> nm_device_init(): device's worker thread started, continuing.
Apr  8 16:45:14 localhost NetworkManager: <information> Now managing wired Ethernet (802.3) device 'eth0'.
Apr  8 16:45:14 localhost NetworkManager: <information> Deactivating device eth0.
Apr  8 16:45:14 localhost NetworkManager: <information> Updating allowed wireless network lists.
Apr  8 16:45:15 localhost NetworkManager: <information> SWITCH: no current connection, found better connection 'wlan0'.
Apr  8 16:45:15 localhost NetworkManager: <information> Activated the DHCP daemon /sbin/dhcdbd with PID 3027.
 
Old 04-08-2006, 01:27 PM   #12
Lenard
Senior Member
 
Registered: Dec 2005
Location: Indiana
Distribution: RHEL/CentOS/SL 5 i386 and x86_64 pata for IDE in use
Posts: 4,790

Rep: Reputation: 56
The 'ndiswrapper -l' command output looks good, you may want to consider updating to ndiswrapper 1.12, from the ChangeLog file;

Version 1.12 2006-04-04
======================
* Sis163 USB driver with version 1.11 failed to associate reliably. This is
fixed.
* TI 1450 USB driver failed to initialize card if module is reloaded. This is
fixed.
* WPA with TKIP with TI ACX100 driver now works with 'ap_scan=2' in
wpa_supplicant's configuration file. Driver for D-Link DWL-650+ has support
for WPA with TKIP for this chipset.
* Added support for non-encrypted networks with wpa_supplicant.
* Am1772 with WPA and TKIP authenticates reliably now.
* Compilation issue with 2.4 kernels fixed.
* Added support for WEP with wpa_supplicant through 'wext' driver
interface. There is no need for 'ndiswrapper' interface with wpa_supplicant
anymore.
* Fixed an issue with 64-bit USB drivers. No 64-bit USB driver is known to
work, though.


Do not know if any of the changes apply to your hardware or not. Ndiswrapper is crashing at boot [ndiswrapper (iw_set_bitrate:520): setting bitrate failed (C00000BB)] which could mean the driver (bcmwl5) is close but not quite right or is one of the bugs fixed in ndiswrapper 1.12.
 
Old 04-08-2006, 03:06 PM   #13
huru
LQ Newbie
 
Registered: Mar 2006
Location: Trondheim - Norway
Distribution: Fedora Core 5
Posts: 16

Original Poster
Rep: Reputation: 0
The update to 1.12 was straight forward, but there was no change. I don't think there is any problem with the driver at all, rather that the module isn't loaded before the NetworkManager is started. I found the reason for the ndiswrapper (iw_set_bitrate:520): setting bitrate failed (C00000BB)]: Every time "ifup wlan0" is run it appears in dmesg. But when I use NetworkManager "ifup " doesn't work (since dhclient is already running).

Do you use NetworkManager?
 
Old 04-08-2006, 05:50 PM   #14
Lenard
Senior Member
 
Registered: Dec 2005
Location: Indiana
Distribution: RHEL/CentOS/SL 5 i386 and x86_64 pata for IDE in use
Posts: 4,790

Rep: Reputation: 56
No, I have no reason to and it is not even installed on any of my systems. If I move my laptop from home or work to wherever and I want to access the Internet, I just connect to one of the open places I frequent(DHCP connection), the ones that are not I already have scripts available to connect with (4thStreet is one of them).

Basically the scripts go like;

ifdown wlan0
sudo service network restart
ifup wlan0[-XXXX]*
*one of the places that requires a password or some other response

Not had a problem since I started using wireless in 1996.
 
Old 04-08-2006, 06:00 PM   #15
huru
LQ Newbie
 
Registered: Mar 2006
Location: Trondheim - Norway
Distribution: Fedora Core 5
Posts: 16

Original Poster
Rep: Reputation: 0
Solution?!?!?!?
After reading "/etc/rc.d/rc.sysinit" I found that usermodules should lie in "/etc/sysconfig/modules/*.modules" as executables, and did (echo "modprobe ndiswrapper" >> my.modules; chmod ugo+x my.modules). Now NetworkManager starts the wireless automatically after I log in. Now I'm satisfied, but if anyone have a more proper solution, or can confirm that this was the proper way to do it, I'm listening:-)

Last edited by huru; 04-08-2006 at 06:05 PM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
how to get ndiswrapper to load at boot time master Linux - Wireless Networking 3 02-25-2006 05:33 PM
ndiswrapper wouldn't load on boot sguen Slackware 5 07-28-2005 03:46 PM
load modules at boot coldsalmon Linux - Newbie 4 04-21-2005 05:36 PM
Load modules at boot martincho Linux - Networking 2 11-27-2004 11:12 AM
Modules don't seem to load on boot ViNsAniTy Linux - Newbie 4 04-21-2004 01:40 PM


All times are GMT -5. The time now is 10:35 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration