LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Fedora
User Name
Password
Fedora This forum is for the discussion of the Fedora Project.

Notices



Reply
 
Search this Thread
Old 09-03-2006, 10:23 AM   #1
spacecoyote
LQ Newbie
 
Registered: Sep 2006
Posts: 3

Rep: Reputation: 0
Exclamation Key repeat on graphical login screen is too fast, Its almost impossible to login. FC5


I just installed Fedora Core 5 from a DVD. But I can barely login as the key repeat is too fast. Changing the settings in the control panel didn't affect it. My BIOS has no keyboard options.

Also, GNOME freezes very easily right now. Not a big deal though as I prefer KDE, and it works just fine. Also the graphical package manager gives an error when detecting installed packages (or something like that, I can't remember exactly, and I can't test that right now, as I'm logged in on Windows at the moment).

It would also be good for future reference to know if theres a way to log in to KDE from the command line terminal.

Thanks in advance for the help.
 
Old 09-03-2006, 10:47 AM   #2
slackhack
Senior Member
 
Registered: Jun 2004
Distribution: Arch, Debian, Slack
Posts: 1,016

Rep: Reputation: 46
you can change to init:3 in /etc/inittab to boot to a console, then launch kde with startx and having exec startkde in ~/.xinitrc.

sounds like some gnome package is corrupted or buggy, maybe something to do with hal. did you check the md5sum of the iso? maybe removing gnome and reinstalling it from the repositories would fix the problem, or just upgrading if it's behind.
 
Old 09-03-2006, 11:00 AM   #3
spacecoyote
LQ Newbie
 
Registered: Sep 2006
Posts: 3

Original Poster
Rep: Reputation: 0
Hmm...Maybe I should just re-install without the Gnome packages. Also udev wasn't starting up the first 2 times I booted.

Yeah, I have no problem booting to a console.
 
Old 09-03-2006, 03:01 PM   #4
spacecoyote
LQ Newbie
 
Registered: Sep 2006
Posts: 3

Original Poster
Rep: Reputation: 0
Re-installing without Gnome fixes some things, but the problem with the login screen remains. If I knew which file stored the key repeat, I could experiment with the setting. But right now I can't, because if I screw up the key repeat any worse I won't be able to login. It seems to be affecting X Windows as well, but not the terminal.
 
Old 09-14-2006, 09:14 AM   #5
fvgm
LQ Newbie
 
Registered: Sep 2006
Posts: 1

Rep: Reputation: 0
same problem

Hi, im have the same problems, the keys are rrreeeeepppattinggg under X. In text mode, everything goes ok. Does someone have a solution for this?? Im have already changed configurations in /etc/X11/xorg.conf with no success. My pc is k6-2 400mhz.

Plase help me
 
Old 09-27-2006, 09:05 PM   #6
davekelly1979
LQ Newbie
 
Registered: Sep 2006
Posts: 1

Rep: Reputation: 0
Fast keyboard repeat solved!

Please see this post below. I made the change to my modules file as stated and it works great. BTW, I'm using a desktop, not a laptop as discussed in the article. It's an old AMD K6 350MHz (fast huh?)

ubuntuforums.org /archive /index.php /t-25574.html
(couldn't post a URL here because I'm not yet allowed by the forumn, just take out the erroneous spaces)

As originally posted:

risager
April 11th, 2005, 07:19 PM
I now solved the bounce-key situation on my Toshiba. In the file /etc/modules I replaced the line
psmouse
with
psmouse rate=40
as described in the original post. Previously I had just removed the module with 'rmmod psmouse' and then done 'modprobe psmouse rate=40'. That didn't work. But after rebooting with the new '/etc/modules' file the bouncings and occasional delays are completely gone. :grin:

Hope it works also for the rest of you Toshiba users.
 
Old 12-25-2006, 11:42 PM   #7
klumix
LQ Newbie
 
Registered: Dec 2006
Posts: 5

Rep: Reputation: 0
keyboard problems Xorg -configure should fix it

If you are having a problem with your keyboard keys repeating or seeming to stick here is how to fix it. This should work with almost any ubuntu kubuntu or other distros with gui's you will probably only see this problem in a gui desktop. Don't try to fix it with keyboard settings it won't help you. You probably added a new keyboard to your system or you selected a wrong keyboard option when you installed.

If you are using ubuntu or kubuntu or the sort logout then select session type terminal write the following command down before you do so that you will know what to do next. Or just open a terminal accessories-> terminal

sudo Xorg -configure

type the above command at the command line.
It will probably give you the following info

Fatal server error:
Server is already active for display 0
If this server is no longer running, remove /tmp/.X0-lock
and start again.

So do what is says and remove that file with the following command

sudo rm /tmp/.X0-lock
Then type the above command again

sudo Xorg -configure

Type

reboot

Everything should work perfectly now.

The problem was caused by a bad xorg configuration. the Xorg -configure command automatically configures your keyboard for you.
 
Old 07-20-2008, 02:44 PM   #8
ert829
LQ Newbie
 
Registered: Jul 2008
Posts: 1

Rep: Reputation: 0
turn off key repeat (command: xset r off )

lots of people (including me) have had this problem. you type a letter, and it repeats multiple times. (e.g. hheeeellllppp!!!)

I am running SUSE Linux 10.3 in a VMWare session. I turned the keyrepeat off by typing the following in a console....."xset r off" (no quotes, of course)

you can see the other xset command options with the command xset /?

hope this stops the insanity! (this one really drove me nuts) Please post this hint on other forums to help others.

-ert829
 
Old 05-13-2010, 09:53 AM   #9
Vincent de Jong
LQ Newbie
 
Registered: May 2010
Posts: 1

Rep: Reputation: 0
Thumbs up

Spacecoyote,

Your solution worked, Thank you.

Vmware Workstation, Fedora Core 12 guest.
 
  


Reply

Tags
error, fc5, fedora, login


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Changing the graphical login screen... Oklahoma Linux - Newbie 5 03-24-2007 01:44 AM
FC5 graphical login problem snake15301 Fedora 6 05-26-2006 12:41 PM
What Next after LogIn (graphical screen)?? kodai Linux - Newbie 20 09-16-2004 11:50 AM
Graphical Login Screen? neocookie Linux - Software 17 06-07-2004 06:10 PM
Usual graphical login screen DaDdY SnEb Linux - Newbie 6 05-30-2003 08:48 PM


All times are GMT -5. The time now is 10:35 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration