LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Fedora (http://www.linuxquestions.org/questions/fedora-35/)
-   -   kernel too old for this udev version (http://www.linuxquestions.org/questions/fedora-35/kernel-too-old-for-this-udev-version-407048/)

wimjvanenk 01-23-2006 02:04 PM

kernel too old for this udev version
 
Ik heb me rot gegoogled, veel klokken horen luiden maar de klepel is nog niet gevonden.
Ik heb Fedora 2.6.14-1.1656_FC4 en dat werkte tot gisteren.
Gisteren heb ik wat geyummed en oa udev upgedate. Vanmorgen weigerde mijn pc om X windows op te starten. Hij/zij kan mijn muis niet vinden.
Zodra init wordt opgestart zie ik een foutmelding: udev kan niet worden opgestart met de foutmelding: Kernel too old for this udev version.
De udev version (als antwoord op rpm -q udev) is 078-4.
Ik heb een nvidia (wat? driver, kaart?? nou: zoiets)

Help!

Wim

Thetargos 01-23-2006 07:15 PM

It would be TONS helpful if you could post in a language we "all" could understand (like English) or post on a site where you know you'll get local support, as not many of us can speak (or read) germanic languages.

wimjvanenk 01-24-2006 03:08 AM

Sorry, I am new on this medium. I thought this was a dutch board. Btw: english is also a germanic language.
So, my problem is: I have Fedora 2.6.14-1.1656_FC4, it was working very satisfactory until last Sunday. I did some yum-stuff to update some packages including Udev. I have now Udev version 078-4 (according to rpm -q udev). But now, since yesterdaymorning, I cannot start X-windows.
When i start up my pc, i get, after innit : Kernel too old for this udev version".
I can work with linux on bash-level but no X-windows, no display etc.
Maybe it is relevant that you know that i have nvidia.

Thanks for using your brains!!

Wim

Thetargos 01-24-2006 09:12 AM

Quote:

Originally Posted by wimjvanenk
Sorry, I am new on this medium. I thought this was a dutch board. Btw: english is also a germanic language.

Well, it has a lot of galeic language in it too (anglo-saxon :) ), but you're right!
Quote:

Originally Posted by wimjvanenk
So, my problem is: I have Fedora 2.6.14-1.1656_FC4, it was working very satisfactory until last Sunday. I did some yum-stuff to update some packages including Udev. I have now Udev version 078-4 (according to rpm -q udev). But now, since yesterdaymorning, I cannot start X-windows.
When i start up my pc, i get, after innit : Kernel too old for this udev version".
I can work with linux on bash-level but no X-windows, no display etc.
Maybe it is relevant that you know that i have nvidia.

Thanks for using your brains!!

Wim

Ok, the udev message looks strange, indeed. Since you can work with BASH, can you look at the /var/log/messages file(s) for any apperance of this message? You have to have root permisson and grepping the file should sufice, or use 'cat /var/log/messages | grep udev'. Since you can boot into a text-mode console, then udev is running fine, would be worth checking those logs and see what's causing the message, though.

The version of the kernel you have seems to be updated, and as such, maybe the problem is that you have two or three 2.6.14 kernels installed? Verify with 'rpm -q kernel | grep 2.6.14'. For the record, I found on my system four (4) 2.6.14 kernel installations 2.6.14-1.16{37, 44, 53, 56}, and how did you install the nVidia driver? If you are using Livna's packages, then you should already be set, as a yum update nvidia* should suffice to get you to the latest possible driver, but if you installed with the .run file from nVidia's site, you will need to re-install the driver from an init 3 state, install with the -K flag at the end of the ./NVIDIA-blah-blah-blah.run string to only build the kernel module. You require the kernel-devel package to build the driver this way!

Hope this helps.

Lenard 01-24-2006 09:31 AM

Quote:

Originally Posted by wimjvanenk
Sorry, I am new on this medium. I thought this was a dutch board. Btw: english is also a germanic language.
So, my problem is: I have Fedora 2.6.14-1.1656_FC4, it was working very satisfactory until last Sunday. I did some yum-stuff to update some packages including Udev. I have now Udev version 078-4 (according to rpm -q udev). But now, since yesterdaymorning, I cannot start X-windows.
When i start up my pc, i get, after innit : Kernel too old for this udev version".
I can work with linux on bash-level but no X-windows, no display etc.
Maybe it is relevant that you know that i have nvidia.

You might want to check your yum configuration, the udev version is from the Fedora development site and is meant for the upcoming FC5 release. It's not a a big deal, but you need to have at least a 2.6.15 kernel installed. Yes I know that many of the 2.6.15 updates have been backported to your current kernel but the kernel version is reported as 2.6.14<something>.

Try one of the 2.6.15 kernels from here;

http://download.fedora.redhat.com/pu...ates/testing/4

wimjvanenk 01-24-2006 10:26 AM

Ok, the udev message looks strange, indeed. Since you can work with BASH, can you look at the /var/log/messages file(s) for any apperance of this message? You have to have root permisson and grepping the file should sufice, or use 'cat /var/log/messages | grep udev'. Since you can boot into a text-mode console, then udev is running fine, would be worth checking those logs and see what's causing the message, though.

The message is: udev_db_get_all_entries: unable tp open udev_db '/dev/.udev/db': No such file or directory

The version of the kernel you have seems to be updated, and as such, maybe the problem is that you have two or three 2.6.14 kernels installed? Verify with 'rpm -q kernel | grep 2.6.14'. For the record, I found on my system four (4) 2.6.14 kernel installations 2.6.14-1.16{37, 44, 53, 56},

kernel: 2.6.11-1.1369
kernel: 2.6.14-1.1653
kernel: 2.6.14-1.1656


and how did you install the nVidia driver?

I did it via yum.


if i have to update my kernel to 2.6.15 I need some help how to arrange that via yum or up2date or some other way? My linux know how is geowing but still very small.


Lep pozdrav, hvala i dovidenja (thats croatian, a slavic language)


Wim

Lenard 01-24-2006 11:15 AM

The easy (for me) is to simply install the new kernel using rpm. If you have a working network connection then;

(so you know which 2.6.15 to get)
rpm -qa --queryformat '%{NAME}-%{VERSION}-%{RELEASE}.%{ARCH}.rpm\n' 'kernel*'

The command is one long line with a space after the rpm\n' portion and before the rest.

Then type something like (this is only an example please adjust);

rpm -ivh http://download.fedora.redhat.com/pu...4_FC4.i686.rpm

The command is one long line with a space after 'rpm -ivh' and before the rest(shown as a link). Please adjust to be compatible with the kernel version(s) you have installed. This will install the new kernel and keep your existing kernels intact.

Thetargos 01-24-2006 12:13 PM

Quote:

Originally Posted by wimjvanenk
I did it via yum.


if i have to update my kernel to 2.6.15 I need some help how to arrange that via yum or up2date or some other way? My linux know how is geowing but still very small.


Lep pozdrav, hvala i dovidenja (thats croatian, a slavic language)


Wim

I have no idea what you said there in croatian :confused:

Anyway, you have two options: Either you install a 2.6.15 kernel (or build your own) or revert to a stable release of udev to use with your current 2.6.14 kernel. You will be able to use yum to updagte your nVidia driver if you stick to Fedora's kernels, or if you walk the 2.6.15 path, you will have to resort to installing the nVidia drive from the .run file off nVidia's site, which is quite easy to do, though it has to be done from an init 3 state.

wimjvanenk 01-27-2006 09:10 AM

I am sorry not reacting any more: i have the flu!

Lenard 01-28-2006 04:28 AM

Well that's OK, hope you get well soon.

wimjvanenk 01-28-2006 06:13 AM

Tja, i am not well yet but better. But my pc is ok. I forced to install Udev 58 over Udev 078 and now every thing is working, Alhamdellilah!
So thanks for your help. I have learned a lot.

Wim


All times are GMT -5. The time now is 06:37 AM.