LinuxQuestions.org
Visit the LQ Articles and Editorials section
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Fedora
User Name
Password
Fedora This forum is for the discussion of the Fedora Project.

Notices

Reply
 
Search this Thread
Old 12-04-2004, 01:13 AM   #1
tweak1313
LQ Newbie
 
Registered: Dec 2004
Distribution: Fedora
Posts: 2

Rep: Reputation: 0
Kernel module not loading at boot


I'm running Fedora Core 3 and am having trouble getting the nvidia drivers to work.

Correct me if I'm wrong, but the driver installs an external module which xwindows then uses as a driver for my video card. Initially when I run the install program and restart x everything works just fine until I restart. After restart x will not load and gives an error message something like "module 'nvidia' not found" My take on it is that there is a missing insmod command somewhere in the rc files. Does anyone know where I should insert an insmod command to get the nvidia module to load at boot?

Thanks,
- tweak
 
Old 12-04-2004, 06:52 AM   #2
masand
Guru
 
Registered: May 2003
Location: INDIA
Distribution: Ubuntu, Solaris,CentOS
Posts: 5,522

Rep: Reputation: 58
hi there

have a look at
/etc/modprobe.conf
man modprobe.conf

i have't done this but i think this can be done like this

regards
 
Old 12-04-2004, 04:17 PM   #3
tweak1313
LQ Newbie
 
Registered: Dec 2004
Distribution: Fedora
Posts: 2

Original Poster
Rep: Reputation: 0
Well I got everything working. I ended up just adding the command 'modprobe nvidia' to a random place in the rc.sysinit file.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
module loading at boot vasco1984 Linux - General 4 05-11-2004 06:39 AM
Loading a Module at boot time Nappa Fedora 8 04-14-2004 07:12 PM
Module not loading at boot sbadelt Linux - Hardware 2 12-18-2003 11:34 AM
ppa module not loading at boot Thetargos Linux - Hardware 0 08-11-2003 09:46 PM
kernel 2.5.65 and module loading m0rl0ck Linux - Software 4 03-21-2003 01:18 AM


All times are GMT -5. The time now is 11:32 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration