LinuxQuestions.org
Visit the LQ Articles and Editorials section
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Fedora
User Name
Password
Fedora This forum is for the discussion of the Fedora Project.

Notices



Reply
 
Search this Thread
Old 06-16-2005, 11:22 AM   #1
kpachopoulos
Member
 
Registered: Feb 2004
Location: Athens, Greece
Distribution: Gentoo,FreeBSD, Debian
Posts: 704

Rep: Reputation: 30
kernel build problems -how to install older gcc version?


I have Fedora 4 test 3 and i tried to compile a new kernel. However, in different versions i have tried to build ( fedora kernels and also from kernel.org) i get an error about i2c and ia32, although i have not added any i2c support/modules in the kernel.

As i have read, the problems may be caused by the gcc-4 compiler-not sure. I tried to install gcc-3.3, but i ran into dependency problems:

gcc-3.3--> cpp-3.3-->xorg-x11-6.8.2 (/usr/bin/cpp is needed by (installed) xorg-x11-6.8.2-30.x86_64)

What can i do?
Thanks
 
Old 06-16-2005, 01:03 PM   #2
kpachopoulos
Member
 
Registered: Feb 2004
Location: Athens, Greece
Distribution: Gentoo,FreeBSD, Debian
Posts: 704

Original Poster
Rep: Reputation: 30
I even have downloaded kernel-2.6.10 and i keep getting the same error during compilation!!!
I have compiled kernels many times, but that dosn't happen to me!!!
Why?! Is this a gcc problem?

Code:
...
In file included from include/linux/if_ether.h:106,
                 from include/linux/netdevice.h:29,
                 from include/net/sock.h:48,
                 from arch/x86_64/ia32/sys_ia32.c:73:
include/linux/skbuff.h: In function ‘skb_add_data’:
include/linux/skbuff.h:1017: warning: pointer targets in passing argument 2 of ‘
csum_partial_copy_from_user’ differ in signedness
  CC      arch/x86_64/ia32/ia32_ioctl.o
In file included from include/linux/if_ether.h:106,
                 from include/linux/netdevice.h:29,
                 from include/linux/if_bridge.h:105,
                 from fs/compat_ioctl.c:24,
                 from arch/x86_64/ia32/ia32_ioctl.c:14:
include/linux/skbuff.h: In function ‘skb_add_data’:
include/linux/skbuff.h:1017: warning: pointer targets in passing argument 2 of ‘
csum_partial_copy_from_user’ differ in signedness
In file included from fs/compat_ioctl.c:50,
                 from arch/x86_64/ia32/ia32_ioctl.c:14:
include/linux/fb.h: At top level:
include/linux/fb.h:860: error: array type has incomplete element type
In file included from fs/compat_ioctl.c:69,
                 from arch/x86_64/ia32/ia32_ioctl.c:14:
include/linux/i2c.h:58: error: array type has incomplete element type
include/linux/i2c.h:197: error: array type has incomplete element type
make[1]: *** [arch/x86_64/ia32/ia32_ioctl.o] Error 1
make: *** [arch/x86_64/ia32] Error 2
[root@localhost linux-2.6.10]#
 
Old 07-02-2005, 02:14 PM   #3
syamsoul
LQ Newbie
 
Registered: May 2005
Location: malaysia
Distribution: fedora core 3
Posts: 2

Rep: Reputation: 0
i've the same problem too.. and don't know what is the problem...
i had download a custom kernel from some site, and in FC3.92, i can compile it and successfully load the compiled kernel, but in FC4 , i can't. anybody out there, any tips for a newbie like me? :P
 
Old 07-04-2005, 09:56 AM   #4
sausagejohnson
Member
 
Registered: Mar 2004
Location: Canberra, Australia
Distribution: Fedora Core 9
Posts: 242

Rep: Reputation: 30
Dude, check my post here: http://www.linuxquestions.org/questi...hreadid=339858
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Regarding distribution + kernel version + gcc version + glib version. JCipriani Linux - General 8 04-19-2008 03:54 PM
How can I install an older gcc thorney Fedora 1 11-25-2005 09:16 PM
how to install an older version of a package... haora Linux - Newbie 1 05-27-2005 10:48 AM
using an older version of gcc win32sux Slackware 1 05-12-2004 02:53 AM
Install older version of gcc s9902245 Linux - Newbie 1 09-16-2003 04:08 PM


All times are GMT -5. The time now is 12:55 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration