LinuxQuestions.org
Go Job Hunting at the LQ Job Marketplace
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Fedora
User Name
Password
Fedora This forum is for the discussion of the Fedora Project.

Notices

Reply
 
Search this Thread
Old 09-21-2007, 09:34 AM   #1
tony yu
Member
 
Registered: Sep 2003
Location: Taiwan
Distribution: mandriva 2006
Posts: 108

Rep: Reputation: 15
kdemultimedia-3.5.7 compile error


The version of xine installed was 1.1.8 with arts support option on. But when compiling kdemultimedia-3.5.7, i get error below, what happened?
(i'm using fedora 7)

*********************************************************************
make[3]: Entering directory `/home/tony/kdemultimedia-3.5.7/xine_artsplugin'
/bin/sh ../libtool --silent --tag=CXX --mode=link g++ -Wno-long-long -Wundef -a
nsi -D_XOPEN_SOURCE=500 -D_BSD_SOURCE -Wcast-align -Wchar-subscripts -Wall -W -W
pointer-arith -O2 -Wformat-security -Wmissing-format-attribute -Wno-non-virtual-
dtor -fno-exceptions -fno-check-new -fno-common -DQT_CLEAN_NAMESPACE -DQT_NO_ASC
II_CAST -DQT_NO_STL -DQT_NO_COMPAT -DQT_NO_TRANSLATION -o libarts_xine.la -rp
ath /usr/lib -L/usr/lib/qt-3.3/lib -module -no-undefined -Wl,--no-undefined
-Wl,--allow-shlib-undefined -pthread xinePlayObject.lo xinePlayObject_impl.lo au
dio_fifo_out.lo -L/usr/lib -lxine -lz -lresolv -lnsl -pthread -lrt -lX11 -lXext
-lkmedia2_idl -lsoundserver_idl -lartsflow
.libs/xinePlayObject_impl.o: In function `xinePlayObject_impl::loadMedia(std::ba
sic_string<char, std::char_traits<char>, std::allocator<char> > const&)':
xinePlayObject_impl.cpp.text+0x1477): undefined reference to `pthread_create'
xinePlayObject_impl.cpp.text+0x148a): undefined reference to `pthread_detach'
.libs/xinePlayObject_impl.o: In function `xinePlayObject_impl::xinePlayObject_im
pl(bool)':
xinePlayObject_impl.cpp.text+0x19cd): undefined reference to `pthread_create'
.libs/xinePlayObject_impl.o: In function `xinePlayObject_impl::xinePlayObject_im pl(bool)':
xinePlayObject_impl.cpp.text+0x1ebd): undefined reference to `pthread_create'
.libs/xinePlayObject_impl.o: In function `xinePlayObject_impl::~xinePlayObject_i mpl()':
xinePlayObject_impl.cpp.text+0x226e): undefined reference to `pthread_join'
.libs/xinePlayObject_impl.o: In function `xinePlayObject_impl::~xinePlayObject_i mpl()':
xinePlayObject_impl.cpp.text+0x25bd): undefined reference to `pthread_join'
.libs/xinePlayObject_impl.o: In function `xinePlayObject_impl::~xinePlayObject_i mpl()':
xinePlayObject_impl.cpp.text+0x280d): undefined reference to `pthread_join'
collect2: ld returned 1 exit status
make[3]: *** [libarts_xine.la] Error 1
make[3]: Leaving directory `/home/tony/kdemultimedia-3.5.7/xine_artsplugin'
make[2]: *** [all-recursive] Error 1
make[2]: Leaving directory `/home/tony/kdemultimedia-3.5.7/xine_artsplugin'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/home/tony/kdemultimedia-3.5.7'
make: *** [all] Error 2
 
Old 09-27-2007, 07:42 AM   #2
tony yu
Member
 
Registered: Sep 2003
Location: Taiwan
Distribution: mandriva 2006
Posts: 108

Original Poster
Rep: Reputation: 15
This could be an issue with kde-3.5.7, not keeping up with the latest xine-lib after 1.1.4. i again just downgrade my xine to 1.1.3, then compiling without any errors.
 
Old 09-29-2007, 07:44 AM   #3
tony yu
Member
 
Registered: Sep 2003
Location: Taiwan
Distribution: mandriva 2006
Posts: 108

Original Poster
Rep: Reputation: 15
i post message to http://lists.kde.org/?l=kde-multimed...8319407670&w=2, and got a patch, yet don't try it though.
 
Old 10-13-2007, 06:55 AM   #4
tony yu
Member
 
Registered: Sep 2003
Location: Taiwan
Distribution: mandriva 2006
Posts: 108

Original Poster
Rep: Reputation: 15
well, it does not work.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Problems with locales and kdemultimedia Zmyrgel Debian 0 04-26-2006 08:07 AM
KDEMultimedia vs. K3B - why not both!? lefty.crupps MEPIS 7 09-07-2005 10:04 PM
rpm -e kdemultimedia kdeaddons konstantine Linux - Newbie 1 03-31-2005 07:23 PM
Error when building kdemultimedia. RoaCh Of DisCor Linux - Software 1 10-14-2004 12:59 PM
Installing KDEMultimedia digsby0007 Linux - Software 1 02-07-2003 10:57 AM


All times are GMT -5. The time now is 10:25 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration