LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Fedora
User Name
Password
Fedora This forum is for the discussion of the Fedora Project.

Notices



Reply
 
Search this Thread
Old 08-14-2004, 07:50 PM   #1
UmneyDurak
Member
 
Registered: Jun 2004
Posts: 178

Rep: Reputation: 30
It stopped working.


Hi.
Ok, my FC2 stopped booting.
Here what happened.
I finally got dualboot running by removing 300 mb partition on hda drive, putting 100 mb /boot partitions there. Then I installed rest of FC2 partitions on hdb on first 20 gigs, and grub on to /boot.
I installed all the upgraded and booted in to windows.
There I created a 200 mb partition on hda, and created 3 new partions on remaining 60 gig on hdb.
When I tried booting in to linux again, instead of a menu I just get grub prompt. I checked /boot, grub is still there, grub.conf is there.
Whats going on?
Oh also, my mbr still contains windows manager. I just eddited boot.ini, to boot in to grub when I select linux. c:\linux.bin...
where linux.bin is the result of dd if=/dev/hda7 of=/mnt/floppy/linux.bin bs=512 count =1 command

P.S. I'm really getting fed up with this, been trying to install FC2 for the last few days. If I can't get this fixed I'm going back to mandrake. I'm NOT reinstalling FC2 again.

Last edited by UmneyDurak; 08-14-2004 at 07:53 PM.
 
Old 08-14-2004, 08:18 PM   #2
futhark
Member
 
Registered: Nov 2003
Location: Montréal (Can)
Distribution: FC4
Posts: 110

Rep: Reputation: 15
I think I've encountered the same problem before and if I'm right this is not distro-specific. One should create all partitions before installing. Otherwise partitions number may shift when deleting + recreating partitions.

I suggest you to find out what is your current Fedora root partition device (forget about the original). Then, boot with a modified root=/dev/hdNN parm in grub (you can edit options on the spot before booting). After Fedora boots, edit your /etc/fstab and /etc/grub.conf.

BTW I suggest to install grub in your hda MBR. It boots Windows perfectly. If you want to get rid of Linux at some point, just fdisk /mbr and grub will go away.
 
Old 08-14-2004, 08:46 PM   #3
UmneyDurak
Member
 
Registered: Jun 2004
Posts: 178

Original Poster
Rep: Reputation: 30
I don't think so: http://www.linuxquestions.org/questi...hreadid=217489
It's not touching my mbr partition. Also last time I tried it, my partition tableon hdb was seriously messed up.
 
Old 08-14-2004, 09:45 PM   #4
futhark
Member
 
Registered: Nov 2003
Location: Montréal (Can)
Distribution: FC4
Posts: 110

Rep: Reputation: 15
Quote:
Originally posted by UmneyDurak
I don't think so: http://www.linuxquestions.org/questi...hreadid=217489
It's not touching my mbr partition. Also last time I tried it, my partition tableon hdb was seriously messed up.
Okay I understand you don't want to put grub in the mbr.

I'm sure your linux install didn't vanish. I think it's partition changed name when you edited your partitions. Did you verify this?
 
Old 08-14-2004, 09:56 PM   #5
UmneyDurak
Member
 
Registered: Jun 2004
Posts: 178

Original Poster
Rep: Reputation: 30
Yeah I think thats what happened.
Unfortenatly I made a mistake of coppying a grub.conf from the floppy disk back to grub dir. After it stopped bootting. The file was blank, for some reason. I think I copied it wrong when I coppied it from the grub partition to the disk, right after the installation, for back.
So right now I'm trying to recreate the grub.conf file.
BTW. I tried the commands root one works fine, but when I try kernel it can't find the vmlinuz image.
I tried
kernel /vmlinuz root=/dev/hda5
kernel /boot/vmlinuz-2.6.5-1.358 root=/dev/hda5
without boot, different partitions on hda
it keeps giving me the file not found error.
I double checked and that file is on /boot partition, which is hda5

Last edited by UmneyDurak; 08-14-2004 at 10:23 PM.
 
Old 08-14-2004, 10:48 PM   #6
futhark
Member
 
Registered: Nov 2003
Location: Montréal (Can)
Distribution: FC4
Posts: 110

Rep: Reputation: 15
Here are the minimal commands I would need to boot my system with grub. Initrd isn't so important if you don't have scsi drives.

root (hd0,4)
kernel /boot/vmlinuz ro root=/dev/hda5
boot

Note I don't have a boot partition. I have only one root partition. If hda5 would be a boot partition, I'd need to strip the "/boot" part from the path and change /dev/hda5 accordingly ... but that does not seem to be your case.

Note I never booted through vmlinuz successfully. Back when I was learning how to use grub, specifying vmlinuz as the kernel file didn't work. It may work now, I don't know.

Say you still can't boot. You will need to find out exactly what is the name of your kernel file and plug this on the kernel line. Personally, I'm a big fan of the rescue mode. If I had your problem, I'd boot a rescue CD and do this.

First I'd try to mount a floppy on which I have a grub.conf file.
Code:
mkdir /floppy
mount /dev/fd0 /floppy
Then I'd mount my root partition:
Code:
mkdir /r
mount /dev/hda5 /r
chroot /r
ls /boot
vi /etc/grub.conf
And finally I'd copy the sample grub.conf file over. If you have no grub example, edit the following:

Code:
default=0
timeout=10
splashimage=(hd0,4)/boot/grub/splash.xpm.gz
title to the rescue!
        root (hd0,4)
        kernel /boot/vmlinuz-2.6.7 ro root=/dev/hda5
        initrd /boot/initrd-2.6.7.img
title DOS
        rootnoverify (hd0,0)
        chainloader +1
HTH!
 
Old 08-14-2004, 11:35 PM   #7
UmneyDurak
Member
 
Registered: Jun 2004
Posts: 178

Original Poster
Rep: Reputation: 30
Look I already tried those kernel commands.
Let me be more explicit in what I tried:
kernel /vmlinuz root=/dev/hda5
kernel /boot/vmlinuz-2.6.5-1.358 root=/dev/hda5
kernel /vmlinuz-2.6.5-1.358 root=/dev/hda5
kernel /vmlinuz root=/dev/hda5
kernel /vmlinuz-2.6.5-1.358 root=/dev/hda1
.
.
.
kernel /vmlinuz-2.6.5-1.358 root=/dev/hda7
kernel /boot/vmlinuz-2.6.5-1.358 root=/dev/hda1
.
.
.
kernel /boot/vmlinuz-2.6.5-1.358 root=/dev/hda7

all of them give file not found error
Currently my grub.conf looks like this:
default=0
timeout=10
#hd0,4 is because my /boot partition is on hda5
splashimage=(hd0,4)/boot/grub/splash.xpm.gz
#my / partition is on hdb1
root (hd1,0)
#I also tried with root=LABEL=/
kernel /boot/vmlinuz-2.6.5-1.358 ro root=/dev/hda5
initrd /boot/initrd-2.6.5-1.358.img

Last edited by UmneyDurak; 08-14-2004 at 11:39 PM.
 
Old 08-15-2004, 01:00 PM   #8
futhark
Member
 
Registered: Nov 2003
Location: Montréal (Can)
Distribution: FC4
Posts: 110

Rep: Reputation: 15
Quote:
Originally posted by UmneyDurak

Currently my grub.conf looks like this:
default=0
timeout=10
#hd0,4 is because my /boot partition is on hda5
splashimage=(hd0,4)/boot/grub/splash.xpm.gz
#my / partition is on hdb1
root (hd1,0)
In this case what you need to boot is this:

Code:
root (hd0,4)
kernel /vmlinuz-2.6.5-1.358 root=/dev/hdb1
initrd /initrd-2.6.5-1.358.img
boot
You must not confuse grub's "root" command with the kernel "root" option. They have different meanings.

In grub, "root" means selecting the partition to boot from. This is the partition where the kernel resides, in your case hda5.

On the kernel line, "root" means what partition to mount as your root drive, in your case hdb1.

I am also noticing another mistake. When the boot partition is independant from the root, none of the path you're giving to grub should start with "/boot".
 
Old 08-15-2004, 03:41 PM   #9
UmneyDurak
Member
 
Registered: Jun 2004
Posts: 178

Original Poster
Rep: Reputation: 30
Yeah figured it out, when I did another quick install and looked at my grub.conf.
#Boot=/dev/hda8
Default=0
Timeout=10
Splashimage=(hd0,7)
Title fedora core
Root (hd0, 7)
Kernel /vmlinuz-2.6.5-1.358 ro root=LABEL=/ rhgb quiet
Initrd /initrd-2.6.5-1.358.img

So if my /boot is on hda8, root will be (hd0,7)
Then kernel and initrd will be relative to that.
So for example if they were in some other folder on boot partition, lets say the folder is called test.
Then the commands will lookt like this.

Kernel /test/vmlinuz-2.6.5-1.358 ro root=LABEL=/ rhgb quiet
Initrd /test/initrd-2.6.5-1.358.img
Anyway the last attempt to reinstall FC2 messed up my mbr so bad that I had to remove partitions on both HD. So I'm startting fresh.
This time I'm making my 80 gig HD primarry, and 20 GIG HD secondary. That way there will be NO partition mixing. Linux Partitions on one HD, and windows Partittions on the other.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Network stopped working enemorales Linux - Wireless Networking 5 08-24-2005 06:01 AM
su stopped working bulldogzerofive Linux - Software 5 01-17-2005 03:05 AM
X stopped working sueno Fedora 15 10-02-2004 01:23 PM
mozilla stopped working master Linux - General 13 07-05-2004 11:39 AM
My X just stopped working??? freeindy Linux - Newbie 4 11-30-2002 11:53 AM


All times are GMT -5. The time now is 09:26 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration