LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Fedora
User Name
Password
Fedora This forum is for the discussion of the Fedora Project.

Notices



Reply
 
Search this Thread
Old 09-16-2007, 02:28 PM   #1
lightpace
LQ Newbie
 
Registered: Sep 2007
Posts: 4

Rep: Reputation: 0
issue with starting Apache after php recompile


hi

i had everything running fine, until i recompile php with mysql and that required me to update httpd (for apxs) and mysqld with devel. after compiling php everything came up but apache is not starting.

i am getting following message in logs.

Code:
v=hda1 ino=260730 scontext=user_u:system_r:httpd_t:s0 tcontext=user_u:object_r:httpd_modules_t:s0 tclass=file
Sep 16 09:34:35 anaconda kernel: audit(1189949675.371:27): avc:  denied  { execmod } for  pid=8700 comm="httpd" name="libphp5.so" dev=hda1 ino=260730 scontext=user_u:system_r:httpd_t:s0 tcontext=user_u:object_r:httpd_modules_t:s0 tclass=file
Sep 16 09:36:00 anaconda kernel: audit(1189949760.597:28): avc:  denied  { execmod } for  pid=8711 comm="httpd" name="libphp5.so" dev=hda1 ino=260730 scontext=user_u:system_r:httpd_t:s0 tcontext=user_u:object_r:httpd_modules_t:s0 tclass=file
^^Sep 16 09:48:22 anaconda kernel: audit(1189950502.670:29): avc:  denied  { execmod } for  pid=8730 comm="httpd" name="libphp5.so" dev=hda1 ino=260730 scontext=user_u:system_r:httpd_t:s0 tcontext=user_u:object_r:httpd_sys_content_t:s0 tclass=file
^^

[root@anaconda run]# rpm -aq | grep httpd
httpd-devel-2.2.4-2.1.fc6
system-config-httpd-1.4.1-1.fc6
httpd-2.2.4-2.1.fc6
[root@anaconda run]# rpm -aq | grep mysql
mysql-server-5.0.27-1.fc6
mysql-5.0.27-1.fc6
mysql-devel-5.0.27-1.fc6
[root@anaconda run]# rpm -aq | grep php
php-cli-5.1.6-3.6.fc6
php-common-5.1.6-3.6.fc6
[root@anaconda run]# uname -a
Linux anaconda 2.6.20-1.3001.fc6xen #1 SMP Thu Aug 9 16:18:09 EDT 2007 i686 i686 i386 GNU/Linux
any words of wisdom?
thanks
- mark

Last edited by XavierP; 09-16-2007 at 05:53 PM.
 
Old 10-11-2007, 02:52 PM   #2
shafty023
Member
 
Registered: Oct 2007
Distribution: OSX
Posts: 248

Rep: Reputation: 31
It looks to me like SELinux is giving problems with apache. Do you have SELinux enabled?
 
Old 10-12-2007, 05:26 PM   #3
noran01
LQ Newbie
 
Registered: Oct 2007
Posts: 12

Rep: Reputation: 0
SELinux is definitely your problem here.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Proplems starting apache with php wisdom Linux - Software 1 11-17-2006 10:48 PM
Initial PHP configuration after starting MySQL and Apache studioq Linux - Newbie 2 09-28-2006 12:23 AM
Very confused over Apache / PHP issue stokes Slackware 6 02-05-2006 10:32 AM
Issue with Apache not starting! awsoda Linux - Newbie 1 07-25-2003 10:31 PM


All times are GMT -5. The time now is 03:05 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration