LinuxQuestions.org
LinuxAnswers - the LQ Linux tutorial section.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Fedora
User Name
Password
Fedora This forum is for the discussion of the Fedora Project.

Notices

Reply
 
Search this Thread
Old 03-19-2005, 05:25 PM   #1
mreinecker
Member
 
Registered: Mar 2005
Location: New Jersey
Distribution: SuSE Professional 9.2
Posts: 31

Rep: Reputation: 15
Is multi channel audio possible ?


I have an on-board Intel AC'97 soundcard... (Corp. 82801EB/ER ICH5/ICH5R AC'97 Audio Contoller to be exact...). Anyway, I figured out that if I turn down the PCM volume, my sound quality is better (clearer). However, I've noticed that while using XMMS, or any other music player, I can only get sound from that program. For example, if I am using XMMS to play music, the sounds on Gaim do not function. After searching through this forum and several others, I have come to the conclusion that this is due to the fact that I don't have multi channel sound. I have found no resolution for this issue, and was wondering if anyone knows of a way to set up multi channel sound. Is my only solution to use a better quality PCI soundcard instead of the on-board one? Thank you.
 
Old 03-19-2005, 06:52 PM   #2
uberNUT69
Member
 
Registered: Jan 2005
Location: Tasmania
Distribution: Xen Debian Lenny/Sid
Posts: 578

Rep: Reputation: 30
---> 'if I turn down the PCM volume, my sound quality is better '
Sound quality for onboard audio is rarely ideal

---> 'I can only get sound from that program'
Can't help you here, however I remember seeing solutions for this in the forums.
There is apparently an easy way to add apps to a list that can share the audio.

---> 'I have come to the conclusion that this is due to the fact that I don't have multi channel sound'
I don't agree

---> 'Is my only solution to use a better quality PCI soundcard instead of the on-board one?'
This is not your problem, but should improve your sound quality.
 
Old 03-20-2005, 12:05 PM   #3
pld
Member
 
Registered: Jun 2003
Location: Southern US
Distribution: Ubuntu 5.10
Posts: 206

Rep: Reputation: 30
i was thinking that your problem is not really "multi channel sound" per se. More, you are having problems with applications sharing the sound instead. There is a way (i refer up to ubernuts post) to have multiple programs all accessing the audio, but off the top of my head i dont recall what it was (not even sure if i have the same problem, as i hate desktop sounds personally...)
 
Old 03-20-2005, 03:18 PM   #4
liquidtenmilion
Member
 
Registered: May 2004
Location: South Carolina
Distribution: Slackware 11.0
Posts: 606

Rep: Reputation: 31
if you are using alsa(you should be)

then create a ~/.asoundrc file that has the contents of:

pcm.card0 {

type hw

card 0

mmap_emulation true

}

pcm.!output {
type dmix
ipc_key 1234
ipc_key_add_uid 1
slave {
pcm "card0"
period_time 0
period_size 1024
buffer_size 32768
rate 48000
}
bindings {
0 0
1 1
}
}

#
# DSNOOP output device
#
pcm.!input {
type dsnoop
ipc_key 4321
ipc_key_add_uid 1
slave {
pcm "card0"
period_time 0
period_size 1024
rate 48000
}
}

#
# ASYM duplex device
#
pcm.!duplex {
type asym
playback.pcm "output"
capture.pcm "input"
}

#
# Make the duplex device default
#
pcm.!default {
type plug
slave.pcm "duplex"
}

#
# OSS Compability

pcm.!dsp0 {
type plug
slave.pcm "duplex"
}

ctl.!mixer0 {
type hw
card 0
}


then set everything to use alsa(in xmms right click, preferences, and you can switch from esd or oss to alsa)

and you should be able to play multiple alsa sounds at the same time.
 
Old 03-20-2005, 06:42 PM   #5
mreinecker
Member
 
Registered: Mar 2005
Location: New Jersey
Distribution: SuSE Professional 9.2
Posts: 31

Original Poster
Rep: Reputation: 15
Thanks liquid. I still have some questions for you, or anyone who can help. How do I go about creating this file ? Just make a new text document ? Also, after creating the file, where should it be placed ?

Last edited by mreinecker; 03-20-2005 at 06:45 PM.
 
Old 03-21-2005, 12:47 AM   #6
uberNUT69
Member
 
Registered: Jan 2005
Location: Tasmania
Distribution: Xen Debian Lenny/Sid
Posts: 578

Rep: Reputation: 30
probably the easiest way is to open a terminal (eg. xterm or konsole), and use an editor like vi
eg:
vi ~/.asoundrc
(the preceding ~/ means the current user's home directory)
press "i" for insert
select the text above using your mouse (this automatically copies the selected text to your clipboard)
and the click the middle mouse button in the terminal window to paste the contents.

to save the file and exit, press
ESC :wq ENTER (5 separate keypresses)

to make sure the file has been created type
ls -la | grep asound

and to examine its contents try something like:
cat .asoundrc
or
less .asoundrc
 
Old 03-21-2005, 02:08 AM   #7
rvqbl
LQ Newbie
 
Registered: Jan 2004
Location: Oklahoma
Distribution: Ubuntu
Posts: 27

Rep: Reputation: 15
Quote:
Originally posted by liquidtenmilion
if you are using alsa(you should be)
then create a ~/.asoundrc file that has the contents of:
and you should be able to play multiple alsa sounds at the same time.
I just did this and solved a problem that has been annoying me forever. Why is something this easy not done automatically when installing ALSA?

Thanks...
 
Old 03-21-2005, 02:24 PM   #8
mreinecker
Member
 
Registered: Mar 2005
Location: New Jersey
Distribution: SuSE Professional 9.2
Posts: 31

Original Poster
Rep: Reputation: 15
How do I get gaim to use alsa sounds ?
 
Old 03-21-2005, 06:15 PM   #9
liquidtenmilion
Member
 
Registered: May 2004
Location: South Carolina
Distribution: Slackware 11.0
Posts: 606

Rep: Reputation: 31
click on preferences, then sounds then you'll see sound method.

there click on command and type in aplay %s
 
Old 03-22-2005, 04:39 PM   #10
pld
Member
 
Registered: Jun 2003
Location: Southern US
Distribution: Ubuntu 5.10
Posts: 206

Rep: Reputation: 30
lol rvqbl,

I never even thought about it before personally. after reading this thread I went and read the alsa documentation about using dmix, and after a bit of fiddling and whatnot, lo and blow holes, I can listen to mplayer, alsaplayer, xmms, and my own humming all at the same time! yeah!

funny how i didnt even think about it until someone else had the problem... Then it became an obsession to get it to work on my system.

however, I still cannot have music playing while I play quake3, which kinda sucks. anyone know if there is some way to have quake3 play nice with dmix so i can listen to music at the same time?
 
Old 03-22-2005, 07:02 PM   #11
liquidtenmilion
Member
 
Registered: May 2004
Location: South Carolina
Distribution: Slackware 11.0
Posts: 606

Rep: Reputation: 31
Oss programs have problems with dmix(mainly, dmix doesn't affect it)

You can try it by using *aoss quake3command*(note type in the command for quake 3 which i don't know not actually quake3command)

but that might not work. If it does they YAY!!!(install the package alsa-oss first)

if it doesnt then you can try artsdsp quake3command which will work, but it might cause sound lag.(just tell arts to use alsa, which i think it does by default if its there.)

if the lag bothers you, then there is nothing really you can do besides buying a soundblaster live soundcard.
 
Old 03-22-2005, 07:49 PM   #12
mreinecker
Member
 
Registered: Mar 2005
Location: New Jersey
Distribution: SuSE Professional 9.2
Posts: 31

Original Poster
Rep: Reputation: 15
Post

I have all problems resolved ! I now have XMMS working properly. Sounds for gaim work while XMMS is open and playing music. Thanks everybody !
 
Old 03-28-2005, 07:15 AM   #13
johnnydangerous
Member
 
Registered: Jan 2005
Location: Sofia, Bulgaria
Distribution: Fedora Core 4 Rawhide
Posts: 431

Rep: Reputation: 30
I had it fixed can't remmember how but this file:
Quote:
if you are using alsa(you should be)

then create a ~/.asoundrc file that has the contents of:

pcm.card0 {

type hw

card 0

mmap_emulation true

}

pcm.!output {
type dmix
ipc_key 1234
ipc_key_add_uid 1
slave {
pcm "card0"
period_time 0
period_size 1024
buffer_size 32768
rate 48000
}
bindings {
0 0
1 1
}
}

#
# DSNOOP output device
#
pcm.!input {
type dsnoop
ipc_key 4321
ipc_key_add_uid 1
slave {
pcm "card0"
period_time 0
period_size 1024
rate 48000
}
}

#
# ASYM duplex device
#
pcm.!duplex {
type asym
playback.pcm "output"
capture.pcm "input"
}

#
# Make the duplex device default
#
pcm.!default {
type plug
slave.pcm "duplex"
}

#
# OSS Compability

pcm.!dsp0 {
type plug
slave.pcm "duplex"
}

ctl.!mixer0 {
type hw
card 0
}


then set everything to use alsa(in xmms right click, preferences, and you can switch from esd or oss to alsa)

and you should be able to play multiple alsa sounds at the same time.
seems to result in GUI box saying sound not working check ... your grandma..
 
Old 03-28-2005, 03:55 PM   #14
liquidtenmilion
Member
 
Registered: May 2004
Location: South Carolina
Distribution: Slackware 11.0
Posts: 606

Rep: Reputation: 31
that configuration doesn't support all cards, just intel i810 cards, and the nvidia onboard sound.
 
Old 03-29-2005, 01:56 PM   #15
lixy
Member
 
Registered: Apr 2004
Posts: 120

Rep: Reputation: 15
Talking

Thanks to everyone who posted here. It works!!!
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Enable 4 Channel Audio? voxel Linux - Laptop and Netbook 0 09-04-2005 07:12 PM
A Few Problems (Lexmark X1180, Multi Channel Audio, CD Writer) alur3n Linux - Hardware 1 07-12-2005 10:24 AM
Listne to mp3s on Linux multi-channel usernameddr Linux - Software 5 03-19-2005 02:15 PM
CD audio no right channel system ok robby737 Linux - Newbie 0 07-29-2004 10:32 AM
6 channel audio with linux bignester Linux - Software 3 08-23-2003 11:58 AM


All times are GMT -5. The time now is 11:33 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration