LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Fedora (http://www.linuxquestions.org/questions/fedora-35/)
-   -   installing fedora 9 to non-raid scsi hard drive adaptec 39160 hangs (http://www.linuxquestions.org/questions/fedora-35/installing-fedora-9-to-non-raid-scsi-hard-drive-adaptec-39160-hangs-662153/)

backthefup 08-12-2008 02:32 AM

installed fedora 9 to non-raid scsi hard drive adaptec 39160 not detected first boot
 
I'm trying to install Fedora Core 9 to a non-raid SCSI hard drive with an Adaptec 39160 controller. It hangs after saying "waiting for hardware to initialize..." I have searched to no avail for boot options for SCSI support but cannot find any. Is there a way to force the correct driver. I loaded another basic version of Linux from the Ultimate Boot Cd and it saw the SCSI card as a AIC-7899 but I don't see anything like that come up on boot with Fedora. Please let me know how I can troubleshoot this problem. Thank you.

UPDATE: OK I hit Ctrl-Alt-F4 or something, it showed me what was happening. it is hanging while loading my IDE cd-rom as a SCSI cd-rom. Is there a way to stop that?

FURTHER UPDATE: OK I was able to complete the installation using the linux noprobe option. My problem is now, on reboot I see the Grub menu but Linux will not load when I select it. It doesn't find the SCSI drive. I get a setuproot: error that /dev, /proc and /sys can't be found and /dev/selinux can't be found. How do I use a SCSI kernel or load the module as the computer is booting.
k

ia64processor 08-14-2008 04:47 AM

Not certain if it could fix the problem but you can try to generate a new initrd disk.

I assume you have specified the correct boot sequence in the motherboard's BIOS and the 39160's BIOS.

- Boot your PC in rescue mode with the Fedora9 DVD, see if it can read the / partition. Next, run the following command:
# chroot /mnt/sysimage

- aic7xxx is the kernel module required for Adaptec 29xxx/39xxx series adaptors. Check if it is included in the /etc/modprobe.conf

- Rename the existing initrd-2.6.25.11-97.fc9.x86_64.img to initrd-2.6.25.11-97.fc9.x86_64.x86_64.old in /boot partition (your initrd file might have different version)

- Generate a new initrd disk:
# mkinitrd /boot/initrd-2.6.25.11-97.fc9.x86_64.x86_64.img 2.6.25.11-97.fc9.x86_64

- sync, exit and the system should reboot. See if you still get the same errors or something else...


All times are GMT -5. The time now is 07:31 PM.