LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Fedora
User Name
Password
Fedora This forum is for the discussion of the Fedora Project.

Notices

Reply
 
Search this Thread
Old 05-06-2004, 11:07 PM   #1
Pacifix
LQ Newbie
 
Registered: May 2004
Posts: 4

Rep: Reputation: 0
Unhappy Installing apt on c2t3 - rpm conflict - no clue?


I've got my new test 3 system, which I'm very happy with except that I can't get apt installed. I've downloaded the three files suggested on on the thread "apt for fedora 2 t3" by geesh (can't post url what with my newbie-ness) (synaptic-0.48.1-0.fdr.3.1.90, apt-0.5.15cnc6-0.fdr.11.1.91, apt-devel-0.5.15cnc6-0.fdr.11.1.91) but when I try to install them via rpm -ivh *.rpm, I get the following:
Code:
warning: apt-0.5.15cnc6-0.fdr.11.1.91.i386.rpm: V3 DSA signature: NOKEY, key ID 8df56d05
Preparing...                ########################################### [100%]
        file /etc/apt/apt.conf from install of apt-0.5.15cnc6-0.fdr.11.1.91 conflicts with file from package atrpms-package-config-58-1.rhfc1.at
        file /etc/apt/preferences from install of apt-0.5.15cnc6-0.fdr.11.1.91 conflicts with file from package atrpms-package-config-58-1.rhfc1.at
        file /etc/apt/rpmpriorities from install of apt-0.5.15cnc6-0.fdr.11.1.91 conflicts with file from package atrpms-package-config-58-1.rhfc1.at
        file /etc/apt/sources.list from install of apt-0.5.15cnc6-0.fdr.11.1.91 conflicts with file from package atrpms-package-config-58-1.rhfc1.at
        file /etc/apt/vendors.list from install of apt-0.5.15cnc6-0.fdr.11.1.91 conflicts with file from package atrpms-package-config-58-1.rhfc1.at
And I'm afraid I'm too much of a newbie to know where to go next. I added a few repositories to my yum.conf the first few days, but I've since reverted back to the original, vanilla yum.conf (hoping to fix this). Could someone tell me what to do next? Thanks,

Pacifix
 
Old 05-06-2004, 11:18 PM   #2
jon-do
Member
 
Registered: Feb 2004
Distribution: Red 9, FC 2 Test 3
Posts: 98

Rep: Reputation: 16
It gets a little bit complicated when you install packages from third person repositories. In order to install apt, you have to remove atrpms-package-config-58-1.rhfc1.at
 
Old 05-06-2004, 11:19 PM   #3
Pacifix
LQ Newbie
 
Registered: May 2004
Posts: 4

Original Poster
Rep: Reputation: 0
cool. how do I do that? thanks/
 
Old 05-06-2004, 11:26 PM   #4
jon-do
Member
 
Registered: Feb 2004
Distribution: Red 9, FC 2 Test 3
Posts: 98

Rep: Reputation: 16
Code:
rpm -e atrpms-package-config
 
Old 05-06-2004, 11:37 PM   #5
Pacifix
LQ Newbie
 
Registered: May 2004
Posts: 4

Original Poster
Rep: Reputation: 0
Code:
error: Failed dependencies:
        /etc/yum.conf is needed by (installed) yum-2.0.7-0.20040416_32.rhfc1.at
? sorry for my cluelessness...
 
Old 05-07-2004, 12:41 AM   #6
jon-do
Member
 
Registered: Feb 2004
Distribution: Red 9, FC 2 Test 3
Posts: 98

Rep: Reputation: 16
how many packages have you donwloaded from atrpms and what install package did you use?
 
Old 05-07-2004, 12:59 AM   #7
Pacifix
LQ Newbie
 
Registered: May 2004
Posts: 4

Original Poster
Rep: Reputation: 0
Code:
rpmquery --whatrequires atrpms
make-3.80-4.rhfc1.at
tetex-2.0.2-34.rhfc1.at
diffstat-1.34-0_5.rhfc1.at
I've only used yum so far. When I tried to install apt from the dag repository, I ran into depedencies problems and so just went with yum.
 
Old 05-07-2004, 03:31 AM   #8
jon-do
Member
 
Registered: Feb 2004
Distribution: Red 9, FC 2 Test 3
Posts: 98

Rep: Reputation: 16
Since you have yum do
Code:
yum remove atrpms
it will list other dependencies of atrpms that will also be remove, write those dependencies down and yes to remove with all its dependecies.

Now try to install apt afterwards
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
apt-get upgrade ,conflict with libxvidcore!!!! nordickiwi Fedora 0 10-17-2004 01:48 PM
Apt-get upgrade conflict problem satimis Red Hat 0 07-18-2004 08:25 PM
installing xglobe and have no clue innova Linux - Newbie 2 04-15-2004 01:52 AM
apt and urpmi conflict? Nadim Mandriva 3 04-05-2004 04:12 AM
conflict with get-apt install mplayer and lame-libs illtbagu Linux - Software 4 02-14-2003 12:31 AM


All times are GMT -5. The time now is 08:32 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration