LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Fedora
User Name
Password
Fedora This forum is for the discussion of the Fedora Project.

Notices



Reply
 
Search this Thread
Old 03-22-2005, 04:48 AM   #1
brokenpromises
Member
 
Registered: Jan 2005
Location: NZ
Distribution: Fedora / Debian
Posts: 98

Rep: Reputation: 21
Installed drivers, but still cant change resolution


Hi Again guys

I formatted and re-installed FC3, and used this guide:

Quote:
12 March 2005

The currently available version is the 1.0-7167 driver from Nvidia.

Login as root to text console <CTRL><ALT><F1> (or F2,F3,F4)
disable X-server, install driver, re-enable X-server:

[root@charon ~]# init 3
(just hit enter if the prompt does not return)

[root@charon ~]# sh NVIDIA-Linux-x86-1.0-7167-pkg1.run

EDIT /etc/X11/xorg.conf (see below)

[root@charon ~]# modprobe nvidia

NVRM: loading NVIDIA Linux x86 NVIDIA Kernel Module 1.0-7167 Fri Feb 25
09:08:22 PST 2005

[root@charon ~]# init 5

Note: A reboot is recommended, but may NOT be required.
If you had a previous Nvidia driver installed, it is recommended that you reboot to
RESTART the udev system.

Changes to /etc/X11/xorg.conf

ection "Module"
add (if not already there):
Load "glx"
comment out (add # in front of them, if they are there):
#Load "dri"
#Load "GLcore"

("glx" and "dri" were there for me, "GLcore" was not)

Section "Device"
change from:
Driver "nv"
to:
Driver "nvidia"

--------------------

The 1.0-7167 driver seems to properly work with udev.

PROBLEM: (for version 1.0-6629 and older) The new udev included
in FC3 prevented the nvidia module from loading automatically.

The Recommended Fix:

# cp -a /dev/nvidia* /etc/udev/devices
# chown root.root /etc/udev/devices/nvidia*

Only if above does NOT work

EDIT /etc/rc.local

ADD the following to the END of the file:

/sbin/modprobe nvidia

--------------------

Other Kernel Issues:

If you update your kernel the NVidia driver must be re-installed to
match the new kernel.
to install the nVidia video driver for my GeForce MX420. I modified my files as shown in the walkthrough, and rebooted the computer. But I did not see any changes. I went into my Applications > Display and opened the drop down menu to change my resolution, but I could see only 2 modes - 800x600 and 640x480. These modes were still there before installing the driver.


Is there away to tell if the driver is running or not?

Why can't I change resolution?

Ive been trying all day to get the driver installed, and now that Ive got that done I really dont see any benifits. Im still stuck on 800x600.

Any Help Appreciated.

Last edited by brokenpromises; 03-22-2005 at 04:52 AM.
 
Old 03-22-2005, 09:10 AM   #2
Technoslave
Member
 
Registered: Dec 2003
Location: Northern VA
Posts: 493

Rep: Reputation: 30
Look in your xorg.conf file again. You should see under your Section "Screen", the line Modes. Add whatever resolutions you need there.

I don't change resolution size ( keep mine at 1280x1024 ), so this next part may be sketchy. I believe you can cycle through your resolutions using ALT+CTRL++ or -, the + to increase res the - to decrease.

Because my kernel was newer than nvidia had drivers for, a few months ago when I tried installing, and since I don't run 3D apps on my comp I haven't tried. But at one point NVidia used a splash screen when you restarted your X, if you see the splash screen you know you're good. Otherwise, just play a 3D game ( there's a scroll shooter, can't remember the name ), good FPS means it's installed, 1 or 2 FPS and you know it's not.
 
Old 03-22-2005, 03:11 PM   #3
brokenpromises
Member
 
Registered: Jan 2005
Location: NZ
Distribution: Fedora / Debian
Posts: 98

Original Poster
Rep: Reputation: 21
Hi Technoslave, thanx for the reply.

I added the mode "1024x768" to the xorg.conf, but I still cant see it in the resolution changing drop down menu. I deleted all other modes and just kept 1024x768, but I still couldnt see 1024x768 in the menu. Instead the resolution defaulted to 640x480.

When I opened my xorg.conf to see what happened, I saw that there was a line called "load dri", which was supposed to be commented out. But there was already a commented out "#load dri" which leads me to think that the driver is not installed.

At no point during boot do I see a "nVidia" splash screen.

What is the problem? Do I need to delete the files and start over? The installation process went without problems, but I dont think the driver is running. I dont have any 3D apps at the moment.

How many FPS am I supposed to be getting in"gltest"?

Any help appreciated

Last edited by brokenpromises; 03-22-2005 at 03:14 PM.
 
Old 03-22-2005, 05:42 PM   #4
Technoslave
Member
 
Registered: Dec 2003
Location: Northern VA
Posts: 493

Rep: Reputation: 30
Tux Racer is a 3D app, if you have that.

I don't know what drop down you're talking about, but I can generally tell what resolution things run at...in a similiar thread, someone opened up Gimp and created a window in the resolution he wanted and found that his linux install was fibbing to him with regards to the resolution he was seeing.

Anyway, as far as I know, if you only have 1024x768 as the mode in your file, it's either going to be that resolution, or it's going to be a black screen.

There's no need to reboot in order to get the resolution inside your xorg.conf, just hit CTRL+ALT+BACKSPACE, that will restart your X session.
 
Old 03-22-2005, 08:05 PM   #5
brokenpromises
Member
 
Registered: Jan 2005
Location: NZ
Distribution: Fedora / Debian
Posts: 98

Original Poster
Rep: Reputation: 21
Hi Again Technoslave

My monitor has an OSD display which displays the resolution that it is currently on along with the refresh rate. My monitor says that its running 800x600.

Its looking like I might have to format again today and start again, however Id like to go around this if possible.

I really dont think that the driver is installed, because I do not see any nVidia splash screen. I will try playing tuxracer and post results again.

Last edited by brokenpromises; 03-23-2005 at 06:11 AM.
 
Old 03-23-2005, 06:12 AM   #6
brokenpromises
Member
 
Registered: Jan 2005
Location: NZ
Distribution: Fedora / Debian
Posts: 98

Original Poster
Rep: Reputation: 21
When I got home I realised that I didnt have any games installed, so I went into the package manager and installed TuxRacer.

After the installation completed, I opened tuxracer and it simply refused to open. It "loaded" for a little while (when your mouse icon changes) and then just went away and never did anyhting. Rebooting did not fix it either.

Now im stuck with 800x600 and without a 3D application.

Any help on How to Change my Resolution and how to check if the driver is running will be highly appreciated.

I also tried changing resolution using CTRL+ALT++, and CTRL+ALT+- and the only 2 available modes were 800x600 and 640x480

Please Help? :'(

Last edited by brokenpromises; 03-23-2005 at 06:14 AM.
 
Old 03-26-2005, 04:37 PM   #7
evil_empire
Member
 
Registered: Mar 2005
Distribution: Fedora Core 3
Posts: 176

Rep: Reputation: 31
Paste or attach or provide a link to your xorg.conf file here.
Also provide the output of "lsmod" and "modinfo nvidia" commands here. Run these command on a console while on X.
 
Old 03-26-2005, 07:05 PM   #8
brokenpromises
Member
 
Registered: Jan 2005
Location: NZ
Distribution: Fedora / Debian
Posts: 98

Original Poster
Rep: Reputation: 21
My xorg.conf file:

Code:
Section "ServerLayout"
        Identifier     "single head configuration"
        Screen      0  "Screen0" 0 0
        InputDevice    "Mouse0" "CorePointer"
        InputDevice    "Keyboard0" "CoreKeyboard"
EndSection

Section "Files"   
        RgbPath      "/usr/X11R6/lib/X11/rgb"
        FontPath     "unix/:7100"
EndSection

Section "Module"
        Load  "dbe"
        Load  "extmod"
        Load  "fbdevhw"
        Load  "glx"
        Load  "record"
        Load  "freetype"
        Load  "type1"
#      Load  "dri"
EndSection

Section "InputDevice"
        Identifier  "Keyboard0"
        Driver      "kbd"
        Option      "XkbModel" "pc105"
        Option      "XkbLayout" "us"
EndSection

Section "InputDevice"
        Identifier  "Mouse0"
        Driver      "mouse"
        Option      "Protocol" "IMPS/2"
        Option      "Device" "/dev/input/mice"
        Option      "ZAxisMapping" "4 5"
        Option      "Emulate3Buttons" "yes"
EndSection

Section "Monitor"
        Identifier   "Monitor0"
        VendorName   "Monitor Vendor"
        ModelName    "Unknown monitor"
        HorizSync    31.5 - 37.9
        VertRefresh  50.0 - 70.0
        Option      "dpms"
EndSection

Section "Device"
        Identifier  "Videocard0"
        Driver      "nv"
        VendorName  "Videocard vendor"
        BoardName   "NVIDIA GeForce 4 MX (generic)"
EndSection

Section "Screen"
        Identifier "Screen0"
        Device     "Videocard0"
        Monitor    "Monitor0"
        DefaultDepth     24
        SubSection "Display"
                Viewport   0 0
                Depth     16
                Modes    "1024x768" "800x600" "640x480"
        EndSubSection
        SubSection "Display"
                Viewport   0 0
                Depth     24
                Modes    "1024x768" "800x600" "640x480"
        EndSubSection
EndSection

Section "DRI"
        Group        0
        Mode         0666
And running commands "lsmod" and "modinfo nvidia" gave an error message saying "bash: modinfo: command not found" and "bash: lsmod: command not found".

Help
 
Old 03-26-2005, 09:39 PM   #9
mjmwired
Member
 
Registered: Apr 2004
Distribution: CentOS6, CentOS5, F16, F15, Ubuntu, OpenSuse
Posts: 620

Rep: Reputation: 39
I don't think you followed my instructions exactly, there should be "nvidia" in devices NOT "nv".

Also 'modinfo' and 'lsmod' were run as root, that's why I had: "root@charon"

http://www.mjmwired.net/resources/mj...3.shtml#nvidia

Last edited by mjmwired; 03-26-2005 at 09:40 PM.
 
Old 03-27-2005, 01:00 PM   #10
evil_empire
Member
 
Registered: Mar 2005
Distribution: Fedora Core 3
Posts: 176

Rep: Reputation: 31
mjmwired is correct.
Change the driver to "nvidia" instead of "nv" in the Device section.
Restart X and then see.
Post back.
 
Old 03-27-2005, 05:58 PM   #11
brokenpromises
Member
 
Registered: Jan 2005
Location: NZ
Distribution: Fedora / Debian
Posts: 98

Original Poster
Rep: Reputation: 21
Hi,

I modified my xorg.conf file so it looks like this and rebooted:
Code:
Section "Device"
        Identifier  "Videocard0"
        Driver      "nvidia"
        VendorName  "Videocard vendor"
        BoardName   "NVIDIA GeForce 4 MX (generic)"
EndSection
But I am still unable to see any other resolutions other than 800x600 and 640x480 in the menu. When I cycle through the available resolutions (using CTRL ALT +), the only two available are 800x600 and 640x480.

And as for the "lsmod" and "modinfo nvidia" commands:

http://img77.exs.cx/img77/9904/screenshot8cb.png

Last edited by brokenpromises; 03-27-2005 at 06:02 PM.
 
Old 03-28-2005, 10:57 AM   #12
mjmwired
Member
 
Registered: Apr 2004
Distribution: CentOS6, CentOS5, F16, F15, Ubuntu, OpenSuse
Posts: 620

Rep: Reputation: 39
Are you sure you restarted your xserver? (every change to xorg.conf requires the xserver to be restarted - usually logging out and back in should do the trick)

Did you try running '/usr/bin/system-config-display' and setting the correct resolution?

You might want to try picking a monitor that supports more resolutions, it looks like you have a generic monitor with limited scan ranges.

-----------------

[mirandam@charon ~]$ su -
Password:

[root@charon ~]# /sbin/lsmod | grep nvidia
nvidia 3917564 12

[root@charon ~]# /sbin/modinfo nvidia
filename: /lib/modules/2.6.11.5/kernel/drivers/video/nvidia.ko
license: NVIDIA
alias: char-major-195-*
parmtype: nv_disable_pat:int
parmtype: NVreg_VideoMemoryTypeOverride:int
parmtype: NVreg_EnableVia4x:int
parmtype: NVreg_EnableALiAGP:int
parmtype: NVreg_ReqAGPRate:int
parmtype: NVreg_NvAGP:int
parmtype: NVreg_EnableAGPSBA:int
parmtype: NVreg_EnableAGPFW:int
parmtype: NVreg_SoftEDIDs:int
parmtype: NVreg_Mobile:int
parmtype: NVreg_ResmanDebugLevel:int
parmtype: NVreg_FlatPanelMode:int
parmtype: NVreg_DevicesConnected:int
parmtype: NVreg_VideoEnhancement:int
parmtype: NVreg_RmLogonRC:int
vermagic: 2.6.11.5 preempt K7 REGPARM gcc-3.4
depends:
alias: pci:v000010DEd*sv*sd*bc03sc00i00*
 
Old 04-05-2005, 07:56 PM   #13
sueno
Member
 
Registered: Feb 2004
Location: Reykjavík Iceland
Distribution: Fedora Core 3. also testing mandrake
Posts: 54

Rep: Reputation: 15
Howdy brokenpromises I once had a similar problem as you are having now I installed a new video card into my computer and got stuck with 800x600 resolution what I did was turning off the xserver by entering command line as root and type "init 3"
When the xserver was turned off then you log in as root again and type the command "system-config-display" then you should get some grapical interface again where you can adjust some settings for your display including the resolution.
When you are done setting your resolution and perhaps changing some other settings there if you like. you press ok to exit
then you should be at the console again then you just have to type "init 5" to get your graphical server back up and running and it should be running the resolution you adjusted in configuration program.

Hope this helps.

Last edited by sueno; 04-05-2005 at 07:59 PM.
 
Old 04-06-2005, 03:09 AM   #14
brokenpromises
Member
 
Registered: Jan 2005
Location: NZ
Distribution: Fedora / Debian
Posts: 98

Original Poster
Rep: Reputation: 21
Thanx for all the help guys, but the problem has been solved. The solution was right there the whole time.

Thanx Again
brokenpromises
 
Old 04-19-2005, 03:18 PM   #15
hasan_aljudy
LQ Newbie
 
Registered: Apr 2005
Posts: 2

Rep: Reputation: 0
I'm having the same problem .. how did you solve it brokenpromises?
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Can't change resolution MichaelD Linux - Newbie 2 05-23-2005 02:03 PM
Text Resolution, Graphic resolution. Change from prompt dlublink Suse/Novell 2 01-28-2005 12:50 PM
With the change to Xorg in 10.1 has anyone installed ATI Drivers jchance Mandriva 0 11-29-2004 08:35 PM
ndiswrapper installed, drivers installed, what now? beatupbilly Fedora 1 11-19-2004 06:32 PM
Installed ATI drivers but low resolution carlosinfl Fedora 3 06-06-2004 12:54 AM


All times are GMT -5. The time now is 03:19 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration