LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Fedora
User Name
Password
Fedora This forum is for the discussion of the Fedora Project.

Notices

Reply
 
Search this Thread
Old 03-22-2004, 03:53 PM   #1
tsj944
LQ Newbie
 
Registered: Mar 2004
Posts: 4

Rep: Reputation: 0
INIT: id "x" respawning too fast. Disabled for 5 minutes


Hi all,

I recently installed Fedora Core 1 (Yarrow) and everything went fine, until I download updates (I clicked on the red check mark at the bottom right of the screen). After they were done downloading, some started to install but I received some error messages. Now when I try to boot into Linux it starts to load, but end up getting a message that says:

INIT: id "x" respawning too fast. Disabled for 5 minutes.

If I do not do anything, this message will keep coming up at 5 minute intervals. I can press enter an come to a login prompt, but being new to Linux, I do not really know what to do. Do I have to reinstall Fedora? or are there commands I can type? I appreciate the help. Thanks
 
Old 03-22-2004, 06:47 PM   #2
jailbait
Guru
 
Registered: Feb 2003
Location: Blue Ridge Mountain
Distribution: Debian Wheezy, Debian Jessie
Posts: 7,552

Rep: Reputation: 180Reputation: 180
"Do I have to reinstall Fedora? or are there commands I can type?"

The automated update system has screwed up and made a mess of your rpm package set. You can log in as root and try to straighten out the mess by hand. To log in as root when you get the respawn mesage use the three finger command <Ctrl> <Alt> <F3> This will get you a login prompt. Login as root and you will be at a command prompt. Use the command:
rpm -qa | sort > /root/packages.txt
to create a list of all of your rpm packages. You can use:
less /root/packages.txt
to look through the packages that you have installed.

"some started to install but I received some error messages."

Take a look at the packages that were listed in the install error messages and see if you can find duplicate packages or missing packages.

Here is a thread that explains what to do with duplicate packages:
http://www.linuxquestions.org/questi...hreadid=160259

If you have messages about missing dependencies then you have missing packages. In that case you should install the missing package from either the install CD or by downloading the package. Use command line rpm to do the install.

If you cannot get the problem straightened out the way I described above then you will have to reinstall Fedora Core 1 to get a good working set of installed packages.

___________________________________
Be prepared. Create a LifeBoat CD.
http://users.rcn.com/srstites/LifeBo...home.page.html

Steve Stites
 
Old 03-22-2004, 10:59 PM   #3
jon-do
Member
 
Registered: Feb 2004
Distribution: Red 9, FC 2 Test 3
Posts: 98

Rep: Reputation: 16
I am guessing one of the package that was upgraded was xorg. Do this

when it says "respawning too fast ......" hit Ctrl-Alt-F2 to go to another console
and login as root.

At the cml type
#XFree86 =configure
#XFree86 -xf86config /root/XF86Config.new

You should see a blank screen with an "X" cursor
hit Ctrl-Alt-Backspace to get to the cml

Then
#cp /root/XF86Config.new /etc/X11/XF86Config
 
Old 04-03-2004, 06:54 AM   #4
fermy
LQ Newbie
 
Registered: Apr 2004
Posts: 1

Rep: Reputation: 0
I've got the same problem here. Just tried what jon-do suggested. Everything goes according to plan, the XF86Config.new file gets created, the cross on the dark screen appears, and /etc/X11/XF86Config is replaced.

However, when I try startx, the following error shows up:

xauth: error while loading shared libraries: libXmuu.so.1: cannot open shared object file: No such file or directory

Seems like some files or directories are missing, how do I restore them?

Thanks a lot.
 
Old 04-03-2004, 10:23 AM   #5
jailbait
Guru
 
Registered: Feb 2003
Location: Blue Ridge Mountain
Distribution: Debian Wheezy, Debian Jessie
Posts: 7,552

Rep: Reputation: 180Reputation: 180
"xauth: error while loading shared libraries: libXmuu.so.1: cannot open shared object file: No such file or directory

Seems like some files or directories are missing, how do I restore them?"

When I issue:
rpm -q --whatprovides linXmuu.so.1 I get:
XFree86-libs-4.3.0-42

So check to see if you have XFree86-libs-4.3.0-42 with:
rpm -qi XFree86-libs

If it is not installed then you can install it again from your install CD.

If it is installed then you can remove it with:
rpm --nodeps -e XFree86-libs
and then install it again from your install CD.

___________________________________
Be prepared. Create a LifeBoat CD.
http://users.rcn.com/srstites/LifeBo...home.page.html

Steve Stites
 
Old 04-05-2004, 10:26 PM   #6
xoxanxox
LQ Newbie
 
Registered: Apr 2004
Posts: 1

Rep: Reputation: 0
Similar Problem..

I have recently been trying to install Red Hat 9.0 and have been having some difficulties. The installation seem to go fine until the time comes to reboot after it's done. There seems to be pages and pages of one line over and over again: "rpmbd: fatal region error detected; run recovery". The system then reboots and when I get to the boot loader (GRUB) I load RH ( which is the only OS on my system ) and I get the same error: "INIT: Id "x" respawning too fast. Disabled for 5 minutes" after which I recieve a login prompt. Every five minutes the message is displayed again regardless of my activities. I, too, am a new linux user and frankly I don't know what to do. I have tried downloading drivers for my videocard (nVIDIA RIVA TNT2) because I have read that was the problem. However my attempts to install it were unsuccessful. Another thing I tried was to edit the XF86Config file only to discover that I do not have one. I was wondering if this may be a problem. If anyone has any suggestions for me, they would would be greatly appreciated.

Thanks a lot.
_________________________________

K. Hogan
 
Old 04-06-2004, 10:07 AM   #7
jailbait
Guru
 
Registered: Feb 2003
Location: Blue Ridge Mountain
Distribution: Debian Wheezy, Debian Jessie
Posts: 7,552

Rep: Reputation: 180Reputation: 180
"Another thing I tried was to edit the XF86Config file only to discover that I do not have one. I was wondering if this may be a problem."

Yes. You absolutely have to have /etc/X11/XF86Config for X Window to work.

" Every five minutes the message is displayed again regardless of my activities."

You can temporarily stop trying to run X Window until you get the problem fixed. To default to command line mode edit your /etc/inittab file and change the default run level from 5 to 3.
In /etc/inittab change the line:
id:5:initdefault:
to
id:3:initdefault:
and then reboot.

This does not solve your missing XF86Config problem but it will get rid of the annoying error messages. Whenever you get X Window working then you can set the default run level back to 5.

___________________________________
Be prepared. Create a LifeBoat CD.
http://users.rcn.com/srstites/LifeBo...home.page.html

Steve Stites
 
Old 04-06-2004, 10:01 PM   #8
jon-do
Member
 
Registered: Feb 2004
Distribution: Red 9, FC 2 Test 3
Posts: 98

Rep: Reputation: 16
Do what jailbait wrote, that will put you in single user mode. login as root and do what I wrote. This will create a file called XF86Config.new.
Copy that file to /etc/X11/ as XF86Config.
 
Old 04-07-2004, 11:54 AM   #9
tmagaz
LQ Newbie
 
Registered: Apr 2004
Location: Tennessee
Distribution: Red Hat Enterprise
Posts: 1

Rep: Reputation: 0
FYI: I can recreate this error by deleting the kerberos directory under /usr. Apparently, some part of X or possibly Up2date uses the shared libraries in this directory during startup. I stumbled on this by accidentally deleting the directory. The easiest way to restore it was to "force" install the krb* rpms. I only discovered this fact after restoring my /boot partition.

Last edited by tmagaz; 04-07-2004 at 11:58 AM.
 
Old 04-08-2004, 12:16 AM   #10
jaggedsphere
LQ Newbie
 
Registered: Mar 2004
Posts: 7

Rep: Reputation: 0
tsj944, did you ever solve this problem??? I am suffering from the same one right now and would so like to be able to get my emails off or at least move them to my Win98 drive but alas there seems to be no simple solution....
 
Old 05-03-2004, 03:48 PM   #11
vraa
LQ Newbie
 
Registered: Jul 2003
Location: Houston
Distribution: Fedora!
Posts: 1

Rep: Reputation: 0
I have had the exact same problems as the original poster, I followed the directions in this thread and so far it's worked, I need to start installing the required modules from the CD, infact it's getting to the Anaconda *i think* installer now.
 
Old 05-20-2004, 12:23 PM   #12
pmarino
LQ Newbie
 
Registered: May 2004
Posts: 4

Rep: Reputation: 0
When i wrote

#XFree86 -xf86config /root/XF86Config.new

it didn't appear the blank screen with a x cursor. It shows an error message that says no screens.What can i Do? please help!
 
Old 05-24-2004, 03:02 PM   #13
DarkVenom
Member
 
Registered: May 2004
Distribution: Fedora Core 1
Posts: 35

Rep: Reputation: 15
having the same problem too all i did was did the updates and then thats it and then the disable crap comes in and i followed what u ppl said but still cant get it to work
 
Old 05-25-2004, 08:18 AM   #14
DarkVenom
Member
 
Registered: May 2004
Distribution: Fedora Core 1
Posts: 35

Rep: Reputation: 15
when i typed in etc/X11/ as XF86Config. it said permission denied and i did su and then password
 
Old 05-25-2004, 08:27 AM   #15
DarkVenom
Member
 
Registered: May 2004
Distribution: Fedora Core 1
Posts: 35

Rep: Reputation: 15
would i have to reinstall the cds now since we cant get rid of that problem
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
INIT: Id "x" respawning too fast: disabled for 5 minutes linuxccc Linux - Software 3 07-25-2007 07:23 PM
X Server broken. start w/ "INIT: ld "x" respawning too fast: disabled for 5 minutes&q tektone Linux - Hardware 5 07-25-2007 07:18 PM
RH9 INIT: ID "x" respawning too fast: disabled for 5 minutes valimare Linux - Newbie 4 02-16-2007 04:53 AM
INIT:Id "x" respawning too fast: disabled for 5 minutes problem satimis Red Hat 4 07-22-2004 06:03 AM
INIT: Id "x" respawning too fast: disabled for 5 minutes" Lego3 Linux - Software 0 06-16-2004 08:01 AM


All times are GMT -5. The time now is 01:36 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration