LinuxQuestions.org
Register a domain and help support LQ
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Fedora
User Name
Password
Fedora This forum is for the discussion of the Fedora Project.

Notices

Reply
 
Search this Thread
Old 01-05-2005, 10:55 AM   #1
kirill_igum
LQ Newbie
 
Registered: Jan 2005
Location: Rochester, NY, USA
Distribution: UBUNTU
Posts: 3

Rep: Reputation: 0
I/O problems with CD-ROM after recent (04JAN05) kernel update


Hi,

I have Fedora Core 3 and i use linux for scientific calculations (i am not an expert).
Before a recent update through "yum update", everything worked fine. I was able to eject CD-ROM as a user and was able to read CDs without any problem.

After I ran "yum update" on 03 or 04 of Jan 05 (don't know where to find logs) i got few problems:

I am unable to eject CD as a user, i get an error:
[kirill@rachmaninov ~]$ eject
eject: unable to eject, last error: Invalid argument
(i can mount and umount as a user)
However, if i do the same under root, i get:
[root@rachmaninov ~]# eject
eject: unable to eject, last error: Invalid argument
but cd ejects. So for some reason it works under root.

I cannot acces or cp some files from cd-rom as user or root, for example:
[root@rachmaninov ~]# cp /media/cdrecorder/squarepusher\ -\ ultravisitor/squarepusher\ -\ ultravisitor\ -\ 13\ -\ tetra-sync.mp3 .
cp: reading `/media/cdrecorder/squarepusher - ultravisitor/squarepusher - ultravisitor - 13 - tetra-sync.mp3': Input/output error
if i try to cp this file on mac or pc, i have no problem.
if i use mpg321 to play this file on my machine, i have no problem.

Thanks
 
Old 01-05-2005, 10:58 AM   #2
kirill_igum
LQ Newbie
 
Registered: Jan 2005
Location: Rochester, NY, USA
Distribution: UBUNTU
Posts: 3

Original Poster
Rep: Reputation: 0
sorry, forgot to add:

[root@rachmaninov ~]# uname -s -r -v -m -p -i -o
Linux 2.6.9-1.681_FC3smp #1 SMP Thu Nov 18 15:19:10 EST 2004 i686 i686 i386 GNU/Linux
 
Old 01-05-2005, 12:39 PM   #3
kirill_igum
LQ Newbie
 
Registered: Jan 2005
Location: Rochester, NY, USA
Distribution: UBUNTU
Posts: 3

Original Poster
Rep: Reputation: 0
Talking oops

oops, sry

solved the problem by restarting the comp.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Problems with NVIDIA drivers after kernel update with yast online update Sheytan Linux - Software 4 05-06-2007 10:27 AM
FC3 (with recent kernel update) CUPS problem dinkydarko Fedora 4 03-10-2005 12:05 AM
Problems with NVIDIA drivers after kernel update with yast online update Sheytan Linux - Distributions 0 10-13-2004 11:01 AM
CD Rom Mount Problem after Kernel Update Cynthia Blue Linux - Hardware 1 12-28-2003 03:21 PM
UPDATE - Recent Downtime jeremy LQ Suggestions & Feedback 18 12-02-2003 11:14 AM


All times are GMT -5. The time now is 09:53 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration