LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Fedora
User Name
Password
Fedora This forum is for the discussion of the Fedora Project.

Notices

Reply
 
Search this Thread
Old 02-03-2007, 08:14 AM   #1
decrepit
Member
 
Registered: May 2006
Distribution: Ubuntu10.04, < fedora12
Posts: 347

Rep: Reputation: 34
How to tell yum missing dependency is actually there


I'm having shutdoen problems in Core6 whenever I run wine version 0.9.29.fc6, (as previously posted here http://www.linuxquestions.org/questi...d.php?t=523437 ).
I also have core4 on this machine with no similar problem running wine 0.9.27.fc4.
Thought I'd see what happens if I uninstall 0.9.29.fc6 and reinstall the core4 version.

yum comes up with this missing dependency.
Error: Missing Dependency: /usr/X11R6/bin/xmessage is needed by package wine-core.

however I've copied xmessage to /usr/X11R6/bin from FC4.

[mike@core6 ~]$ cd /usr/X11R6/bin
[mike@core6 bin]$ ls
mkfontdir mkfontscale xmessage

so how do I convince yum the dependency isn't missing???

Last edited by decrepit; 02-03-2007 at 08:19 AM.
 
Old 02-03-2007, 08:39 AM   #2
macemoneta
Senior Member
 
Registered: Jan 2005
Location: Manalapan, NJ
Distribution: Fedora x86 and x86_64, Debian PPC and ARM, Android
Posts: 4,593
Blog Entries: 2

Rep: Reputation: 326Reputation: 326Reputation: 326Reputation: 326
The dependency is still missing, because the dependency isn't in the filesystem, it's in the rpm database. You need to install the requisite package that contains xmessage:

yum install xorg-x11-apps

Have you applied maintenance to your system to see if the problem is corrected? I'm using wine with FC6 on multiple machines, and haven't encountered your problem.
 
Old 02-04-2007, 05:36 AM   #3
decrepit
Member
 
Registered: May 2006
Distribution: Ubuntu10.04, < fedora12
Posts: 347

Original Poster
Rep: Reputation: 34
Thanks macemoneta, didn't realise yum depended on the rpm database.
The problem is thou, xorg-x11-apps is already installed.
It seems that core6 doesn't install it to /usr/X11R6/bin
If I use core4 version, I afraid that will interfer with the aps that need the core6 version.

I guess you mean updates by system maintenance????
I'm on broadband but it's download limited, I've only got 80mb left until next week, (core6 updates sure use it up!) after that I'll have a fully up to date machine, hopefully that will fix it.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
yum: Missing dependency xine-lib(vdr) >= 0.7.6 beekley Fedora 2 07-13-2006 11:08 PM
Yum dependency: beats me! linmix Linux - Software 1 02-21-2006 05:16 PM
yum not resolving dependency? dr_zayus69 Linux - Software 6 02-04-2006 02:08 AM
yum install kino - Missing Dependency: libavutil.so schlough Linux - Software 5 01-13-2006 09:07 PM
yum missing dependencY puppet Linux - Software 6 10-26-2005 10:20 AM


All times are GMT -5. The time now is 05:39 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration