LinuxQuestions.org
Go Job Hunting at the LQ Job Marketplace
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Fedora
User Name
Password
Fedora This forum is for the discussion of the Fedora Project.

Notices

Reply
 
Search this Thread
Old 12-13-2004, 01:51 AM   #1
rykel
Member
 
Registered: Jan 2004
Location: Singapore
Distribution: Main Distros: Ubuntu & SUSE, OTHERS: MEPIS, FC, Mandriva, Linspire, Xandros, Knoppix
Posts: 58

Rep: Reputation: 15
How to set up proxy in Apt-Get's apt.conf?


Hi there,

I am using Fedora Core 3, and have just installed Apt-Get from FreshRPMs.

However, when I try to download the package listings from the repositories, it does not work.

I am using dial-up, and I believe that apt.conf is not configured to use my ISP proxy. (yes, no problem surfing the net etc.)

My current ISP proxy is http://proxy.mystarhub.com.sg (port: 8080).

Could you please show me how to edit my apt.conf file in order to use the proxy?

Or is there another possible reason why apt-get cannot seem to connect to the freshrpms servers?

Thanks!!!


Regards,

Rykel
Singapore
 
Old 12-15-2004, 08:32 AM   #2
MarioT
Member
 
Registered: May 2004
Posts: 52

Rep: Reputation: 15
define in apt.conf

Acquire {
Retries "0";
HTTP {
Proxy "http://proxy.mystarhub.com.sg:8080";
};
};

Last edited by MarioT; 12-15-2004 at 08:33 AM.
 
Old 12-16-2004, 02:59 AM   #3
rykel
Member
 
Registered: Jan 2004
Location: Singapore
Distribution: Main Distros: Ubuntu & SUSE, OTHERS: MEPIS, FC, Mandriva, Linspire, Xandros, Knoppix
Posts: 58

Original Poster
Rep: Reputation: 15
It works - thanks buddy!!!

tat was sooo simple... my problem was tat i tried to state my proxy AFTER tat semi-colon... :P

btw, i am now taking the effort to learn how i may install programs WITHOUT using RPMs, OR to create my own RPMs like what Thomas Chung from FedoraNews taught... (yupp, managed to create working copies of firefox 1.0 and thunderbird for FC1)... so wish me success!


best regards,

rykel
singapore
 
Old 08-15-2011, 06:48 AM   #4
muditagarwal88
LQ Newbie
 
Registered: Aug 2011
Posts: 1

Rep: Reputation: Disabled
user type changed to root

i am using ubuntu 11.04 and i am new to linux.. now i have changed my user type from custom to administrator...
and i want to access apt.conf to add proxy informtion. which i cant not.. it is a readonly file.. how can i change it back.

is there any difference between administrator and root.. because the file says it as read and write permission to root.
 
Old 08-15-2011, 06:53 AM   #5
TobiSGD
Moderator
 
Registered: Dec 2009
Location: Hanover, Germany
Distribution: Main: Gentoo Others: What fits the task
Posts: 15,598
Blog Entries: 2

Rep: Reputation: 4059Reputation: 4059Reputation: 4059Reputation: 4059Reputation: 4059Reputation: 4059Reputation: 4059Reputation: 4059Reputation: 4059Reputation: 4059Reputation: 4059
Yes, there are differences between root and administrator. I don't know which, but being an administrator is not the same as being root. if you want to edit that file you have to do it as root with
Code:
sudo YOUR_FAVORITE_TEXT_EDITOR_HERE /etc/apt/apt.conf
 
Old 08-15-2011, 07:08 AM   #6
brianL
LQ 5k Club
 
Registered: Jan 2006
Location: Oldham, Lancs, England
Distribution: Slackware & Slackware64 14.1
Posts: 7,049
Blog Entries: 52

Rep: Reputation: Disabled
Are you sure you want to ask a Ubuntu question in the Fedora forum?
 
Old 08-15-2011, 07:26 AM   #7
TobiSGD
Moderator
 
Registered: Dec 2009
Location: Hanover, Germany
Distribution: Main: Gentoo Others: What fits the task
Posts: 15,598
Blog Entries: 2

Rep: Reputation: 4059Reputation: 4059Reputation: 4059Reputation: 4059Reputation: 4059Reputation: 4059Reputation: 4059Reputation: 4059Reputation: 4059Reputation: 4059Reputation: 4059
LOL, that question was asked in 2004, muditagarwal88 revived an old thread.
 
Old 08-15-2011, 07:42 AM   #8
brianL
LQ 5k Club
 
Registered: Jan 2006
Location: Oldham, Lancs, England
Distribution: Slackware & Slackware64 14.1
Posts: 7,049
Blog Entries: 52

Rep: Reputation: Disabled
Ha! Never noticed the thread date.
muditagarwal88
Press the Report button and ask for your question to be moved to the Ubuntu forum.
 
Old 12-18-2011, 02:35 AM   #9
penguin359
LQ Newbie
 
Registered: Jul 2007
Distribution: Gentoo Linux
Posts: 3

Rep: Reputation: 0
Quote:
Originally Posted by MarioT View Post
define in apt.conf

Acquire {
Retries "0";
HTTP {
Proxy "http://proxy.mystarhub.com.sg:8080";
};
};
Since this thread has been revived, I thought I'd post a shorter, but identical answer to what MarioT wrote. Try just using this:
Code:
Acquire::http::Proxy "http://proxy.mystarhub.com.sg:8080";
Retries defaults to 0 so it isn't needed.
 
Old 10-09-2013, 03:24 AM   #10
dotancohen
Member
 
Registered: Dec 2004
Location: Haifa
Distribution: Fedora Core 4, Kubuntu
Posts: 235

Rep: Reputation: 32
Do note that the default apt-cacher port is 3142, not 8080 as suggested by the posts above.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
can't set up apt to use proxy Confusedious Linux - Newbie 3 10-06-2005 12:05 PM
where is apt.conf? darkleaf Linux - Software 6 07-05-2004 11:52 AM
apt-proxy and cron-apt - download once for the whole LAN Abject Debian 1 06-20-2004 01:53 PM
i can't find the file /etc/apt/apt.conf. lsj Linux - Newbie 1 05-21-2004 02:24 AM
APT behind a proxy geniarse Debian 4 04-14-2004 09:26 PM


All times are GMT -5. The time now is 11:11 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration