LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Fedora
User Name
Password
Fedora This forum is for the discussion of the Fedora Project.

Notices

Reply
 
Search this Thread
Old 10-13-2010, 05:40 PM   #1
PaulFC5
Member
 
Registered: Feb 2008
Posts: 62

Rep: Reputation: 3
How to set the default screen resolution in FC13?


A bit of an idiot question I know but:

Have just upgraded from FC12 - which I found to be a bit of a pain - nothing seemed to work as it should - to FC13 which is working quite a lot better - automatically updating everything etcetc - and I can now install what I want. The preupgrade installation bizzo seemed to work quite well.

But I can't seem to be able to set a "default" screen resolution - being slightly geriatric I like 832x624 - but rather have to do it manually every time I start the OS. Not a big problem, sure, but slightly annoying.
Have dug into it quite a lot but can't seem to find a way of having it boot up each time at the res I want it to.

And also, in the past, when clicking onto URLs in emails in Thunderbird they automatically opened themselves in Firefox - but not now.
Even clicking "Open in Browser" doesn't seem to do it. Have to copy and paste etc.
Surprisingly the other way seems to work OK - "Contact:" tags in Firefox open a Tbird email pane.
Again not a major prob but annoying.
Do I have to get into about.config or write a user.js file or that sort of thing??

TIA
Paul W

FC13 Athlon 64x2/5000 2G RAM
 
Old 10-14-2010, 06:14 AM   #2
RockDoctor
Senior Member
 
Registered: Nov 2003
Location: Minnesota, US
Distribution: Fedora, Ubuntu
Posts: 1,225

Rep: Reputation: 251Reputation: 251Reputation: 251
Quote:
Originally Posted by PaulFC5 View Post
But I can't seem to be able to set a "default" screen resolution - being slightly geriatric I like 832x624 - but rather have to do it manually every time I start the OS. Not a big problem, sure, but slightly annoying.
Have dug into it quite a lot but can't seem to find a way of having it boot up each time at the res I want it to.
This part's easy - you need an appropriately-configured /etc/X11/xorg.conf file. As root, in a terminal window:
Code:
Xorg -configure :1
. This will create the file xorg.conf.new. Edit the "Screen" section, adding the following line below the appropriate Depth:
Code:
Modes "832x624" "800x600"
(I threw the 800x600 in there just in case for some reason 832x624 causes problems)
 
1 members found this post helpful.
Old 10-14-2010, 05:00 PM   #3
PaulFC5
Member
 
Registered: Feb 2008
Posts: 62

Original Poster
Rep: Reputation: 3
Couldn't get to an xorgconf.new

Heil Obama!

Shouldn't really say that - our SS is serving under the crosstika too - the first NZ VC (Victoria Cross) in 60ish years - since Adolf1 warned about what's now going on in Occupied Palestine under the judeofascists with the support of the various fuehrers of the 4thReich.


Thanks for that leadin to the way to set up the "automatic" 8ooishx600ish resolution I'm after.
But when I did that in a terminal, as root of course, a string of all the vidcards the Xserver recognises came up with:

(EE) module ABI major version (6) doesn't match the server's version (7)
(EE) Failed to load module "ast" (module requirement mismatch, 0)
(EE) module ABI major version (6) doesn't match the server's version (7)
(EE) Failed to load module "apm" (module requirement mismatch, 0)
(++) Using config file: "/root/xorg.conf.new"
(==) Using config directory: "/etc/X11/xorg.conf.d"
(==) Using system config directory "/usr/share/X11/xorg.conf.d"
(EE) [drm] No DRICreatePCIBusID symbol
Number of created screens does not match number of detected devices.
Configuration failed.

appearing underneath.
[Can't ATM figure out how to paste "whatevers" as quotes - next time :-S :-) - it was enough to dig up KWrite after a series of crashes in KWord]

So it seems it tried to make an xorgconf.new but it couldn't do it - one didn't appear - maybe some libraries/apps missing??
And xorg.conf.d didn't seem to have much relevance to anything.

AAMOI to get to a root log-in: it seems to be hopeless to try to do it from the "Switch User" bizzo - the CPU(s) seem to wind up working at most of 100% - the OS virtually stalls - have to reboot to get to root - maybe one needs to su?? - a bit like winDoze :-(

As to how to set up Skype in linux - seems to be in the "forget it material" category :-) :-D

TIA
Paul W
 
Old 10-19-2010, 03:29 AM   #4
JZL240I-U
Senior Member
 
Registered: Apr 2003
Location: Germany
Distribution: openSuSE 13.1 / 12.3_64-KDE, Ubuntu 14.04, Fedora 20, Mint 17, Chakra
Posts: 3,674

Rep: Reputation: Disabled
I don't understand why you want to reduce resolution. Just for larger fonts you can set the system fonts in the control center. For further tweaking look here:

http://www.linuxquestions.org/questi...5/#post1309027
 
1 members found this post helpful.
Old 10-19-2010, 04:52 PM   #5
PaulFC5
Member
 
Registered: Feb 2008
Posts: 62

Original Poster
Rep: Reputation: 3
It's not just the fonts - it's the icons etc too.
The eyesight is just getting to be a bit less user-friendly with age :-S - I have to use my reading glasses to get rabbits with my (silenced) .22 (legal here in Kiwiland) now - I'd rather see the sights clearly and have to squint a little for the target :-)
And, having started this computers bizzo about 2 decades ago when even having a graphics screen - 640x480 with 16 colours WOW! was cutting edge :-), I've just become used to using a screen res of 832x624 or similar.
Even though it's occasionally necessary to change it to 1000ishx800ish to get at the "OK" buttons etc in some apps.

But after a fair bit of time fossicking around in /etc/X11.... I can't seem to even find an xorg.conf file - only a setup-by-default keyboard file:
///etc/X11/xorg.conf.d/00-system-setup-keyboard.conf
And the man page wasn't very helpful either - especially if I can't find an xorg.conf file to modify.

Do I have to write one - or a user.js - or an xorg.conf.new??

TIA
Paul W
 
Old 10-20-2010, 03:43 AM   #6
JZL240I-U
Senior Member
 
Registered: Apr 2003
Location: Germany
Distribution: openSuSE 13.1 / 12.3_64-KDE, Ubuntu 14.04, Fedora 20, Mint 17, Chakra
Posts: 3,674

Rep: Reputation: Disabled
Yes, the new distros create xorg.conf on the fly and don't save it. You can have one on hard disk, though, and it gets used then. Just use any convenient copy you may have on an older machine and use just the sections you need.

If it is for the icons, try the way shown in the link I posted. Works for the whole setup. Just experiment a little, doesn't hurt and you can always save your old settings in a comment.

I know eye concerns, my dioptre is about -7.5 with some astigmatism thrown in...
 
1 members found this post helpful.
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
screen resolution set too high, now i get a black screen strangerklone Linux - Newbie 3 05-22-2009 05:43 AM
how do I set the default resolution? (slackware-current) Drone4four Slackware 5 08-10-2006 05:53 AM
default screen resolution smaller than max. resolution ?? Thoddy Linux - General 2 11-10-2005 01:33 AM
Hoary -- can't set a default vid resolution harrkev Ubuntu 3 08-21-2005 04:24 PM
How can I set the default resolution? DFrey Linux - Newbie 5 11-19-2001 02:33 AM


All times are GMT -5. The time now is 10:52 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration