LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Fedora (http://www.linuxquestions.org/questions/fedora-35/)
-   -   How to make SCIM to work (http://www.linuxquestions.org/questions/fedora-35/how-to-make-scim-to-work-284753/)

satimis 01-31-2005 11:28 PM

How to make SCIM to work
 
Hi folks,

FedoraCore2
Linux localhost.localdomain 2.6.10-1.9_FC2 #1
scim-1.1.2-1fc3

I have SCIM running on this FC2 for more than 2 weeks but I could not manage inputing Chinese. Followings are the results of my tests

1)
on terminal
# service IIim stop
Stopping IIIMF input server: [ OK ]
(Remark: I also have IIIMF running on this box)

2)
# ps awx | grep scim
6281 pts/2 R 0:00 grep scim

3)
on terminal 1
$ locale
LANG=zh_CN.UTF-8
LC_CTYPE="zh_CN.UTF-8"
LC_NUMERIC="zh_CN.UTF-8"
LC_TIME="zh_CN.UTF-8"
LC_COLLATE="zh_CN.UTF-8"
LC_MONETARY="zh_CN.UTF-8"
LC_MESSAGES="zh_CN.UTF-8"
LC_PAPER="zh_CN.UTF-8"
LC_NAME="zh_CN.UTF-8"
LC_ADDRESS="zh_CN.UTF-8"
LC_TELEPHONE="zh_CN.UTF-8"
LC_MEASUREMENT="zh_CN.UTF-8"
LC_IDENTIFICATION="zh_CN.UTF-8"
LC_ALL=

$ XMODIFIERS=@im=SCIM LC_CTYPE=zh_CN.UTF-8

on terminal 2
$ export OOO_FORCE_DESKTOP=none
$ ooffice

[Ctrl]+[Space], [Ctrl]+[Shift] have no function, Chinese input not working

4)
same to kedit.

Any advice? TIA

B.R.
satimis

JDW 02-01-2005 03:08 PM

hi,

don't launch oowriter from a separate terminal, launch it from the same terminal as you did the XMODIFEIR setting for...that should work...

jdw

satimis 02-02-2005 02:47 AM

Hi JDW,

Quote:

don't launch oowriter from a separate terminal, launch it from the same terminal as you did the XMODIFEIR setting for...that should work...
Performed another round as follows;

# service IIim stop
Stopping IIIMF input server: [ OK ]

(same terminal)
$ XMODIFIERS=@im=SCIM LC_CTYPE=zh_CN.UTF-8
$ export OOO_FORCE_DESKTOP=none
$ ooffice

OOoWriter started but impossible to input Chinese. [Ctrl]+[Space], [Ctrl]+[Alt]+[Space], [Ctrl]+[Shift] all have no function.

$ ps awx | grep scim
4567 pts/3 S 0:00 grep scim

I also tried omitting the step "export OOO_FORCE_DESKTOP=none"
$ XMODIFIERS=@im=SCIM LC_CTYPE=zh_CN.UTF-8
$ ooffice

Also the same result. Chinese input did not work.

B.R.
satimis

JDW 02-02-2005 03:13 PM

a-ha, try this :-

$ export XMODIFIERS=@im=SCIM; export LC_CTYPE=zh_CN.UTF-8; scim -d

$ oowriter

I will bet this will work...

cheers,

jdw

satimis 02-03-2005 04:21 AM

Hi JDW,

Quote:

a-ha, try this :-

$ export XMODIFIERS=@im=SCIM; export LC_CTYPE=zh_CN.UTF-8; scim -d
$ oowriter

Now OOoWriter started

[Ctrl]+[Space] switching English/Euro Languages
[Ctrl]+[Shift] switching input methods, but only "code input" method available.

I tried "right click" the tag to start SCIM settings but I can't add other input methods. I don't know how to operate "code input". Is there a way to add other input methods

B.R.
satimis

JDW 02-03-2005 02:43 PM

another a-ha, have you got scim-chinese and scim-tables installed as well? that will provide you with the input tables etc...

one step closer!

jdw

JDW 02-03-2005 02:51 PM

one more thing, the packages/sources for scim software are available at http://sourceforge.net/projects/scim...

jdw

satimis 02-03-2005 09:10 PM

Quote:

Originally posted by JDW
another a-ha, have you got scim-chinese and scim-tables installed as well? that will provide you with the input tables etc...
Hi JDW,

scim-1.1.2-1fc3
============
I have following packages downloaded already;

scim-chinese-0.4.2-1fc3.i386.rpm
scim-tables-0.5.0-1fc3.i386.rpm
scim-tables-additional-0.5.0-1fc3.i386.rpm
scim-tables-zh-0.5.0-1fc3.i386.rpm

Please advise which "scim-tables..." I need to install.

TIA

B.R.
satimis

satimis 02-03-2005 09:19 PM

Quote:

Originally posted by JDW
[B]one more thing, the packages/sources for scim software are available at http://sourceforge.net/projects/scim...
/B]
Hi JDW,

The link seems broken. Whether you meant the tarball

scim-1.0.1.tar.gz

I have it downloaded already from
http://www.scim-im.org/downloads/scim_download

However before installing scim form source I think I need to remove 'scim-1.1.2-1fc3' first which is now running on my FC2 box.

B.R.
satimis

JDW 02-03-2005 09:38 PM

you can install all of them if you like...it shouldn't hurt your setup, but the scim-tables-zh would be the Chinese tables...

jdw

satimis 02-04-2005 04:02 AM

Hi JDW,

Quote:

you can install all of them if you like...it shouldn't hurt your setup, but the scim-tables-zh would be the Chinese tables...
# rpm -Uvh scim-chinese-0.4.2-1fc3.i386.rpm
Code:

/etc/security/selinux/file_contexts: No such file or directory
error: Failed dependencies:
        libscim-1.0.so.0 is needed by scim-chinese-0.4.2-1fc3
        libscim-gtkutils-1.0.so.0 is needed by scim-chinese-0.4.2-1fc3

# rpm -Uvh scim-tables-0.5.0-1fc3.i386.rpm
Code:

/etc/security/selinux/file_contexts: No such file or directory
Preparing...                ########################################### [100%]
  1:scim-tables            ########################################### [100%]

# rpm -Uvh scim-tables-additional-0.5.0-1fc3.i386.rpm
Code:

/etc/security/selinux/file_contexts: No such file or directory
Preparing...                ########################################### [100%]

scim-tables-0.5.0-1fc3.i386.rpm
scim-tables-additional-0.5.0-1fc3.i386.rpm
both went through without problem.

I was not allowed to install 'scim-chinese-0.4.2-1fc3' because of dependencies. Only code input method was available. other input method disappeared

'scim-tables-additional-0.5.0-1fc3.i386.rpm' is for other languages input such as Russian, Vietnam, Arabic, etc,

Any suggestion. TIA

B.R.
satimis

satimis 02-04-2005 04:20 AM

Hi JDW,

Further to my last posting, google search found

libscim-1.0.so.0
libscim-gtkutils-1.0.so.0
coming from
scim-1.0.2-1fc3.i386 RPM

I have 'scim-1.0.2-1fc3.i386.rpm' downloaded. Shall I remove 'scim-1.1.2-1fc3', the latest version of SCIM, which is running on my FC2 box and install the older version 'scim-1.0.2-1fc3.i386 RPM'

B.R.
satimisscim-1.0.2-1fc3.i386 RPM

JDW 02-06-2005 08:04 PM

hi,

1) you shouldn't have to change to the older version of scim.

2) the package scim-pinyin is a replacement for scim-chinese, you don't really need the scim-chinese package

jdw

satimis 02-06-2005 08:28 PM

Quote:

Originally posted by JDW
1) you shouldn't have to change to the older version of scim.

2) the package scim-pinyin is a replacement for scim-chinese, you don't really need the scim-chinese package

Hi JDW,

$ rpm -qa | grep scim
scim-tables-0.5.0-1fc3
scim-1.1.2-1fc3
scim-tables-additional-0.5.0-1fc3

The above SCIM packages are running in my FC2 box. 'scim-tables-additional-0.5.0-1fc3' is for other languages input such Koreian, Arabic, etc. I only have 'code input' available which I'm not familiar. Other code inputs such as Canjie, Easy, pinyin, etc. could not be found.

I have following packages downloaded in my box
Code:

scim-1.0.1.tar.gz                scim-tables-0.5.0-1fc3.i386.rpm
scim-1.1.2-1fc3.i386.rpm          scim-tables-additional-0.5.0-1fc3.i386.rpm
scim-1.1.3.tar.gz                scim-tables-zh-0.5.0-1fc3.i386.rpm
scim-chinese-0.4.2-1fc3.i386.rpm  scim-uim-0.1.3-4fc3.i386.rpm
scim-devel-1.1.2-1fc3.i386.rpm    skim-1.0.1-1fc2.i386.rpm
scim-pinyin-0.5.0-1fc3.i386.rpm  skim-1.0.2-3fc3.i386.rpm
scim-qtimm-0.7.5-1fc3.i386.rpm    skim-1.0.3.tar.bz2

I suppose I have to install;
scim-pinyin-0.5.0-1fc3.i386.rpm
scim-tables-zh-0.5.0-1fc3.i386.rpm
skim-1.0.2-3fc3.i386.rpm (for KDE)

I expect to input Chinese on English environment (locale: English US), input methods preferred: Canjie, Easy, pinyin.

How about
scim-qtimm-0.7.5-1fc3.i386.rpm
scim-uim-0.1.3-4fc3.i386.rpm

I have no idea what are their function. Please advise.

TIA

B.R.
satimis

JDW 02-06-2005 08:35 PM

install scim-pinyin and scim-tables and you should be able to use Cangjie, smart pinyin etc. in an English environment (I've found as long as you set your LC_CTYPE setting to zh_CN.UTF-8 or zh_TW.UTF-8.

jdw


All times are GMT -5. The time now is 08:40 AM.