LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Fedora
User Name
Password
Fedora This forum is for the discussion of the Fedora Project.

Notices



Reply
 
Search this Thread
Old 08-08-2009, 08:57 AM   #1
tamil_sel@yahoo.com
LQ Newbie
 
Registered: Aug 2009
Posts: 4

Rep: Reputation: 0
How to create modprobe.conf.


Hello,

How to create/generate modprobe.conf.

I Fedora 11 hang, it display fedora logo only and no signon screen.
When do interactive startup, it just stop at line
Starting atd:

On top of screen can see a message
'WARNING eprecated config file /etc/modprobe.conf, all config files belong into /etc/modprobe.d/.'

I can signon to tty2(ctrl-alt-f2) and notice that /etc/modprobe.conf is blank.

This happen when recent update for Fedora 11. My banshee, VLC and mplayer just play sound for few second and then no sound. For VLC and mplayer movie keep playing without sound but for banshee a song suppose to complete 4 minutes but now it just finish 1 minute without any sound. I uninstall alsa using yumex but not able to install back. Then I reboot my PC but just hang.

Anyone in this forum can help how-to create modprobe.conf.

Thank you.
Tamil.

Last edited by tamil_sel@yahoo.com; 08-08-2009 at 11:21 PM.
 
Old 08-09-2009, 06:03 PM   #2
PTrenholme
Senior Member
 
Registered: Dec 2004
Location: Olympia, WA, USA
Distribution: Fedora, (K)Ubuntu
Posts: 4,154

Rep: Reputation: 333Reputation: 333Reputation: 333Reputation: 333
No, modprob.conf is (as the message you posted suggested) no longer used by Fedora. If you look at /etc/modprobe.d, you should see something like this:
Code:
$ ls -l /etc/modprobe.d/
total 40
-rw-r--r--. 1 root root   52 2008-08-18 07:36 anaconda.conf
-rw-r--r--. 1 root root  845 2009-04-09 11:40 blacklist.conf
-rw-r--r--. 1 root root  184 2009-07-01 09:59 blacklist-nouveau.conf
-rw-r--r--. 1 root root  845 2008-07-23 03:25 blacklist.rpmnew
-rw-r--r--. 1 root root  809 2009-05-30 15:23 blacklist.rpmsave
-rw-r--r--. 1 root root   16 2008-01-04 00:43 blacklist-visor.conf
-rw-r--r--. 1 root root 5616 2009-05-19 18:56 dist.conf
-rw-r--r--. 1 root root  473 2009-05-19 18:56 dist-oss.conf
-rw-r--r--. 1 root root   53 2009-06-30 04:50 floppy-pnp.conf
-rw-r--r--. 1 root root    0 2009-04-20 16:51 local.conf
If you need to make a change or addition to the modprob settings, add it to /etc/modprobe.d/local.conf using the format you can see in, e.g., /etc/modprobe.d/dist.conf.

Note that apps which modify /etc/modprob.conf may create that file, but it's use may cause conflicts with the files in /etc/modprobe.d/, so additions made there should be moved to the local.conf file, and the (unwanted, conflicting) modprobe.conf file unlinked.
 
Old 08-12-2009, 09:22 AM   #3
tamil_sel@yahoo.com
LQ Newbie
 
Registered: Aug 2009
Posts: 4

Original Poster
Rep: Reputation: 0
Quote:
Originally Posted by PTrenholme View Post
No, modprob.conf is (as the message you posted suggested) no longer used by Fedora. If you look at /etc/modprobe.d, you should see something like this:
Code:
$ ls -l /etc/modprobe.d/
total 40
-rw-r--r--. 1 root root   52 2008-08-18 07:36 anaconda.conf
-rw-r--r--. 1 root root  845 2009-04-09 11:40 blacklist.conf
-rw-r--r--. 1 root root  184 2009-07-01 09:59 blacklist-nouveau.conf
-rw-r--r--. 1 root root  845 2008-07-23 03:25 blacklist.rpmnew
-rw-r--r--. 1 root root  809 2009-05-30 15:23 blacklist.rpmsave
-rw-r--r--. 1 root root   16 2008-01-04 00:43 blacklist-visor.conf
-rw-r--r--. 1 root root 5616 2009-05-19 18:56 dist.conf
-rw-r--r--. 1 root root  473 2009-05-19 18:56 dist-oss.conf
-rw-r--r--. 1 root root   53 2009-06-30 04:50 floppy-pnp.conf
-rw-r--r--. 1 root root    0 2009-04-20 16:51 local.conf
If you need to make a change or addition to the modprob settings, add it to /etc/modprobe.d/local.conf using the format you can see in, e.g., /etc/modprobe.d/dist.conf.

Note that apps which modify /etc/modprob.conf may create that file, but it's use may cause conflicts with the files in /etc/modprobe.d/, so additions made there should be moved to the local.conf file, and the (unwanted, conflicting) modprobe.conf file unlinked.
Thank you, for your help my friend. In my Fedora 11 don't have local.conf. So I create a blank /etc/modprobe.d/local.conf and still cannot bootup. When bootup it just hang, displaying fedora sign in gnome, if interactive startup, it just hang at line 'Starting atd [ok]'. How to identify what cause this problem ?

Thank you.
Tamil.
 
Old 08-12-2009, 12:34 PM   #4
PTrenholme
Senior Member
 
Registered: Dec 2004
Location: Olympia, WA, USA
Distribution: Fedora, (K)Ubuntu
Posts: 4,154

Rep: Reputation: 333Reputation: 333Reputation: 333Reputation: 333
If you got the [OK] for the atd service, that one was started. So you need to see what the next service to be started is. On my Fedora 11 system, the init sequence after atd looks like this:
Code:
$ ls -l /etc/rc.d/rc5.d | grep -A 20 atd
lrwxrwxrwx. 1 root root 13 2009-08-01 13:33 S95atd -> ../init.d/atd
lrwxrwxrwx. 1 root root 18 2009-07-29 10:50 S97libvirtd -> ../init.d/libvirtd
lrwxrwxrwx. 1 root root 21 2009-08-07 09:30 S98tog-pegasus -> ../init.d/tog-pegasus
lrwxrwxrwx. 1 root root 14 2009-07-28 18:07 S98wicd -> ../init.d/wicd
lrwxrwxrwx. 1 root root 11 2009-06-11 06:36 S99local -> ../rc.local
So, if my boot hung after atd was started, I'd look for a problem with the virtual system. Notice, however, that the last script to be executed is /etc/rc.d/rc.local which, on my system, looks like this:
Code:
$ cat /etc/rc.d/rc.local
#!/bin/sh
#
# This script will be executed *after* all the other init scripts.
# You can put your own initialization stuff in here if you don't
# want to do the full Sys V style init stuff.
touch /var/lock/subsys/local

#------------------
# Added to the default script
#
# Activate and mount all available volume groups with mount points in /etc/fstab
./etc/rc.d/rc.vg_activate

# Mount any "noauto" devices listed in /etc/fstab that are not already mounted
./etc/rc.d/rc.mount_noauto
Unless you've changed the default script, yours should look like the part of mine above the #----- line. If it doesn't, I'd try to see if something in there was causing your problem.
 
Old 08-14-2009, 10:42 AM   #5
tamil_sel@yahoo.com
LQ Newbie
 
Registered: Aug 2009
Posts: 4

Original Poster
Rep: Reputation: 0
Quote:
Originally Posted by PTrenholme View Post
If you got the [OK] for the atd service, that one was started. So you need to see what the next service to be started is. On my Fedora 11 system, the init sequence after atd looks like this:
Code:
$ ls -l /etc/rc.d/rc5.d | grep -A 20 atd
lrwxrwxrwx. 1 root root 13 2009-08-01 13:33 S95atd -> ../init.d/atd
lrwxrwxrwx. 1 root root 18 2009-07-29 10:50 S97libvirtd -> ../init.d/libvirtd
lrwxrwxrwx. 1 root root 21 2009-08-07 09:30 S98tog-pegasus -> ../init.d/tog-pegasus
lrwxrwxrwx. 1 root root 14 2009-07-28 18:07 S98wicd -> ../init.d/wicd
lrwxrwxrwx. 1 root root 11 2009-06-11 06:36 S99local -> ../rc.local
So, if my boot hung after atd was started, I'd look for a problem with the virtual system. Notice, however, that the last script to be executed is /etc/rc.d/rc.local which, on my system, looks like this:
Code:
$ cat /etc/rc.d/rc.local
#!/bin/sh
#
# This script will be executed *after* all the other init scripts.
# You can put your own initialization stuff in here if you don't
# want to do the full Sys V style init stuff.
touch /var/lock/subsys/local

#------------------
# Added to the default script
#
# Activate and mount all available volume groups with mount points in /etc/fstab
./etc/rc.d/rc.vg_activate

# Mount any "noauto" devices listed in /etc/fstab that are not already mounted
./etc/rc.d/rc.mount_noauto
Unless you've changed the default script, yours should look like the part of mine above the #----- line. If it doesn't, I'd try to see if something in there was causing your problem.
Thank you my friend. I follow as per instruction.
When use below command :-
$ls -l /etc/rc.d/rc5.d | grep -A 20 atd
It only dispay

lrwxrwxrwx. 1 root root 13 2009-08-01 13:33 S95atd -> ../init.d/atd
lrwxrwxrwx. 1 root root 11 2009-06-11 06:36 S99local -> ../rc.local[/code]

When use below command :-
$ cat /etc/rc.d/rc.local
It display everything as your script but after #--------- all blank.

I am also using nvidia FX5200 graphic card.

Do nvidia causing problem ?
How to rebulid file '/etc/rc.d/rc.local' ?

Thank you.
Tamil.
 
Old 08-14-2009, 12:45 PM   #6
PTrenholme
Senior Member
 
Registered: Dec 2004
Location: Olympia, WA, USA
Distribution: Fedora, (K)Ubuntu
Posts: 4,154

Rep: Reputation: 333Reputation: 333Reputation: 333Reputation: 333
No, as I said, the lines after (and including) the #---- are things I added to my system. What you have is the default rc.local, so you do not need to "rebuild" it at all.

So, what we've discovered is that your system is booting correctly, but not actually starting. Since you have a nVidia video card, and Fedora does not distribute and propitiatory software, your system will be attempting to start using the FOSS noveau driver. But that driver does not work with every nVidia chip set.

Therefor you need to either install the propitiatory nVidia driver or, for now, see if you can boot your system using the vesa video driver. (The vesa driver provides only a small part of the full video functionality, but it should be enough for you to download and install the nVidia driver from the rpm-fusion repositories.)

To boot using the vesa driver, you need to add the xdriver=vesa option to the kernel line in the GRUB boot menu. The simplest way to do that is to use the built-in GRUB editor to make a temporary change to the boot instructions.

Here's how:
  1. When you first power on your system, you should see a message that GRUB is loading stage 1.5. When that message is displayed, press the "Escape" key (or Control+[ if you don't have a key labeled "Escape"). Note: If your boot menu is displayed with a message that Fedora is going to boot in 5 seconds, press the "Escape" again.
  2. That should display the boot menu without the timer message.
  3. Use the arrow keys on the keyboard to highlight the Fedora boot line. (You have to use the arrow keys because GRUB does not recognize the mouse.)
  4. Press the "e" key to start the GRUB temporary editor. (The editor makes only temporary changes because it only change the in-memory copy of the configuration file, but does not write the changes you make back into the file.)
  5. The full boot instructions should be displayed. Use the keyboard arrow keys to select the line that starts with kernel and press "e" key again.
  6. That line should be displayed with the cursor located at the end of the line.
  7. Type a space followed by xdriver=vesa and then press the "return" key.
  8. The boot line should again be displayed. Press the "b" key to tell GRUB to boot from the changed line.
If that works, you will have proved that you problem is that the FOSS driver does not recognize your nVidia hardware.

I'd suggest that to add the rpm-fusion repository to your YUM repository list, and install the akmod package for the latest nVidia driver. Alternatively, you could download the run package from the nVidia web site and compile the driver yourself, but the problem with that is that:
  1. You will need to recompile the driver yourself every time the kernel changes and
  2. you will need to install the compiler and kernel development files.
Post again if this is not clear. Good luck.
 
Old 08-17-2009, 10:31 AM   #7
tamil_sel@yahoo.com
LQ Newbie
 
Registered: Aug 2009
Posts: 4

Original Poster
Rep: Reputation: 0
Quote:
Originally Posted by PTrenholme View Post
No, as I said, the lines after (and including) the #---- are things I added to my system. What you have is the default rc.local, so you do not need to "rebuild" it at all.

So, what we've discovered is that your system is booting correctly, but not actually starting. Since you have a nVidia video card, and Fedora does not distribute and propitiatory software, your system will be attempting to start using the FOSS noveau driver. But that driver does not work with every nVidia chip set.

Therefor you need to either install the propitiatory nVidia driver or, for now, see if you can boot your system using the vesa video driver. (The vesa driver provides only a small part of the full video functionality, but it should be enough for you to download and install the nVidia driver from the rpm-fusion repositories.)

To boot using the vesa driver, you need to add the xdriver=vesa option to the kernel line in the GRUB boot menu. The simplest way to do that is to use the built-in GRUB editor to make a temporary change to the boot instructions.

Here's how:
  1. When you first power on your system, you should see a message that GRUB is loading stage 1.5. When that message is displayed, press the "Escape" key (or Control+[ if you don't have a key labeled "Escape"). Note: If your boot menu is displayed with a message that Fedora is going to boot in 5 seconds, press the "Escape" again.
  2. That should display the boot menu without the timer message.
  3. Use the arrow keys on the keyboard to highlight the Fedora boot line. (You have to use the arrow keys because GRUB does not recognize the mouse.)
  4. Press the "e" key to start the GRUB temporary editor. (The editor makes only temporary changes because it only change the in-memory copy of the configuration file, but does not write the changes you make back into the file.)
  5. The full boot instructions should be displayed. Use the keyboard arrow keys to select the line that starts with kernel and press "e" key again.
  6. That line should be displayed with the cursor located at the end of the line.
  7. Type a space followed by xdriver=vesa and then press the "return" key.
  8. The boot line should again be displayed. Press the "b" key to tell GRUB to boot from the changed line.
If that works, you will have proved that you problem is that the FOSS driver does not recognize your nVidia hardware.

I'd suggest that to add the rpm-fusion repository to your YUM repository list, and install the akmod package for the latest nVidia driver. Alternatively, you could download the run package from the nVidia web site and compile the driver yourself, but the problem with that is that:
  1. You will need to recompile the driver yourself every time the kernel changes and
  2. you will need to install the compiler and kernel development files.
Post again if this is not clear. Good luck.
Thank you my friend. I having same problem. My Fedora 11 can bootup and shows blue screen with 'F' as logo but it didn't display login screen.

I removed nvidia driver. Still cannot display login screen. I set form 5 to 3 in /etc/inittab (id:3:initdefault). Then I start startx, got error message 'no screens found'.

I attach log file from /var/log and I hope you can get clear picture about my fedora 11. The log files are boot.log, messages and Xorg.0.log. Please remove '.txt' at end of file name.
If you read messages log file on 'Aug 15 22:33:17 localhost initrefdm main process(1936) terminated with status 1.' at this point it just hang. Cannot attach messages file, it size is 514kb.

If you manage to find any answer or suggestion please let know.

Thank you.
Tamil.

Thank you my friend. I decide to re-install fedora 11. I am closing this thread.

Thank you for everyone.
Attached Files
File Type: txt boot.log.txt (10.0 KB, 2 views)
File Type: txt Xorg.0.log.txt (4.4 KB, 0 views)

Last edited by tamil_sel@yahoo.com; 08-21-2009 at 11:20 AM. Reason: Decide to cloas.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
modprobe doesn't work; why is modprobe.conf deprecated in slack 12? aquilolumen Slackware 13 08-26-2007 03:05 AM
Questions re - /etc/modprobe.d/modprobe.conf The_Outlander Slackware 9 12-12-2006 09:28 PM
modprobe.conf from modules.conf Vaxon Linux - Hardware 1 09-22-2004 06:22 AM
[FC2] How to write a modprobe.conf from a module.conf??? Coume Fedora 0 05-31-2004 04:40 AM
create lilo.conf or grub.conf through commands newpenguin Linux - Software 1 11-28-2003 09:22 PM


All times are GMT -5. The time now is 11:34 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration