LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Fedora
User Name
Password
Fedora This forum is for the discussion of the Fedora Project.

Notices

Reply
 
LinkBack Search this Thread
Old 01-10-2008, 07:26 AM   #1
mhtrinh
LQ Newbie
 
Registered: Jan 2006
Location: Avignon, France
Posts: 16

Rep: Reputation: 0
Question How to change default KDE mount option ?


I have Fedora 8 x86_64.

I want to change default option when KDE mount my usb stick (eg : where to mount, umask, users option, etc ...)

I tried :
- Edit /etc/fstab : the device change each time ... (/dev/sdb, /dev/sdc, /dev/sdb1, etc ...)

- Configure autofs : same problem : the device's number and letter change ...

- Edit /etc/hal/fdi/policy/preferences.fdi : I can change the mount point (but I still can't change the "/media") but it don't take umask and users option

- install ivman : I can't find documentations on how to add my options (mount point, users, umask option) :-(

Thanks for your help.
 
Old 01-11-2008, 04:01 PM   #2
jailbait
Guru
 
Registered: Feb 2003
Location: Blue Ridge Mountain
Distribution: Debian Wheezy, SolydK 2013
Posts: 7,434

Rep: Reputation: 134Reputation: 134
Quote:
Originally Posted by mhtrinh View Post
I have Fedora 8 x86_64.

I want to change default option when KDE mount my usb stick (eg : where to mount, umask, users option, etc ...)

I tried :
- Edit /etc/fstab : the device change each time ... (/dev/sdb, /dev/sdc, /dev/sdb1, etc ...)

- Configure autofs : same problem : the device's number and letter change ...

- Edit /etc/hal/fdi/policy/preferences.fdi : I can change the mount point (but I still can't change the "/media") but it don't take umask and users option

- install ivman : I can't find documentations on how to add my options (mount point, users, umask option) :-(

Thanks for your help.
Try putting a line in /etc/fstab for each possible device.

--------------------
Steve Stites
 
Old 01-14-2008, 03:17 AM   #3
mhtrinh
LQ Newbie
 
Registered: Jan 2006
Location: Avignon, France
Posts: 16

Original Poster
Rep: Reputation: 0
Hi,

I have a problematic USB stick : it mount as /dev/sdb an not /dev/sdb1
When I put 2 lines /dev/sdb and /dev/sdb1 in /etc/fstab, I got mount error :
Quote:
/dev/sdb /media/usb_key vfat rw,users,umask=0002,noatime,flush,utf8,shortname=lower 0 0
/dev/sdb1 /media/usb_key vfat rw,users,umask=0002,noatime,flush,utf8,shortname=lower 0 0
With KDE, when I do : right-click on the usb icon on desktop, then "mount", I got error message :
Mount: wrong fs fstype, bad option, bad superblock on /dev/sdb
[blabla ...]
 
  


Reply

Tags
automount, mount, usb


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
How do I change the default language in KDE on FC3? canegames Linux - Software 1 08-01-2006 03:24 PM
How do I change the default boot option in GRUB martinr Linux - Software 3 04-10-2006 06:05 AM
Change the KDE default ICON !? memo007 Linux - Software 2 09-08-2005 06:50 PM
Change Default Manager to KDE from gnome sall Linux - General 5 07-15-2005 02:01 PM
How do I change the default desktop to KDE? jdruin Linux - Newbie 3 04-26-2004 06:47 PM


All times are GMT -5. The time now is 11:49 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration