LinuxQuestions.org
Visit the LQ Articles and Editorials section
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Fedora
User Name
Password
Fedora This forum is for the discussion of the Fedora Project.

Notices

Reply
 
Search this Thread
Old 11-30-2003, 12:20 PM   #1
NickC
Member
 
Registered: Nov 2003
Location: Portland, OR, USA
Posts: 111

Rep: Reputation: 15
How to boot to nongraphical with Grub


I've searched through the boards and it's clear that there are issues running graphical Linux with LCD monitors. That exact thing happened to me also: when I switched my CRT for a 17" LCD, Linux would complain that screen refresh was something like 90 Hz and couldn't be supported.

Doing some research, it seems I can fix the problem by correcting XF86Config to recognize the new LCD. But how do I get to that? I can change the GRUB booting to go to command, but I can't seem to get into Linux to change this configuration file to set monitor resolution to 1280 x 1024 at 60 Hz.
 
Old 11-30-2003, 01:14 PM   #2
wiraone
Member
 
Registered: Nov 2003
Location: Diawang-awangan
Distribution: Ubuntu Hoary!
Posts: 319

Rep: Reputation: 30
In the /boot/grub.conf, remove the rhgb at the end of kernel line..

and /etc/sysconfig/init

Change the GRAPHICAL to NO

Good luck ..

Last edited by wiraone; 11-30-2003 at 01:17 PM.
 
Old 11-30-2003, 01:18 PM   #3
NickC
Member
 
Registered: Nov 2003
Location: Portland, OR, USA
Posts: 111

Original Poster
Rep: Reputation: 15
Thanks. But how do I get there in the first place? Right now, with the new LCD, it goes to Grub, shows Fedora as the boot option, but then as it finishes the boot it gets to that message that screen is unsupported. Are you saying I have to switch first to an older monitor that does work, then log in?

And if that's the only way, can I set the graphical mode to ask me if I want graphical or nongraphical?

Last edited by NickC; 11-30-2003 at 08:27 PM.
 
Old 11-30-2003, 09:03 PM   #4
nigey2k2
LQ Newbie
 
Registered: Nov 2003
Posts: 7

Rep: Reputation: 0
Had probs with mine booting into X cause of the Radeon 9800 Pro .. here's what to do to get to the prompt.

boot up
when grub pops up press e
use the arrow keys to gotot the second line it should look something like this

"kernel /vmlinuz-2.4.22-1.2115.nptl ro root=LABEL=/ rhgb"

press e again (this enable you to edit the line

change the line t look like this ;

"kernel /vmlinuz-2.4.22-1.2115.nptl ro root=LABEL=/ rhgb init 3"

remove the " 's

press enter
then press b to boot

bingo you got init 3 .. if you have a Radeon 9800 Pro and are getting lockups on booting to X do the above steps then install the ati driver for XFree 4.3, run fglrxconfig .. reboot .. and bingo Also a suggestion if you dont have 3d hardware acceleration .. when running fglrxconfig answer yes to use the external agpgart module, ATI's seems to be broke.

hope this has helped
 
Old 12-01-2003, 08:04 AM   #5
NickC
Member
 
Registered: Nov 2003
Location: Portland, OR, USA
Posts: 111

Original Poster
Rep: Reputation: 15
Thanks, I will try. What does it do? Give 3 seconds to boot into Linux without graphics? I noticed there is a very brief display which says login: That sounds like what I need to do. My card is an nVidia TNT2 32 Mb.

Last edited by NickC; 12-01-2003 at 09:07 AM.
 
Old 12-01-2003, 09:27 AM   #6
nigey2k2
LQ Newbie
 
Registered: Nov 2003
Posts: 7

Rep: Reputation: 0
Quote:
Originally posted by NickC
Thanks, I will try. What does it do? Give 3 seconds to boot into Linux without graphics? I noticed there is a very brief display which says login: That sounds like what I need to do. My card is an nVidia TNT2 32 Mb.
No

init 3 is text mode only, so after logging in just do startx to get to graphical mode again.
 
Old 12-01-2003, 01:59 PM   #7
NickC
Member
 
Registered: Nov 2003
Location: Portland, OR, USA
Posts: 111

Original Poster
Rep: Reputation: 15
Cool - thanks!
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
gentoo : grub: The file /boot/boot/grub/stage1 not read correctly Boudewijn Linux - Software 3 05-21-2008 03:13 AM
need to access /boot/grub/menu.lst and /boot/grub/device.map neouto Linux - Newbie 8 09-04-2005 11:45 AM
Setting password on grub, wha to do after changing default values in /boot/grub/menu. sarajevo Linux - Security 1 08-17-2005 08:01 PM
Grub setup problem (/boot/grub/stage1 not found) davidas Debian 2 04-28-2004 08:13 PM
how to open MDK 9.1 nongraphical perdesiz Linux - Software 4 10-10-2003 11:32 AM


All times are GMT -5. The time now is 05:10 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration