LinuxQuestions.org
Register a domain and help support LQ
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Fedora
User Name
Password
Fedora This forum is for the discussion of the Fedora Project.

Notices

Reply
 
Search this Thread
Old 11-21-2006, 06:05 PM   #1
S_VIN
LQ Newbie
 
Registered: Nov 2006
Location: Bangalore, India
Distribution: Fedora Core 6,
Posts: 2

Rep: Reputation: 0
How to automount windows drives in FC6?


Hi all,
I have installed FC6 in my PC along with winxp. I want to share my windows drives. The drives are D drive(hda5) and E drive(hda6).

It works fine if I try the regular mount command as:
Code:
mkdir /mnt/WinXP_D
mount -t vfat /dev/hda5 /mnt/WinXP_D

..and similar code for WinXP_E with hda6
But as you would all agree to mount this way each time you login is a pain in the ass. So I tried automounting by editing the /etc/fstab as:
Code:
/mnt/WinXP_D /dev/hda5 vfat rw,auto,user,sync 0 0
/mnt/WinXP_E /dev/hda6 vfat rw,auto,user,sync 0 0
But its giving error msgs as WinXP_D(and E) is not a block device,.. is write-protected,..cannot mount... in the second line trying to mount as read-only and then cannot mount as read-only also. I could not write down the exact sentences as the screen changes very fast.

What could be wrong? I had tried similar thing in RH8 and it had worked?

Kindly guide.
 
Old 11-21-2006, 06:33 PM   #2
David the H.
Bash Guru
 
Registered: Jun 2004
Location: Osaka, Japan
Distribution: Debian sid + kde 3.5 & 4.4
Posts: 6,823

Rep: Reputation: 1947Reputation: 1947Reputation: 1947Reputation: 1947Reputation: 1947Reputation: 1947Reputation: 1947Reputation: 1947Reputation: 1947Reputation: 1947Reputation: 1947
Change the auto line to noauto, then fstab will not attempt to mount it automatically at boot. That way you can try doing it manually from a terminal and you can see the output messages. When there's an entry in fstab, mounting is as simple as typing 'mount /dev/hd5' or 'mount /mnt/WinXP_D'. Once you've diagnosed the problem you can put it back.

(Edit after reading again) D'oh! I just noticed your problem. You have the device and mount point options reversed. /dev/hda5 should come first.

Finally, FAT drives usually should have a few extra options such as umask for setting the permissions level and uid/gid for setting the user and group. Read the vfat section in 'man mount' for more, and/or do a search of the site.

Last edited by David the H.; 11-21-2006 at 06:37 PM.
 
Old 11-21-2006, 06:58 PM   #3
Hitboxx
Senior Member
 
Registered: Mar 2006
Location: India
Distribution: Fedora
Posts: 1,562
Blog Entries: 3

Rep: Reputation: 51
It should read
Code:
/dev/hda5 /mnt/WinXP_D vfat rw,auto,user,umask=0000,sync 0 0
/dev/hda6 /mnt/WinXP_E vfat rw,auto,user,umask=0000,sync 0 0
 
Old 11-24-2006, 05:13 AM   #4
S_VIN
LQ Newbie
 
Registered: Nov 2006
Location: Bangalore, India
Distribution: Fedora Core 6,
Posts: 2

Original Poster
Rep: Reputation: 0
Thanks David and Shrikant. I implemented your suggestion. The problem is solved.
Thanks again.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
FC6 automount issues chidorex Fedora 8 05-08-2007 10:52 AM
FC5->FC6: hard drives VERY slow!? Thoddy Fedora 15 01-05-2007 02:08 AM
Optical drives don't automount in Slack 10.1 thorney Linux - Newbie 1 08-06-2005 08:26 AM
Automount in LE 2005 cannot access cdrom drives grimlaur Mandriva 6 05-28-2005 06:32 PM
automount cdrom and pen drives mokojin Slackware 3 10-31-2004 02:56 PM


All times are GMT -5. The time now is 08:10 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration