LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Fedora
User Name
Password
Fedora This forum is for the discussion of the Fedora Project.

Notices



Reply
 
Search this Thread
Old 11-10-2006, 05:47 PM   #1
badmofo666
Member
 
Registered: Mar 2004
Location: Texas, USA
Distribution: Ubuntu 12 (notebook), Debian Squeeze (home server), OpenSuse 12 (desktop)
Posts: 96

Rep: Reputation: 15
How do you get partitions to show on "Computer"


Hey, I finally got my fat32 harddisk to mount automatically in Fedora by adding a line in Fstab, but it doesn't show up in "Computer" on the desktop. How would I get it to show up there? Is there a special way you're supposed to mount partitions in Fedora?
 
Old 11-10-2006, 06:36 PM   #2
snecklifter
Member
 
Registered: Mar 2004
Location: UK/West Yorkshire/Huddersfield
Distribution: Fedora 7
Posts: 982

Rep: Reputation: 30
Hi badmofo

In Fstab you should have specified a location where your fat32 partition is mounted. Although I am not certain how to place a shortcut in the "Computer" folder, you can add one to your desktop by typing

$ ln -s /path/to/your/mount/point

in Terminal once you have changed directory to the Desktop.

Regards
Chris
 
Old 11-10-2006, 06:43 PM   #3
PTrenholme
Senior Member
 
Registered: Dec 2004
Location: Olympia, WA, USA
Distribution: Fedora, (K)Ubuntu
Posts: 4,154

Rep: Reputation: 333Reputation: 333Reputation: 333Reputation: 333
No, and what shows up in "Computer" depends on the desktop application you're using.

In your /etc/fstab, what permissions did you assign to the partitions, and where did you mount the drive? Usually a drive is mounted as a directory under /mnt. If that's what you did, go to FileSystem->mnt->{directory name you used}, and you should see the drive there. (If the permissions were not set, the drive will be "read only" unless you're logged in as "root" -- which you should not be.)

Here's an example from my fstab on my notebook:
Code:
/dev/hda1               /mnt/WinXP/c            ntfs    ro,uid=PCT,gid=disk 1 0
/dev/hda2               /mnt/WinXP/d            vfat    uid=PCT,gid=disk 1 2
FYI: My notebook (a Gateway M3) has a BIOS which forces me to have an XP partition as hda1, so I access it as a NTFS ro partition.

<edit>You should be aware that *NIX system use the "single directory tree" model, so all drives (or partitions) are found somewhere under "/". The specific place where the drive is found is the mount point you specify when you mount it.
</edit>

Last edited by PTrenholme; 11-10-2006 at 07:05 PM.
 
Old 11-11-2006, 06:42 AM   #4
badmofo666
Member
 
Registered: Mar 2004
Location: Texas, USA
Distribution: Ubuntu 12 (notebook), Debian Squeeze (home server), OpenSuse 12 (desktop)
Posts: 96

Original Poster
Rep: Reputation: 15
I have it mounted and working at /mnt/storage, but how exactly would I get it into "Computer" in Gnome, and for possible future reference KDE?
 
Old 11-12-2006, 07:52 AM   #5
decrepit
Member
 
Registered: May 2006
Distribution: Ubuntu10.04, < fedora12
Posts: 347

Rep: Reputation: 34
I've got a link to my vfat partions on the desktop, (as snecklifter says), and also to links in "computer", not if the ;ater is because of the former or not. But it's worth a try.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
bash script: using "select" to show multi-word options? (like "option 1"/"o zidane_tribal Programming 6 03-21-2013 11:35 AM
Printing no longer works, jobs queued and show "processing" rhauff Linux - Software 1 09-27-2006 02:19 PM
Kde "show desktop" icon / real player plug in alek66 Linux - General 3 06-19-2006 11:33 AM
Computer is not turning off after "init 0" or "shutdown -h now" f430 Linux - General 5 12-17-2005 03:54 AM
Lost DHCP Lease when putting computer in "Standby" mode for a "long" time pnellesen Linux - Networking 1 01-07-2005 12:44 AM


All times are GMT -5. The time now is 07:38 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration