LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Fedora
User Name
Password
Fedora This forum is for the discussion of the Fedora Project.

Notices

Reply
 
Search this Thread
Old 11-25-2004, 10:20 PM   #1
sdat1333
Member
 
Registered: Nov 2004
Location: North Carolina, USA
Distribution: None right now :(
Posts: 149

Rep: Reputation: 15
how do I make fedora load faster?


I have a dual-boot system with FC3 and WinXP home. WinXP Home loads in about 1 minute 15 seconds(including all the programs I have set to start up). Linux takes 2 minutes to load. I have an AMD Sempron 2600 and 512 megabytes of Ram, so it should load faster. Are there any tricks I can use to get a faster load time?
 
Old 11-25-2004, 10:50 PM   #2
seabass55
Member
 
Registered: Jan 2003
Location: 127.0.0.1
Distribution: Fedora&Gentoo
Posts: 207

Rep: Reputation: 30
have you built your own kernel? You could do that and get rid of all the stuff loading that you don't need. That goes considerably faster. Have you gone thru with chkconfig and disabled all the services you don't need? Sendmail, pcmcia, etc?
 
Old 11-25-2004, 11:31 PM   #3
sdat1333
Member
 
Registered: Nov 2004
Location: North Carolina, USA
Distribution: None right now :(
Posts: 149

Original Poster
Rep: Reputation: 15
How do I build my own kernel? Also, what do I not need to start up? This is a desktop computer.
 
Old 11-26-2004, 12:35 AM   #4
sdat1333
Member
 
Registered: Nov 2004
Location: North Carolina, USA
Distribution: None right now :(
Posts: 149

Original Poster
Rep: Reputation: 15
alright, i got my startup time from GRUB down to 1 minute 10 seconds. My BIOS takes 30 seconds to load, so I will have to work on that. My goal(almost an impossible goal) is for my computer to take 1 minute to load from pushing the power buttion into linux. I am slightly disapointed because windows XP loads in 1 minute including BIOS.
 
Old 11-26-2004, 10:17 AM   #5
seabass55
Member
 
Registered: Jan 2003
Location: 127.0.0.1
Distribution: Fedora&Gentoo
Posts: 207

Rep: Reputation: 30
actually the thing you have to remember with windows...just because you're at your login screen doesn't mean the computer is done booting. Windows keeps loading stuff in the background even when it's "done" booting. Not so with linux once it's done it's done (other than user specific stuff starting up). So don't compare it with windows as it's not very fair.
 
Old 11-26-2004, 10:32 AM   #6
sdat1333
Member
 
Registered: Nov 2004
Location: North Carolina, USA
Distribution: None right now :(
Posts: 149

Original Poster
Rep: Reputation: 15
My computer has autologin, so Idont time to startup screen. Also, I stop the timer once the orange light on the front of my computer stops blinking, and Iknow all software is done loading.
btw, could somebody tell me how to build my own kernel.
 
Old 11-26-2004, 12:06 PM   #7
hkb33
Member
 
Registered: Sep 2004
Location: Raleigh NC
Distribution: Fedora / RHEL
Posts: 171

Rep: Reputation: 30
don't try and build your own kernel if you've never done it before...practice on a test machine...if you screw it up, you could end up losing everything!

As far as improving boot time here are some suggestions:

1) Disable services you don't use:

Click Main Menu---->System Settings---->Server Settings---->Services

If you're running stuff like nfs, samba, vsftpd, httpd, etc. and you don't intend on using them then disable them.

One way to see what services are starting up is to click the details arrow while the system is booting..it will show you what services are starting up. That could be part of the delay.

2) Open the /etc/inittab file in your preferred text editor and locate the following section:

# Run gettys in standard runlevels
1:2345:respawn:/sbin/mingetty tty1
2:2345:respawn:/sbin/mingetty tty2
3:2345:respawn:/sbin/mingetty tty3
4:2345:respawn:/sbin/mingetty tty4
5:2345:respawn:/sbin/mingetty tty5
6:2345:respawn:/sbin/mingetty tty6

The above is all of the virutal terminals that your linux system is told to start at boot time. Each of these takes some time to start up during boot. Place the # character beside the last two or three lines...this will comment out those lines and the system won't try and start them up at boot. This could shave off a few seconds at boot time and also free up memory for other things.

...and I agree with seabass55...if you're going to base your decision on dumping linux based on the fact that Windows boots faster, then I don't think it's fair to do so.
 
Old 11-26-2004, 12:38 PM   #8
benjithegreat98
Senior Member
 
Registered: Dec 2003
Location: Shelbyville, TN, USA
Distribution: Fedora Core, CentOS
Posts: 1,019

Rep: Reputation: 45
A big thing you can do to cut down on your startup time is to disable the graphical boot. Have you done that yet? If you haven't let us know and we can tell you how to disable that.
 
Old 11-26-2004, 12:47 PM   #9
guzzi
Member
 
Registered: Jun 2004
Location: Lawrence, KS
Distribution: Slackware
Posts: 294

Rep: Reputation: 32
boot time

As a point of reference, running Slackware 10 2.4.26 on a P100 with 32M RAM.

From Lilo boot selection, to login prompt is 30 seconds.

This box is a NAT, router and firewall unit that goes straight to a command line prompt.
 
Old 11-26-2004, 02:20 PM   #10
sdat1333
Member
 
Registered: Nov 2004
Location: North Carolina, USA
Distribution: None right now :(
Posts: 149

Original Poster
Rep: Reputation: 15
1) Yah, you guys are right, its kind of unfair to judge linux against windows. I'm hoping that once I get linux tweaked to be just how I want it, then it will be much faster.

2)No, I haven't disabled graphical boot, how do I do that?

Thank you everybody for all your help.
 
Old 11-26-2004, 02:24 PM   #11
benjithegreat98
Senior Member
 
Registered: Dec 2003
Location: Shelbyville, TN, USA
Distribution: Fedora Core, CentOS
Posts: 1,019

Rep: Reputation: 45
As root, edit the /boot/grub/grub.conf or /etc/grub.conf (same file). This file controls which kernels or OS's are listed in grub when it starts up. On the lines that have kernel parameters there are places that say rhgb. I suppose that stands for redhat graphical boot. Remove that from the kernel lines. When you boot up, X will not load until right before you sign in.
 
Old 11-26-2004, 02:39 PM   #12
jolly1701
Member
 
Registered: Nov 2003
Location: England, UK.
Distribution: SuSE 10
Posts: 126

Rep: Reputation: 15
in the /boot/grub folder create a new folder
name it backup
copy & paste the grub.conf file to this new folder before playing with the grub.conf file

open grub.conf file in a text editer
set the delay time from 10 to 1

remove all the enterys below the last kernel image entery
so u only have the last image listed in the grub.conf file
save changes to the file

close down
now time your startup time...
 
Old 11-26-2004, 02:49 PM   #13
sdat1333
Member
 
Registered: Nov 2004
Location: North Carolina, USA
Distribution: None right now :(
Posts: 149

Original Poster
Rep: Reputation: 15
Jolly 1701, I didnt see your post until it was too late, but luckily, I only commented out 4 lines, so it should be easy to reverse. when the kernel is loading I get the following error: "kernel panic-not syncing; VFS: unable to mount root fs on unknown block(0,0). Pls help.
 
Old 11-26-2004, 02:56 PM   #14
benjithegreat98
Senior Member
 
Registered: Dec 2003
Location: Shelbyville, TN, USA
Distribution: Fedora Core, CentOS
Posts: 1,019

Rep: Reputation: 45
yikes....
Did you comment out the whole line or remove the single word rhgb? I re-read my post and I wasn't really clear on how to do it, I don't think.

Can you get into your system with the system restore disk (CD 5)? I've never used it so I don't know exactly how to use it. But anyways you need to use that or some type of rescue disk like that or Knoppix. You need to uncomment those lines and just remove the word rhgb.

If that was my fault due to not being clear, I apologize.

edit:
Here is a link to the disk 5 I mentioned if you don't have it:
http://download.fedora.redhat.com/pu...6-rescuecd.iso

Last edited by benjithegreat98; 11-26-2004 at 02:59 PM.
 
Old 11-26-2004, 03:51 PM   #15
sdat1333
Member
 
Registered: Nov 2004
Location: North Carolina, USA
Distribution: None right now :(
Posts: 149

Original Poster
Rep: Reputation: 15
Oh, OK. Not a problem. Luckily I have a knoppix CD on hand, so this shouldnt be a problem at all. I'll tell you how it goes.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Too slow any way to make it faster? Mr. New Linux - Newbie 12 12-29-2004 03:22 PM
How do I make SUSE load faster? sdat1333 Suse/Novell 7 12-13-2004 02:14 AM
How do make programs load faster? sdat1333 Fedora 8 11-27-2004 09:26 PM
Ability to load homepage faster tutwabee LQ Suggestions & Feedback 13 07-23-2004 01:30 PM
To load KDE much faster! wonderpun General 4 10-17-2002 03:33 PM


All times are GMT -5. The time now is 12:17 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration