LinuxQuestions.org
LinuxAnswers - the LQ Linux tutorial section.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Fedora
User Name
Password
Fedora This forum is for the discussion of the Fedora Project.

Notices

Reply
 
Search this Thread
Old 01-23-2009, 02:06 PM   #1
velska
Member
 
Registered: Aug 2003
Location: Finland
Distribution: Fedora 14, Ubuntu 10.4 LTS
Posts: 65

Rep: Reputation: 15
How do I get to choose my desktop manager?


I have read through my Fedora 10 documents, and I can't seem to be able to figure out exactly where it picks the display manager. So I have two questions:
  • Can I give gdm a configuration file to show alternatives like KDE to start instead of Gnome?
  • How can I start kdm or xdm instead of gdm?

There was a time when I thought I knew how Linux systems start up, but now I am a bit lost. Could be that I'm just tired.
 
Old 01-23-2009, 02:11 PM   #2
repo
LQ 5k Club
 
Registered: May 2001
Location: Belgium
Distribution: Linux Mint
Posts: 8,496

Rep: Reputation: 883Reputation: 883Reputation: 883Reputation: 883Reputation: 883Reputation: 883Reputation: 883
gdm will give you a list of installed window managers.
just click on session
 
Old 01-23-2009, 05:57 PM   #3
velska
Member
 
Registered: Aug 2003
Location: Finland
Distribution: Fedora 14, Ubuntu 10.4 LTS
Posts: 65

Original Poster
Rep: Reputation: 15
I know, but I don't have that...

Quote:
Originally Posted by repo View Post
gdm will give you a list of installed window managers.
just click on session
The trouble is, I was expecting to see the "session" button there (I installed both Gnome and KDE), but I don't see it. And I've been trying to figure out how to either configure gdm or alternatively try out kdm or xdm.
 
Old 01-23-2009, 08:32 PM   #4
digitelle
Member
 
Registered: Jan 2009
Posts: 57

Rep: Reputation: 16
I installed Fedora 10 from the live CD with KDE desktop as default, I wanted to check out gnome as well so I installed it, but it didn't show up in my session switcher on my login screen and I didn't want to bother with that, so these are the steps I took, only opposite because your default is going to look like my edited one, so my default one will be yours after editing..... yeah.

As root edit /etc/sysconfig/desktop (create this file if it doesn't already exist), to contain:
DESKTOP="KDE"
DISPLAYMANAGER="KDM"

Assuming you have everything needed for KDE installed, this should be the manual solution.

Something you may want to look at is Fedora's system-switch-displaymanager and switchdesk if you are looking as switching often.
 
Old 01-23-2009, 08:35 PM   #5
phantom_cyph
Senior Member
 
Registered: Feb 2007
Location: My HDD...
Distribution: WinXP for designing, Linux for life.
Posts: 2,329
Blog Entries: 1

Rep: Reputation: 47
run xwmconfig in a terminal.
 
Old 01-23-2009, 10:06 PM   #6
digitelle
Member
 
Registered: Jan 2009
Posts: 57

Rep: Reputation: 16
Just so we all know a bit more, xwmconfig is not packaged with Fedora or available from these yum repositories:

fedora
rpmfusion-free-updates
rpmfusion-nonfree-updates
rpmfusion-free
rpmfusion-nonfree

But could still be installed of course.
 
Old 01-24-2009, 05:14 PM   #7
velska
Member
 
Registered: Aug 2003
Location: Finland
Distribution: Fedora 14, Ubuntu 10.4 LTS
Posts: 65

Original Poster
Rep: Reputation: 15
Thanks

I guess I got it figured out now. It looked like the prefdm script didn't even find /etc/sysconfig/desktop, so I edited prefdm with some violence. Now it seems to work the way it's supposed to.

Last edited by velska; 01-25-2009 at 01:40 AM.
 
Old 01-25-2009, 01:23 PM   #8
this213
Member
 
Registered: Dec 2001
Location: ./
Distribution: Fedora, CentOS, RHEL, Gentoo
Posts: 167

Rep: Reputation: 34
"yum install switchdesk-gui" will give you a graphical method for doing this. However, I have it installed and don't see it in my menus so you may have to run "switchdesk" from a terminal (which is sort of stupid if you ask me).
 
Old 01-25-2009, 03:34 PM   #9
velska
Member
 
Registered: Aug 2003
Location: Finland
Distribution: Fedora 14, Ubuntu 10.4 LTS
Posts: 65

Original Poster
Rep: Reputation: 15
Switchdesk Doesn't Work

I have switchdesk, and switchdesk-gui. They do a crappy job of it.

As of now I am really wondering where all the configuration info is... prefdm still doesn't read /etc/sysconfig/desktop.

I wonder if there's a file format issue (some characters may be needed), but I haven't found the answer yet. Still looking
 
Old 01-25-2009, 04:21 PM   #10
this213
Member
 
Registered: Dec 2001
Location: ./
Distribution: Fedora, CentOS, RHEL, Gentoo
Posts: 167

Rep: Reputation: 34
Yeah, I was just looking at it and it's apparently not quite what it used to be. Sorry I can't be of more help as I have absolutely no use for KDE, but this might help you:

Quote:
Originally Posted by http://fedoraproject.org/wiki/KDE
To make KDM the default display manager, use your favourite package management tool (yum, kpackagekit) to install system-switch-displaymanager and run the system-switch-displaymanager kdm command.
I would imagine KDM would have an easier time of switching to KDE. I should note though that this really shouldn't be necessary, but I've been finding quite a bit in F10 that I don't agree with (NetworkManger, spacial view, and so on).
 
Old 01-25-2009, 06:07 PM   #11
digitelle
Member
 
Registered: Jan 2009
Posts: 57

Rep: Reputation: 16
What does your prefdm look like?
 
Old 01-26-2009, 05:04 AM   #12
velska
Member
 
Registered: Aug 2003
Location: Finland
Distribution: Fedora 14, Ubuntu 10.4 LTS
Posts: 65

Original Poster
Rep: Reputation: 15
About My prefdm

You asked what my prefdm script looks like. Here it is, it's not long:

Quote:
#!/bin/sh

PATH=/sbin:/usr/sbin:/bin:/usr/bin

# We need to source this so that the login screens get translated
[ -f /etc/sysconfig/i18n ] && . /etc/sysconfig/i18n

# Run preferred X display manager
quit_arg=
preferred=
if [ -f /etc/sysconfig/desktop ]; then
. /etc/sysconfig/desktop
if [ "$DISPLAYMANAGER" = GNOME ]; then
preferred=/usr/sbin/gdm
quit_arg="--retain-splash"
elif [ "$DISPLAYMANAGER" = KDE ]; then
preferred=/usr/bin/kdm
elif [ "$DISPLAYMANAGER" = WDM ]; then
preferred=/usr/bin/wdm
elif [ "$DISPLAYMANAGER" = XDM ]; then
preferred=/usr/bin/xdm
elif [ -n "$DISPLAYMANAGER" ]; then
preferred=$DISPLAYMANAGER
fi
else
quit_arg="--retain-splash"
fi

# shut down boot splash
/usr/bin/plymouth quit $quit_arg

shopt -s execfail

[ -n "$preferred" ] && exec $preferred "$@" >/dev/null 2>&1 </dev/null

# Fallbacks, in order
exec gdm "$@" >/dev/null 2>&1 </dev/null
exec kdm "$@" >/dev/null 2>&1 </dev/null
exec wdm "$@" >/dev/null 2>&1 </dev/null
exec xdm "$@" >/dev/null 2>&1 </dev/null
# catch all exit error
exit 1
Anyway what I did was just edit it to force kdm by commenting out everything from the "Run preferred X display manager" routine except the line that has the statement
preferred=/usr/bin/kdm
and that worked. The desktop switcher doesn't work.
 
Old 01-28-2009, 02:42 AM   #13
velska
Member
 
Registered: Aug 2003
Location: Finland
Distribution: Fedora 14, Ubuntu 10.4 LTS
Posts: 65

Original Poster
Rep: Reputation: 15
Thumbs up Display Manager Switching Tool

I found the tool that I refer to in the title (system-switch-displaymanager). It worked. I didn't find out how it performed its magic, but at least I'm working with kdm now, which gives me some options.
 
  


Reply

Tags
fedora, start


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Can't retain my resolution or choose my graphic manager in Slackware 12.1 gregorian Linux - Newbie 10 05-27-2008 12:34 AM
Is there any DM which choose only desktop environment? nadavvin Linux - Software 3 02-09-2007 02:13 PM
changing desktop manager and window manager Tux Red Hat 4 04-04-2006 01:56 PM
gdm: choose window manager wampfler Fedora 23 01-28-2004 12:41 PM
choose windows manager _ben_deb_ Linux - Newbie 4 06-12-2003 09:18 AM


All times are GMT -5. The time now is 11:04 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration